Bug 474049 - can't partition harddrive without passing 'nodmraid'
can't partition harddrive without passing 'nodmraid'
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 15:57 EST by Jelle Geerts
Modified: 2008-12-10 13:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 15:29:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jelle Geerts 2008-12-01 15:57:34 EST
Description of problem:
The Fedora installer does not allow me to partition my harddrives (two ATA drives).

The installer shows a device like /dev/mapper/nvidia_XXXXXXX (can't remember the XXXXXXX part, doesn't matter.) and it is 240 GB in size. That is the size of my two ATA drives combined (both are 120 GB).

I'm not using RAID, it's even disabled in the BIOS.

To fix the problem, I passed 'nodmraid' to the boot loader and then I could install Fedora.

How reproducible:
For me: just try to install Fedora using the DVD and you will stumble upon the problem.
  
Actual results:
Anaconda is not showing the correct information (I'm not using RAID and it thinks I am).

Expected results:
Just seeing my two harddrives in the setup so I can partition them separately.
Comment 1 Chris Lumens 2008-12-04 15:29:28 EST
Unfortunately, we have no way of knowing whether or not you have RAID enabled in your BIOS.  Since the RAID metadata exists on your disks, we have to assume that you've got it enabled and treat your disks like a RAID device.  The solution is to temporarily enable RAID in the BIOS, delete the RAID device, and then disable it again.  anaconda will then no longer assume you've got RAID active and give you the disks separately like you want.
Comment 2 Jelle Geerts 2008-12-04 16:20:16 EST
Yes, but shouldn't be there a way to tell anaconda that I really am not using RAID?
Comment 3 Chris Lumens 2008-12-04 16:26:58 EST
There is - the presence or absence of RAID metadata on the disks.
Comment 4 Jelle Geerts 2008-12-04 16:34:00 EST
Yes, but of course I mean to ask: Why can't the user override this from the setup?
Comment 5 Chris Lumens 2008-12-04 17:27:06 EST
Well, the "nodmraid" parameter is basically the way to override this.  Problem is, the presence of the RAID metadata means we really have to assume that the BIOS assembled a RAID device for us.  And there's no way to interface with the BIOS to determine this, or even to turn it on or off.  If we take the opposite approach and assume there's not a RAID device, then we're opening ourselves up to a whole other set of bugs where people don't get bootable machines because their BIOS sets up a RAID device, but anaconda did not treat it as such.  This is an area where we are trying to be very cautious.
Comment 6 Jelle Geerts 2008-12-04 17:31:46 EST
Though, after installing Fedora 10, the 'nodmraid' option is no longer needed to boot up the system. This means that in anaconda, I think it should be possible to override _manually_.

I'm not sure whether this is possible. Perhaps when the user says to anaconda "Don't use RAID" the dmraid module needs to be removed from the kernel at runtime?

Do the /dev/sda1 etc. devices even exist when the dmraid module is loaded?
Comment 7 Chris Lumens 2008-12-10 13:18:05 EST
Kernel developers recommend to never remove modules once they're loaded, so that's not really an option.

The device nodes are created as needed by HAL when kernel notifications are sent from the kernel, just as they would be on a running system.
Comment 8 Jelle Geerts 2008-12-10 13:43:58 EST
Okay, so if I get it right, the devices /dev/sd* are also created, along with the /dev/mapper/*devices.

Now, is it possible to let the user choose the devices for partitioning their disks (either with the /dev/mapper/* devices or /dev/sd*) in Anaconda?

That way my issue would be easily solvable in the next Fedora release (or perhaps a later version), I believe.

Note You need to log in before you can comment on or make changes to this bug.