Bug 474053 - Add -DCMAKE_VERBOSE_MAKEFILE=ON to %cmake
Add -DCMAKE_VERBOSE_MAKEFILE=ON to %cmake
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cmake (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 16:12 EST by Ville Skyttä
Modified: 2009-01-21 16:37 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 12:58:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use verbose makefiles by default (626 bytes, patch)
2008-12-01 16:12 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2008-12-01 16:12:46 EST
Created attachment 325298 [details]
Use verbose makefiles by default

I think the default %cmake macro should contain -DCMAKE_VERBOSE_MAKEFILE=ON.

"Silent" Makefiles cause problems with verifying that a build process does what we want which makes reviews harder (or the other way around, easier to miss things in package reviews).  For example desired C*FLAGS in effect, desired arguments to "install" etc.

I don't know why we'd want non-verbose Makefiles for rpm package builds, but if someone comes up with a reason, verbosity could be turned off with "%cmake -DCMAKE_VERBOSE_MAKEFILE=OFF".

(Cc'ing kde-filesystem maintainers - macros.kde4 has the same "problem".)
Comment 1 Ville Skyttä 2008-12-01 16:13:27 EST
(In reply to comment #0)
> I don't know why we'd want non-verbose Makefiles for rpm package builds, but if
> someone comes up with a reason, verbosity could be turned off with "%cmake
> -DCMAKE_VERBOSE_MAKEFILE=OFF".

...that on per-package basis in specfiles, that is.
Comment 2 Till Maas 2008-12-01 16:25:57 EST
I strongly agree that this should be made default, especially because the cmake guidelines[1] already tell to use "VERBOSE=1", which has probably the same effect. 

[1] https://fedoraproject.org/wiki/Packaging/cmake
Comment 3 Rex Dieter 2008-12-01 17:02:35 EST
totally +1.

Orion, any comment/objection?
Comment 4 Orion Poplawski 2008-12-02 12:15:33 EST
Sounds great to me (I use VERBOSE=1 myself everywhere).  Ville - can you push this through?  I'm very busy at the moment.
Comment 5 Rex Dieter 2008-12-02 12:29:27 EST
I'll take care of it.
Comment 6 Rex Dieter 2008-12-02 12:58:58 EST
fixed in rawhide.

We can let it stew awhile, and consider issuing updates for releases soonish.
Comment 7 Ville Skyttä 2008-12-02 14:02:04 EST
Thanks, Rex.  Do you plan to do this also to macros.kde4 in kde-filesystem?  Looks like it's not there in CVS yet.
Comment 8 Rex Dieter 2008-12-02 14:08:18 EST
yep.
Comment 9 Fedora Update System 2009-01-15 15:55:23 EST
cmake-2.6.2-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/cmake-2.6.2-3.fc9
Comment 10 Fedora Update System 2009-01-15 15:56:13 EST
cmake-2.6.2-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/cmake-2.6.2-3.fc10
Comment 11 Fedora Update System 2009-01-16 18:41:31 EST
cmake-2.6.2-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-01-21 16:37:03 EST
cmake-2.6.2-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.