Bug 474060 - mash mishandles exclusivearch on noarch packages
mash mishandles exclusivearch on noarch packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mash (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2008-12-01 17:26 EST by Jesse Keating
Modified: 2014-03-16 23:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 20:42:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for issue (1.38 KB, patch)
2008-12-01 20:06 EST, Jesse Keating
no flags Details | Diff

  None (edit)
Description Jesse Keating 2008-12-01 17:26:48 EST
When filtering out noarch packages based on ExcludeArch or ExclusiveArch, mash mishandles the ExclusiveArch case, because 'noarch' is one of the arches in ExclusiveArch in order for the package to build.  I'm looking at a way to patch this, but for now I wanted to get the bug filed.
Comment 1 Jesse Keating 2008-12-01 17:35:02 EST
Ah, right, case in point is the ipw2100-firmware and ipw2200-firmware packages.  They are noarch, and have ExclusiveArch i386 x86_64 ppc noarch or some such.  They are winding up in the ppc(64) directories when they shouldn't.
Comment 2 Jesse Keating 2008-12-01 20:06:35 EST
Created attachment 325322 [details]
Patch for issue
Comment 3 Bill Nottingham 2008-12-01 22:53:45 EST
Added to git. Is this causing significant compose issues that require a respin now?
Comment 4 Jesse Keating 2008-12-02 00:34:03 EST
I don't believe so.  The only packages catching this now are the ipw2?00-firmware packages.  appliance-tools was triggering it, and led to my initial investigation, but that one is being fixed with ExcludeArch vs ExclusiveArch.
Comment 5 Jesse Keating 2009-04-13 20:42:56 EDT
I do believe this has been built for rawhide.

Note You need to log in before you can comment on or make changes to this bug.