Bug 474070 - Request to downgrade OpenSync to 0.22 for F9/10/rawhide
Request to downgrade OpenSync to 0.22 for F9/10/rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libopensync (Show other bugs)
rawhide
All Linux
urgent Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 18:32 EST by Christopher D. Stover
Modified: 2009-03-27 15:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: libopensync-0.22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-27 15:32:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher D. Stover 2008-12-01 18:32:09 EST
I packaged barry, a desktop toolset for managing your BlackBerry device, which uses OpenSync.  However, it's not compatible with the newer version of OpenSync so F9/10 users are unable to sync their Blackberries.

The OpenSync website states the following: 0.3x releases are not recommended for end users or distribution packaging.  I've also brought this issue upstream and I've included the response I received below.

I'm not sure what other packages are using OpenSync but I propose we downgrade to 0.22, if possible, until a stable higher version is released.  Your thoughts on this would be appreciated.  Thank you.

>> Are there any plans to implement a newer version of libopensync since
>> FC doesn't support 0.22?
>
> opensync 0.3 is a very bad idea to include in a distribution, because it
> doesn't work. The opensync maintainers expressly say it should not be
> included in distributions, right on the opensync home page. If you want
> to have any hope of having synchronization of just about anything
> actually *work*, you should convince the FC guys to downgrade to
> opensync 0.22 until 0.3 / 0.4 is actually usable.
>
> We had the same issue on Mandriva. Someone blindly bumped opensync from
> 0.22 to 0.3 without bothering to test whether it was actually at all
> usable. I came along, tried to actually get synchronization to work, and
> found it was completely impossible, so I had to spend several days
> downgrading all the packages. Then thing started to work.
Comment 1 l ciani 2009-01-31 18:56:06 EST
May I just add that since Fedora 10/opensync0.3, opensync does not sync KDEPIM contacts/calendar with mobile phones.

If going back to opensync0.2 fixes that, than I would welcome the downgrade until opensync reaches a stage (possibly 0.4) where its developers say that it's OK to be packaged in a distribution.
Comment 2 Christopher D. Stover 2009-03-02 13:42:48 EST
Another possibility -- Can we package libopensync-0.4x?  They have a development version out that the barry mailing list is moving to.
Comment 3 Andreas Bierfert 2009-03-03 04:16:53 EST
We will be going for 0.22 downgrade till 0.4x is really ready. Should happen in the next days.
Comment 4 Dave Allan 2009-03-12 15:22:42 EDT
Sounds good--doesn't look like anybody could really be using 0.3, so the new APIs in 0.4x will break all the consumers until they update.

Note You need to log in before you can comment on or make changes to this bug.