Bug 474083 - gmp spec needs autoconf on s390x
gmp spec needs autoconf on s390x
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gmp (Show other bugs)
10
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2008-12-01 21:19 EST by Brad Hinson
Modified: 2008-12-03 06:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 06:46:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add autoconf in %prep (125 bytes, patch)
2008-12-01 21:19 EST, Brad Hinson
no flags Details | Diff

  None (edit)
Description Brad Hinson 2008-12-01 21:19:38 EST
Created attachment 325325 [details]
Add autoconf in %prep

Description of problem:
During rpmbuild on s390x, ./configure fails with:

[snip]
checking size of mp_limb_t... 8
configure: error: Oops, mp_limb_t is 64 bits, but the assembler code
in this configuration expects 32 bits.
You appear to have set $CFLAGS, perhaps you also need to tell GMP the
intended ABI, see "ABI and ISA" in the manual.

This is solved by adding 'autoconf' in spec in %prep (see attached spec file patch).

Version-Release number of selected component (if applicable):
gmp-4.2.2-8.fc10
Comment 1 Stepan Kasal 2008-12-03 06:46:42 EST
Running autoconf without aclocal and automake can break things.
You have to run "aclocal && autoconf && automake -i" or you can use
"autoreconf --install --force"
which calls all of them and then "libtool --force".

And it is more decent to do this in %build then in % prep, since the CPU requirements of these tools are much higher than for unpacking the tarball and applying the patches.

Fixed in gmp-4.2.4-2.

Note You need to log in before you can comment on or make changes to this bug.