This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 474105 - [or_IN] iswpunct, iswdigit, iswalpha returns wrong values for oriya characters
[or_IN] iswpunct, iswdigit, iswalpha returns wrong values for oriya characters
Status: CLOSED DUPLICATE of bug 466912
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 03:46 EST by Pravin Satpute
Modified: 2008-12-31 00:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-31 00:43:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output showing return values of funtions listed in bug (1.49 KB, text/plain)
2008-12-02 03:46 EST, Pravin Satpute
no flags Details

  None (edit)
Description Pravin Satpute 2008-12-02 03:46:29 EST
Created attachment 325341 [details]
output showing return values of funtions listed in bug 

Description of problem:
please see https://bugzilla.redhat.com/show_bug.cgi?id=466912 for more info

Version-Release number of selected component (if applicable):
glibc-2.9-2

How reproducible:
everytime

Steps to Reproduce:
1.
2.
3.

Actual results:
please see attached file

Expected results:


Additional info:
i have attached output of above functions, please let me know which characters
should come under which group, so we can fix this
Comment 1 Ankit Patel 2008-12-02 04:27:57 EST
Hi Manoj,

Can you please provide your feedback to Pravin?

Ankit
Comment 2 Manoj Kumar Giri 2008-12-02 13:47:20 EST
Hi Pravin,

        After going through it i found some mismatch in the character & character class which i'm listing below:

From ଅ-ହ: It should come under only ALPHA category not in ALNUM.
From ୦-୯: It should come under only DIGIT category not in ALNUM.
ଡ଼,ଢ଼,ୟ,ଋ,ୡ and ୱ: It should come under only ALPHA category not in ALNUM.

Thanks & Regards
Manoj
Comment 3 Pravin Satpute 2008-12-31 00:41:56 EST
Thanks Manoj for your inputs
Comment 4 Pravin Satpute 2008-12-31 00:43:02 EST
This bug was opened for language specific information and testing, all the work and discussion happened on bug 466912, patch is now upstreamed.
closing as a duplicate of 466912

*** This bug has been marked as a duplicate of bug 466912 ***

Note You need to log in before you can comment on or make changes to this bug.