Bug 474107 - [te_IN] iswpunct, iswdigit, iswalpha returns wrong values for Telugu characters
[te_IN] iswpunct, iswdigit, iswalpha returns wrong values for Telugu characters
Status: CLOSED DUPLICATE of bug 466912
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 04:04 EST by Pravin Satpute
Modified: 2008-12-31 00:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-31 00:43:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output showing return values of funtions listed in bug ( (1.47 KB, text/plain)
2008-12-02 04:04 EST, Pravin Satpute
no flags Details

  None (edit)
Description Pravin Satpute 2008-12-02 04:04:05 EST
Created attachment 325342 [details]
 output showing return values of funtions listed in bug   (

Description of problem:
please see https://bugzilla.redhat.com/show_bug.cgi?id=466912 for more info

Version-Release number of selected component (if applicable):
glibc-2.9-2

How reproducible:
everytime

Steps to Reproduce:
1.
2.
3.

Actual results:
please see attached file

Expected results:


Additional info:
i have attached output of above functions, please let me know which characters
should come under which group, so we can fix this
Comment 1 Ankit Patel 2008-12-02 04:28:11 EST
Hi Krishnababu,

Can you please provide your feedback to Pravin?

Ankit
Comment 2 Krishna Babu K 2008-12-02 06:32:50 EST
Hi,

According to the attachment (id=325342) these are my inputs:

i) The characters [ఁ-0C01, ం-0C02, ః-0C03] should come under ALPHA column, currently are under PUNCT column.
ii) These characters also [ా-0C3E, ి-0C3F, ీ-0C40, ు-0C41, ూ-0C42, ృ-0C43, ౄ-0C44, ె-0C46, ే-0C47, ై-0C48, ొ-OC4A, ో-0C4B, ౌ-0C4C, ్-0C4D, ౕ-0C55, ౖ-0C56] should come under ALPHA column,currently are under PUNCT column.
iii) These telugu digits [౦-0C66, ౧-0C67, ౨-0C68, ౩-0C69, ౪-0C6A, ౫-0C6B, ౬-0C6C, ౭-0C6D, ౮-0C6E, ౯-0C6F] should come under DIGIT column, currently are under ALPHA column.

Thanks,
Krishnababu.
Comment 3 Pravin Satpute 2008-12-02 07:37:52 EST
krishnababu thanks for input
i will start working on this now
Comment 4 Pravin Satpute 2008-12-31 00:43:47 EST
This bug was opened for language specific information and testing, all the work and discussion happened on bug 466912, patch is now upstreamed.
closing as a duplicate of 466912

*** This bug has been marked as a duplicate of bug 466912 ***

Note You need to log in before you can comment on or make changes to this bug.