Bug 474113 - Enhancement Request: access log configuration - Log Level Box / chooser
Enhancement Request: access log configuration - Log Level Box / chooser
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Console (Show other bugs)
1.1.3
All Linux
low Severity low
: ---
: ---
Assigned To: Nathan Kinder
Viktor Ashirov
:
Depends On:
Blocks: 434915 389_1.3.0
  Show dependency treegraph
 
Reported: 2008-12-02 05:07 EST by Lutz Lange
Modified: 2015-12-07 11:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:43:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (6.93 KB, patch)
2011-03-07 13:34 EST, Nathan Kinder
nkinder: review?
rmeggins: review+
nhosoi: review+
Details | Diff

  None (edit)
Description Lutz Lange 2008-12-02 05:07:44 EST
See Directory Server -> Configuration Tab -> Logs -> Error Log
 - look at the pane on the right hand side, you might need to scroll down
 - find the Log Level chooser box
--> this is great since i can chose log options graphically instead of calculation decimal numbers, to set the right bits

Now see Directory Server -> Configuration Tab -> Logs -> Access Log
 - look at the pane on the right hand side, there is no Log Level Chooser for the access log. 

This is sad. It would be a valuable improvement.
 
Suggested Action:
 - provide a Log Level chooser for the Access Log configuration as well
Comment 1 Rich Megginson 2008-12-02 10:11:26 EST
There are only one or two log levels for the access log, and they are mostly of interest only to developers.
Comment 2 Lutz Lange 2008-12-02 12:01:51 EST
My information says its four values:

0      No information is logged
4      Log internal access operations
256    Connections, operations, and accesses to an entry (default)
512    Accesses to entries, referrals, and results
131072 Precise (microsecond) timing of operation duration

not as much as with the error log, but it might be nice anyway have the choice...
Comment 4 Nathan Kinder 2011-03-07 13:34:48 EST
Created attachment 482764 [details]
Patch
Comment 5 Nathan Kinder 2011-03-07 13:55:33 EST
Pushed to master.  Thanks to Noriko and Rich for their reviews!

Counting objects: 28, done.
Delta compression using up to 2 threads.
Compressing objects: 100% (11/11), done.
Writing objects: 100% (15/15), 3.74 KiB, done.
Total 15 (delta 8), reused 0 (delta 0)
To ssh://git.fedorahosted.org/git/389/ds-console.git
   2ada9d0..c8566da  master -> master
Comment 7 Amita Sharma 2011-07-29 06:49:11 EDT
Yes, I could change it to any of the four Access log levels listed in DS console-
So marking the bug as VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.