Bug 474117 - [gu_IN] iswpunct, iswdigit, iswalpha returns wrong values for gujarati characters
[gu_IN] iswpunct, iswdigit, iswalpha returns wrong values for gujarati charac...
Status: CLOSED DUPLICATE of bug 466912
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 05:32 EST by Pravin Satpute
Modified: 2008-12-31 00:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-31 00:44:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output showing return values of funtions listed in bug (1.42 KB, text/plain)
2008-12-02 05:32 EST, Pravin Satpute
no flags Details
output showing return values of funtions listed in bug (1.52 KB, text/plain)
2008-12-02 05:48 EST, Pravin Satpute
no flags Details

  None (edit)
Description Pravin Satpute 2008-12-02 05:32:34 EST
Created attachment 325351 [details]
output showing return values of funtions listed in bug 

Description of problem:
please see https://bugzilla.redhat.com/show_bug.cgi?id=466912 for more info

Version-Release number of selected component (if applicable):
glibc-2.9-2

How reproducible:
everytime

Steps to Reproduce:
1.
2.
3.

Actual results:
please see attached file

Expected results:


Additional info:
i have attached output of above functions, please let me know which characters
should come under which group, so we can fix this
Comment 1 Ankit Patel 2008-12-02 05:40:20 EST
Sweta,

Can you please provide your feedback to Pravin?

Ankit
Comment 2 Pravin Satpute 2008-12-02 05:48:33 EST
Created attachment 325354 [details]
output showing return values of funtions listed in bug 

mistakenly submitted gurumukhi text file
Comment 3 Sweta Kothari 2008-12-02 07:00:35 EST
Hi,
  
  this is feedback from gu-IN

1) ઁ ં ઃ 
    These  characters should be come under ALPHA.
2)઼ ા િ ી ુ ૂ ૃ ૄ ૅ ે ૈ ૉ ો ૌ ્ ૱
    These characters should be come under ALPHA.
3)૦ ૧ ૨ ૩ ૪ ૫ ૬ ૭ ૮ ૯
    These digits should be come under DIGIT.
Comment 4 Sweta Kothari 2008-12-02 07:13:29 EST
i forgot to commit other characters

4)ૐ	 ૠ	ૡ	ૢ	ૢ
   these characters should be come under ALPHA.
Comment 5 Pravin Satpute 2008-12-02 07:18:55 EST
sweta thanks for inputs
i will try to fix this soon
Comment 6 Pravin Satpute 2008-12-31 00:44:45 EST
This bug was opened for language specific information and testing, all the work and discussion happened on bug 466912, patch is now upstreamed.
closing as a duplicate of 466912

*** This bug has been marked as a duplicate of bug 466912 ***

Note You need to log in before you can comment on or make changes to this bug.