Bug 474122 - kernel panic in Fedora x86_64 installer (DVD/netinst) on Dell Optiplex 740
kernel panic in Fedora x86_64 installer (DVD/netinst) on Dell Optiplex 740
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 05:50 EST by Nandan Bhat
Modified: 2010-01-12 10:31 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-12 10:31:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Archive having installer log files of Fedora 9 x86_64 (13.36 KB, application/x-bzip)
2008-12-07 00:15 EST, Nandan Bhat
no flags Details
Archive having installer log files of Fedora 10 i686 (11.88 KB, application/x-bzip)
2008-12-07 00:16 EST, Nandan Bhat
no flags Details
Boot messages for Fedora 10 x86_64 DVD on Dell Optiplex 740 (18.19 KB, application/octet-stream)
2008-12-22 21:02 EST, Nandan Bhat
no flags Details
Fedora 12 Alpha anaconda logs. (23.78 KB, application/octet-stream)
2009-10-10 14:27 EDT, toddb
no flags Details

  None (edit)
Description Nandan Bhat 2008-12-02 05:50:34 EST
Description of problem: Fedora x86_64 DVD or netinst installer versions have kernel panic on Dell Optiplex 740


Version-Release number of selected component (if applicable): 10


How reproducible: Every time


Steps to Reproduce:
1. Start installation with Fedora x86_64 DVD or netinst CD
2. Observe kernel panic before any user prompts
3.
  
Actual results:
kernel panic before any user prompts

Expected results:
installer progress to media check prompt
Additional info:
last lines on screen indicating the problem; sorry, don't know how to record the messages given as output by the installer.

--- start kernel panic message lines
RAMDISK: Couldn't find valid RAM disk image starting at 0.
EXT3-fs: unable to read superblock
isofs_fill_super: bread failed, dev=md2, iso_blknum=16, block=32
List of all partitions:
No filesystem could mount root, tried: ext3 iso9660
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(9,2)
--- end kernel panic message lines
Comment 1 Chris Lumens 2008-12-04 16:33:14 EST
Looks like your initrd was incorrectly constructed.  Can you attach /var/log/anaconda.log to this bug report?
Comment 2 Nandan Bhat 2008-12-05 00:34:36 EST
I could use some help in getting this log file. Any pointer URLs are also welcome.

As of now, the system has a kernel panic before I can do anything. Maybe some option I need to supply in the form of "linux askmethod ...". 

I tried the option of vga=1, but that only changes the number of visible lines.

Some other mailing list chatter was involving the invoking of dev=md2, though I have no idea about its relevance.
Comment 3 Chris Lumens 2008-12-05 10:11:49 EST
Since you've already got an install done, you could boot up anaconda in rescue mode, have it mount your existing partitions, and then grab log files out of there.
Comment 4 Nandan Bhat 2008-12-07 00:15:20 EST
Created attachment 326034 [details]
Archive having installer log files of Fedora 9 x86_64
Comment 5 Nandan Bhat 2008-12-07 00:16:11 EST
Created attachment 326035 [details]
Archive having installer log files of Fedora 10 i686
Comment 6 Nandan Bhat 2008-12-07 00:20:58 EST
I should probably clarify that F10.x86_64 installer never makes it beyond the first scroll of lines and then encounters a kernel panic, even in Rescue Mode.

I have attached the log files of the F9.x86_64 installation and the F10.i686 installation on the same machine.

If you could tell me a way of capturing the initial text output of the F10 x86_64 installer, I will get back with the result.
Comment 7 Nandan Bhat 2008-12-22 21:02:27 EST
Created attachment 327723 [details]
Boot messages for Fedora 10 x86_64 DVD on Dell Optiplex 740

I am sorry it took so long, but I am not a fast typist.
Comment 8 Nandan Bhat 2009-01-21 06:11:13 EST
This may be an irrelevant comment, but I now have Fedora 10 x86_64 on the Dell Optiplex. The route adopted was

$sudo yum update

While the original problem remains unsolved, I guess I am no longer desperately seeking a solution.

Cheers
Comment 9 Nandan Bhat 2009-03-09 11:01:11 EDT
Curious workaround

I was able to use the method at 
http://fedora.co.in/content/how-install-fedora-without-cd-dvd-or-any-optical-media 
although I did use the DVD.

I already had the i686 version installed. I placed the vmlinuz and initrd.img files in the i686 /boot directory. During GRUB boot screen, I booted using the command line (c).

grub> kernel (hd1,4)/boot/vmlinuz-f10
grub> initrd (hd1,4)/boot/initrd-f10.img
grub> boot

... and it worked!
Comment 10 Mark Watts 2009-03-13 16:05:02 EDT
I see the original problem (kernel panic) when trying to boot-up the Fedora 10 x86_64 installer on my Dell XPS 630.

In this case, I do not have an existing Linux installation to work from - I'm trying to dual-boot with Windows using a separate disk for Linux.
Comment 11 Mark Watts 2009-03-16 05:21:50 EDT
After a lot of fiddling, including trying a PXE boot, I've "discovered" that the x86_64 LiveCD, booted from a USB stick works perfectly.
The install-to-disk option worked and I'm now running F10 with full updates.

Looks like theres something different between the install DVD's and the LiveCD
Comment 12 Richard Underwood 2009-06-12 04:24:58 EDT
I'm having almost exactly the same problem installing Fedora 11 on a Dell Latitude D420 using a USB DVD drive. I've tried both the live and netinst CDs, both give the same error. I've not tried the full install DVD yet.

md: Autodetecting RAID arrays.
md: Scanned 0 and added 0 devices.
md: autorun ...
md: ... autorun DONE.
RAMDISK: Compressed image found at block 0
usb 2-2: new full speed USB device using uhci_hcd at address 2
usb 2-2: New USB device found, idVendor=413c, idProduct=a005
usb 2-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
usb 2-2: configuration #1 chosen from 1 choice
hub 2-2:1.0: USB hub found
hub 2-2:1.0: 4 ports detected
invalid compressed format (err=2)
EXT3-fs: unable to read superblock
EXT4-fs: unable to read superblock
EXT4-fs: Update your userspace programs to mount using ext4
EXT4-fs: ext4dev backwards compatibility will go away by 2.6.31
EXT4-fs: unable to read superblock
isofs_fill_super: bread failed, dev=md2, iso_blknum=16, block=32
List of all partitions:
0800        58605120 sda driver: sd
  0801          204800 sda1
  0802        58400319 sda2
No filesystem could mount root, tried:  ext3 ext4 ext4dev iso9660
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(9,2)

I've tried two different DVD drives, and both give the same problem. Oddly, the laptop already has the F11 preview on it, so it has worked previously.
Comment 13 Richard Underwood 2009-06-12 09:42:22 EDT
I've just tried with Fedora-11-i386-DVD.iso, and that works. It's only the live and netinst images which are failing.
Comment 14 Nandan Bhat 2009-06-29 02:46:31 EDT
Kernel panic on Fedora 11 x86_64 DVD on Dell Optiplex 740

I just wanted to update that the kernel panic is seen even in the above condition. 

My workaround by placing the DVD's vmlinuz and initrd.img in boot directory of existing installation and creating a GRUB entry works as before. I was able to install Fedora 11 x86_64 DVD using this method.
Comment 15 HongWei Guo 2009-08-03 22:03:40 EDT
yesterday, I have this issue, I can't start the live cd even.
and after the service atd start, it happened.
and so,  anybody try to fixed this issue?

thanks

HongWei Guo
Comment 16 John Griffin 2009-08-18 12:35:18 EDT
Exactly the same problem here with a Dell Optiplex 740. Used work around in Comment #14 but have to build the system from scratch now.
Comment 17 rosemont 2009-09-12 22:56:08 EDT
DELL XPS 630 same problem.  Trying to install X86_64 net installer from CD but failed at: Couldn't Find Valid RAM Disk Image Starting at 0.
Comment 18 toddb 2009-10-10 14:27:59 EDT
Created attachment 364349 [details]
Fedora 12 Alpha anaconda logs.

I, too, have gotten the same kernel panic: 'Unable to mount root fs on unknown-block(0,0)'

For me this happens immediately after installing from scratch, Fedora 12 Alpha from dvd. The only changes I made during the installation were:
 - remove the LVM and use simple partitions (this is a new, small machine, with a laptop drive, and no expansion planned)
 - specify that the intended use included development and web server (mythtv, specifically)
 - check the box next to rawhide repo.

Installation was fine, but booting the installed system only ever results in the panic. The anaconda logs are attached. I try some other things, but may have to resort to installing Fedora 11 and then upgrading. Hardware is:
 - Foxconn G45 motherboard
 - e5200 processor
 - 2GB mem
 - Hitachi 80GB sata laptop drive
 - Sony DVD reader
Comment 19 toddb 2009-10-10 14:39:40 EDT
I reinstalled with a few changes, and the system now boots fine. Specifically,
 - I still removed the LVM, but when adding the simple partitions, I did mark the root partition as "force as primary partition".
 - I left the installation specified as a desktop (no dev or web server)
 - I did not request additional installs from the rawhide repo.

I'd have to conclude that it is most likely that the check mark next to the "force primary partition" did the trick.
Comment 20 Bug Zapper 2009-11-18 05:16:02 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 21 Hans de Goede 2010-01-12 10:31:22 EST
This is a mass edit of all mkinitrd bugs.

Thanks for taking the time to file this bug report (and/or commenting on it).

As you may have heard in Fedora 12 mkinitrd has been replaced by dracut. In Fedora 12 the mkinitrd package is still around as some programs depend on
certain libraries it provides, but mkinitrd itself is no longer used.

In Fedora 13 mkinitrd will be removed completely. This means that all work
on initrd has stopped.

Rather then keeping mkinitrd bugs open and giving false hope they might get fixed we are mass closing them, so as to clearly communicate that no more work will be done on mkinitrd. We apologize for any inconvenience this may cause. 

If you are using Fedora 11 and are experiencing a mkinitrd bug you cannot work around, please upgrade to Fedora 12. If you experience problems with the initrd in Fedora 12, please file a bug against dracut.

Note You need to log in before you can comment on or make changes to this bug.