Bug 474124 - [ml_IN] iswpunct, iswdigit, iswalpha returns wrong values for malayalam characters
Summary: [ml_IN] iswpunct, iswdigit, iswalpha returns wrong values for malayalam chara...
Status: CLOSED DUPLICATE of bug 466912
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-12-02 11:02 UTC by Pravin Satpute
Modified: 2008-12-31 05:47 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-31 05:47:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output showing return values of funtions listed in bug (1.44 KB, text/plain)
2008-12-02 11:02 UTC, Pravin Satpute
no flags Details
Attachment showing the alpha, digit, alphanumeric categories (1.44 KB, text/plain)
2008-12-04 16:48 UTC, Santhosh Thottingal
no flags Details

Description Pravin Satpute 2008-12-02 11:02:27 UTC
Created attachment 325357 [details]
output showing return values of funtions listed in bug  

Description of problem:
please see https://bugzilla.redhat.com/show_bug.cgi?id=466912 for more info

Version-Release number of selected component (if applicable):
glibc-2.9-2

How reproducible:
everytime

Steps to Reproduce:
1.
2.
3.

Actual results:
please see attached file

Expected results:


Additional info:
i have attached output of above functions, please let me know which characters
should come under which group, so we can fix this

Comment 1 Santhosh Thottingal 2008-12-04 16:48:53 UTC
Created attachment 325704 [details]
Attachment showing the alpha, digit, alphanumeric categories 

Attached a table showing which characters are digits, letters etc. Please use this table for testing.
All letters in the table should produce 'true' for isalnum.
All matra signs are alphabets. Malayalam numbers are given as digit category.

Comment 2 Pravin Satpute 2008-12-31 05:47:31 UTC
Thanks for you input
This bug was opened for language specific information and testing, all the work and discussion happened on bug 466912, patch is now upstreamed.
closing as a duplicate of 466912

feel free to reopen if any problem

*** This bug has been marked as a duplicate of bug 466912 ***


Note You need to log in before you can comment on or make changes to this bug.