Bug 474125 - Plymouth Assertion ply-image.c: 118
Plymouth Assertion ply-image.c: 118
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 06:11 EST by John R. Deal Jr.
Modified: 2008-12-04 15:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 15:38:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John R. Deal Jr. 2008-12-02 06:11:11 EST
Description of problem:
After updating from F10 Beta+ to Linux localhost.localdomain 2.6.27.5-117.fc10.i686 #1 SMP Tue Nov 18 12:19:59 EST 2008 i686 i686 i386 GNU/Linux on 12.01.2008 on a IBM NetVista desktop (1.8 GHz Pentium IV 1.2 GB RAM) I get assertion error from Plymouth on boot.  The assertion seems to be at ply-image.c: 118 as this is displayed on the console.

The system seems to boot fine and so far have not discovered any problems.

Version-Release number of selected component (if applicable):

plymouth.i386 0.6.0-0.2008.11.17.3.fc11

How reproducible:

boot the system.  The offending system has init level 5 set.

Steps to Reproduce:
1. Update to Linux localhost.localdomain 2.6.27.5-117.fc10.i686 #1 SMP Tue Nov 18 12:19:59 EST 2008 i686 i686 i386 GNU/Linux

2. Reboot the system.
3.
  
Actual results:

Get assertion error at ply-image.c:118

Expected results:

No assertion error.

Additional info:

Running: Linux localhost.localdomain 2.6.27.5-117.fc10.i686 #1 SMP Tue Nov 18 12:19:59 EST 2008 i686 i686 i386 GNU/Linux on IBM NetVista desktop with 1.2 GB RAM.  Seems to run fine after boot.
Comment 1 Charlie Brej 2008-12-02 06:52:44 EST
Thanks for submitting the bug. Is this on the solar theme plugin? Does the graphical theme actually show fine all the way though to gdm or does it just drop to text at the very beginning? What happens if you press Esc a couple times during the boot?

(Ray: This is ply_image_free (ply_image_t *image) called with image = NULL which should probably be allowed but I cant figure out how it managed to happen)
Comment 2 John R. Deal Jr. 2008-12-02 08:29:22 EST
I don't know what you mean by "graphical theme" but I get the progress bar at the bottom of the screen (same as F10 alpha) and hit <esc> to get messages.  The first thing that is displayed is the path for the key mapping.  Then the ply-image.c:118 assertion error.  Then after approx. 15 second delay I get a udev video unknown error (forgot to report that sorry!) then normal messages with no failures.  I hit <esc> several times after the  first <esc> and other than echoing a couple of times it does not effect anything.  As stated earlier, the system seems to come up fine and so far no problems.

Please let me know what else you need me to do to solve this.
Comment 3 Ray Strode [halfline] 2008-12-02 11:43:14 EST
We have a patch for this on the F-10 branch, and in git.  It's not in rawhide yet, but will land next time we roll a new build.
Comment 4 Ray Strode [halfline] 2008-12-04 15:38:37 EST
this is in rawhide now.

Note You need to log in before you can comment on or make changes to this bug.