Bug 474138 - internal-error in get_depends for a group (yumBackend)
internal-error in get_depends for a group (yumBackend)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 07:57 EST by Michal Schmidt
Modified: 2009-01-14 08:31 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 08:31:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
excerpt from PackageKit log (22.76 KB, text/plain)
2008-12-02 08:00 EST, Michal Schmidt
no flags Details
patch to fix get_depends on a group (567 bytes, patch)
2008-12-02 08:04 EST, Michal Schmidt
no flags Details | Diff
what's in git (828 bytes, patch)
2008-12-02 08:26 EST, Richard Hughes
no flags Details | Diff

  None (edit)
Description Michal Schmidt 2008-12-02 07:57:54 EST
Description of problem:
An internal error happens when trying to install a package group. 

Version-Release number of selected component (if applicable):
PackageKit-glib-0.3.11-3.fc10.x86_64
PackageKit-0.3.11-3.fc10.x86_64
PackageKit-udev-helper-0.3.11-3.fc10.x86_64
PackageKit-yum-plugin-0.3.11-3.fc10.x86_64
gnome-packagekit-0.3.11-3.fc10.x86_64
PackageKit-yum-0.3.11-3.fc10.x86_64

How reproducible:
always

Steps to Reproduce:
1. run gpk-application
2. in Package Collections select a previously uninstalled group (in my case it was development-tools)
3. click Apply
  
Actual results:
The group installs, but an internal error can be seen in the log.

Expected results:
Internal errors should never happen.

Additional info:
I'll attach a log and a patch.
The reason I looked in the log was that a friend of mine reported problems with installation of groups (PK was forever in the state of "waiting for other actions to finish"). Though I can't reproduce his problem, I suspect the internal error could be related.
Comment 1 Michal Schmidt 2008-12-02 08:00:22 EST
Created attachment 325368 [details]
excerpt from PackageKit log

Scroll to the end to see the traceback.

Also notice lots of suspicious messages like:
invalid command 'Package gcc-4.3.2-7.x86_64 already installed and latest version'
Comment 2 Michal Schmidt 2008-12-02 08:04:49 EST
Created attachment 325369 [details]
patch to fix get_depends on a group

Fix an internal error when get_depends is called on a group. self._findPackage() returns None for groups, so we can't remove that from the deps_list.

With this patch, gpk-application's behaviour changes a bit. Before it installs the group, it now lists the packages it is going to need and asks for confirmation. It seems to me like the correct behaviour.
Comment 3 Richard Hughes 2008-12-02 08:26:06 EST
Created attachment 325370 [details]
what's in git

I've applied this very similar patch as it's the same as other parts of that file. The new behaviour was the intended behaviour, so I don't think that's a regression. Thanks for your help debugging this.

Note You need to log in before you can comment on or make changes to this bug.