Bug 474143 - openbox-gnome-session not available at login-screen
openbox-gnome-session not available at login-screen
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openbox (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 08:44 EST by Daniel Laczi
Modified: 2008-12-13 10:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-13 10:03:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 555406 None None None Never

  None (edit)
Description Daniel Laczi 2008-12-02 08:44:38 EST
Description of problem:
The openbox-gnome-session (gnome/openbox) is not available at the login-screen. I just can select "gnome" or "openbox".

Version-Release number of selected component (if applicable):
I have done an Fedora 10 installation with the standard gnomepackets and afterwards installed openbox.

Expected results:
I think you should be able to login openbox-gnome-session by selecting it at the login-screen.

Additional info:
I'm not familiar with these things. I createt a "autostart.h" in ~.config/openbox with the contents below, to workaround this problem. Don't know if it is a good solution, but perhaps it will help someone else.

# Run the system-wide support stuff
. $GLOBALAUTOSTART

# Programs that will run after Openbox has started
(sleep 2 && gnome-session) &
Comment 1 Miroslav Lichvar 2008-12-02 08:52:20 EST
The script was dropped as gnome-session no longer supports WINDOW_MANAGER variable.

Reassigning to gnome-session.
Comment 2 Ray Strode [halfline] 2008-12-02 13:23:10 EST
I think the way this works (Jon correct me if I'm wrong) is:

1) openbox should put in the desktop file 

X-GNOME-Provides=windowmanager

This tells gnome-session that it satisfies the "windowmanager" component requirement.

2) invoke gnome-session with different default-session using the --default-session-key argument.  This is the list of things to start automatically and is normally just [gnome-settings-daemon].  This list doesn't normally include the required components (windowmanager, filemanager, and panel), since defaults for these are implicitly added if an override isn't explicitly given.  In your case you want to override windowmanager, so you would add your desktop file to this list.  Since it now has X-GNOME-Provides=windowmanager, it will satisify the "windowmanager" requirement and the default windowmanager won't get implicitly started.
Comment 3 Daniel Laczi 2008-12-03 06:02:43 EST
I think you're right so far. The "openbox-gnome-session" is a normal gnome-session with the openbox windowmanager instead of metacity.

I still think the possiblility to start an "openbox-gnome-session" should be available by default. If for some reason this possibility will no longer be given, please tell me and I will try to find a solution by myself.

The reason why I choose to load the gnome-session after starting openbox like the way above is 1) I don't know how to configure the gnome-session and the login-screen and 2) I still want to be able to login "standard gnome". Also the configuration of openbox is easier and more flexible (I think).
Comment 4 Miroslav Lichvar 2008-12-08 08:06:26 EST
(In reply to comment #2)
> This is the list of things to start
> automatically and is normally just [gnome-settings-daemon].  This list doesn't
> normally include the required components (windowmanager, filemanager, and
> panel), since defaults for these are implicitly added if an override isn't
> explicitly given.

Is default_session supposed to be configurable by user? If the openbox session script on every start copied the default_session value to openbox_session and added openbox to the list, would that be acceptable?

DEFAULT_SESSION=$(gconftool-2 -g /desktop/gnome/session/default_session)
gconftool-2 -t list --list-type=strings -s /desktop/gnome/session/openbox_session "${DEFAULT_SESSION%]},openbox]"
Comment 5 Ray Strode [halfline] 2008-12-08 11:35:44 EST
that should work okay, I think.

(again, would be good if Jon chimed in, though).
Comment 6 Fedora Update System 2008-12-09 13:36:46 EST
openbox-3.4.7.2-7.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/openbox-3.4.7.2-7.fc10
Comment 7 Fedora Update System 2008-12-11 02:55:54 EST
openbox-3.4.7.2-7.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openbox'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11129
Comment 8 Fedora Update System 2008-12-13 10:03:49 EST
openbox-3.4.7.2-7.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.