Bug 474165 - X11 doesn't start anymore - Intel chipset - 845G
X11 doesn't start anymore - Intel chipset - 845G
Status: CLOSED DUPLICATE of bug 478000
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 10:55 EST by Jean-François Rameau
Modified: 2009-09-06 04:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 04:58:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log with no xorg.conf file. (100.46 KB, text/plain)
2008-12-04 04:20 EST, Jean-François Rameau
no flags Details
With intel driver (63.44 KB, text/plain)
2008-12-04 04:21 EST, Jean-François Rameau
no flags Details
xorg.conf with intel driver (647 bytes, text/plain)
2008-12-04 04:22 EST, Jean-François Rameau
no flags Details

  None (edit)
Description Jean-François Rameau 2008-12-02 10:55:11 EST
X11 doesn't start anymore since my migration to FC10 (from scratch).

The graphical card is the following:


00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)

I tried both i810 and intel new driver but no way, I'm now running vesa driver.

Also, the installation has been done with text mode on, the graphical one being freeze after freeze.

I'll be happy to help.

jean-françois
Comment 1 Matěj Cepl 2008-12-03 12:19:11 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Jean-François Rameau 2008-12-04 04:19:22 EST
First test: no xorg.conf file. What I see is gdm greeter but the screen is corrupted around the list of users. Click anywhere then freeze (no console with Ctrl-Alt-F*)

Second test: with intel driver. Same as above.
Comment 3 Jean-François Rameau 2008-12-04 04:20:44 EST
Created attachment 325655 [details]
Xorg log with no xorg.conf file.

No xorg.conf file.
Comment 4 Jean-François Rameau 2008-12-04 04:21:21 EST
Created attachment 325656 [details]
With intel driver
Comment 5 Jean-François Rameau 2008-12-04 04:22:27 EST
Created attachment 325658 [details]
xorg.conf with intel driver
Comment 6 Jean-François Rameau 2008-12-23 09:07:50 EST
Could help someone else. Just add Option "AccelMethod" "XAA" to the device section.

Section "Device"
	Identifier  "Videocard0"
	Driver      "intel"
	Option	    "AccelMethod" "XAA"
EndSection

Better than vesa !
Comment 7 Vedran Miletić 2009-09-06 04:58:14 EDT
This is likely a duplicate.

*** This bug has been marked as a duplicate of bug 478000 ***

Note You need to log in before you can comment on or make changes to this bug.