Bug 474185 - MacBooks ath9k throws many kernel oops while connected.
MacBooks ath9k throws many kernel oops while connected.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 12:43 EST by Fabian Deutsch
Modified: 2009-04-14 13:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 13:51:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (121.56 KB, text/plain)
2008-12-02 12:43 EST, Fabian Deutsch
no flags Details
lspci (1.85 KB, text/plain)
2008-12-02 12:44 EST, Fabian Deutsch
no flags Details
Second dmesg with 2.6.29-0.43.rc2.git1.fc11.i686 (52.14 KB, text/plain)
2009-01-20 13:09 EST, Fabian Deutsch
no flags Details

  None (edit)
Description Fabian Deutsch 2008-12-02 12:43:34 EST
Created attachment 325395 [details]
dmesg

Description of problem:
When connecting to some unsecured wireless network using a MacBook, the ath9k drivers throws kernel oops every 10min.

Version-Release number of selected component (if applicable):
Appeard with Fedora 10, there was no ath9k in Fedora 9.

How reproducible:
Every time connected to an unsecured wireless network.

Steps to Reproduce:
1. Use NM to connect to a wireless network.
2. Use your connection by browsing and reading mails.
3. Wait for a couple of minutes (2-10min)
  
Actual results:
A small popup tells you that a kernel oops appeard and was reported.
NetworkManager might stall and reconnect.

Expected results:
Smooth internet connection.

Additional info:
Kerneloops:
http://www.kerneloops.org/submitresult.php?number=121173
http://www.kerneloops.org/submitresult.php?number=121268
http://www.kerneloops.org/submitresult.php?number=121231

dmesg, lspci attached.
Comment 1 Fabian Deutsch 2008-12-02 12:44:10 EST
Created attachment 325396 [details]
lspci
Comment 2 John W. Linville 2009-01-20 12:50:25 EST
Could you try a recent rawhide kernel?  Does it behave similarly?  Please include the actual kernel version you try.
Comment 3 Fabian Deutsch 2009-01-20 13:01:13 EST
Btw. Seems as if it's worse with Cisco APs. My WRT54g works fine.
Comment 4 Fabian Deutsch 2009-01-20 13:07:56 EST
# uname -a
Linux proprietary.local 2.6.29-0.43.rc2.git1.fc11.i686 #1 SMP Mon Jan 19 01:59:56 EST 2009 i686 i686 i386 GNU/Linux

# rpm -qa | grep kernel
kernel-2.6.29-0.43.rc2.git1.fc11.i686
kernel-firmware-2.6.29-0.43.rc2.git1.fc11.noarch
...


It behaves differently.
It seems as if the signal strength is much better, but I still get a lot of AP reassociations (following dmesg) and the connection is not stable.
Comment 5 Fabian Deutsch 2009-01-20 13:09:24 EST
Created attachment 329496 [details]
Second dmesg with 2.6.29-0.43.rc2.git1.fc11.i686

Mainly note the wlan associate-disassociating-orgies.
Comment 6 Luis R. Rodriguez 2009-03-15 16:01:16 EDT
Your disassoc-assoc issues (which are the origin of this bug report) are unrelated to your disasoc/assoc issues. Your diassoc/assoc issues could be related to interoperability issues or issues with your AP's signal, most likely the first.

Can this bug report be merged with bug 488437.
Comment 7 Fabian Deutsch 2009-03-15 16:20:07 EDT
Yes. After some daily experiences it seems to be some interop issues with Cisco APs.

I can't really tell what happens in bug #488437, but if you suggest it I can just support it :)
Comment 8 Luis R. Rodriguez 2009-03-15 17:21:19 EDT
Sorry what I meant to say was that your assoc/disassoc issues are unrelated to the origins of this bug report which is a WARNING.

For the issues with your Cisco AP please try out wireless-testing or compat-wireless and if you see an issue open up a bug report.

Guide on how to get wirelss-testing:

http://wireless.kernel.org/en/developers/Documentation/git-guide

You can also just use compat-wireless:

http://wireless.kernel.org/en/users/Download
Comment 9 Luis R. Rodriguez 2009-03-15 17:25:40 EDT
Sorry actually if you do see an issue with the latest ath9k (on wireless-testing or through compat-wireless) with your Cisco AP the best way to help debug the issue is to disable netwok manager and pkill wpa_supplicant and then run things manually. Also since you would be using the latest and greatest you can simply report issues using the ath9k mailing list.

http://wireless.kernel.org/en/users/Drivers/ath9k#Mailinglist
http://wireless.kernel.org/en/users/Documentation/Reporting_bugs
http://wireless.kernel.org/en/users/Support

When reporting your issue to the ath9k mailing list please be sure to report exactly the model of your AP and your AP configuration settings.
Comment 10 John W. Linville 2009-04-14 13:51:22 EDT
It sounds like this bug is resolved?  I'm closing on the basis of the last several comments.

Note You need to log in before you can comment on or make changes to this bug.