Bug 474192 - Kernel fails to auto-detect optical media for Optiarc DVD RW AD-7200A
Kernel fails to auto-detect optical media for Optiarc DVD RW AD-7200A
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Alan Cox
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 13:12 EST by Terry Griffin
Modified: 2008-12-10 07:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-10 07:58:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terry Griffin 2008-12-02 13:12:32 EST
Description of problem:

Kernel does not auto-detect the type of optical media, i.e. audio CD vs.
data CD when optical drive is a Optiarc DVD RW AD-7200A (as reported to
OS, but externally labeled as a Sony). This is a parallel IDE ATAPI DVD
drive.

Version-Release number of selected component (if applicable):

2.6.18-92.1.18.el5

How reproducible:

100%

Steps to Reproduce:
1. Insert optical media in to optical drive.
2.
3.
  
Actual results:

The kernel reports: "cdrom: This disc doesn't have any tracks I recognize!"
A desktop icon is created, but there are no pre-defined actions such as
mount (data CD) or play (audio CD).

Expected results:

Desktop icon created with appropriate actions (mount or play) for the media
type (data or audio).

Additional info:

Possibly related to #440289.

Very likely the same problem discussed in this LKML thread:
http://lkml.indiana.edu/hypermail/linux/kernel/0810.0/1323.html

Note that this bug does not prevent mounting a data CD from the
command line using "mount" or playing an audio CD manually.

If I unload the ide-cd module and load ide-scsi instead, then everything
works fine. That is, the kernel is able to auto-detect the optical media
and the appropriate actions are provided in the desktop icon.
Comment 1 Terry Griffin 2008-12-03 20:46:29 EST
I found a firmware update for the model AD-7200A on Optiarc's web site
(www.sonynec-optiarc.us) that fixes the problem. The original firmware
was 1.06. The latest is 1.08.

Upgrading the firmware requires Windows, which was a pain for me because
I had to move the drive to another machine just to do the upgrade.

Anyway as far as I'm concerned the issue is resolved. But still, it
exposes an inconsistency in the kernel because the media autodetection
works fine with 1.06 firmware and ide-scsi, but not with ide-cd.

Note You need to log in before you can comment on or make changes to this bug.