Bug 474225 - Touchpad doesn't work in installer
Touchpad doesn't work in installer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
NeedsRetesting
:
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2008-12-02 16:08 EST by gareth foster
Modified: 2010-02-17 14:46 EST (History)
8 users (show)

See Also:
Fixed In Version: anaconda-13.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-17 14:46:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X11 log (13.00 KB, text/plain)
2009-01-12 18:35 EST, gareth foster
no flags Details
lshal (150.17 KB, text/plain)
2009-01-13 13:32 EST, gareth foster
no flags Details
Fedora 12 Beta x86_64 - DVD Install - dmesg (40.64 KB, text/plain)
2009-10-21 12:45 EDT, Giovanni P. Tirloni
no flags Details
Fedora 12 Beta x86_64 - DVD Install - lshal (106.58 KB, text/plain)
2009-10-21 12:45 EDT, Giovanni P. Tirloni
no flags Details
Fedora 12 Beta x86_64 - DVD Install - /tmp/X.log (21.69 KB, text/plain)
2009-10-21 12:46 EDT, Giovanni P. Tirloni
no flags Details
Fedora 12 Beta x86_64 - After First Boot - dmesg (45.42 KB, text/plain)
2009-10-21 12:46 EDT, Giovanni P. Tirloni
no flags Details
Fedora 12 Beta x86_64 - After First Boot - lshal (136.62 KB, text/plain)
2009-10-21 12:47 EDT, Giovanni P. Tirloni
no flags Details
Fedora 12 Beta x86_64 - After First Boot - /var/log/Xorg.0.log (34.93 KB, text/plain)
2009-10-21 12:48 EDT, Giovanni P. Tirloni
no flags Details

  None (edit)
Description gareth foster 2008-12-02 16:08:47 EST
Description of problem:

I just burned F10 to DVD, when I got the installer started, the mouse pointer wouldn't move. I've got one of the new Macbook Pro laptops, which uses the same touchpad as the Macbook Air, with multitouch.

I can use the Keyboard to install maybe, but bet it won't work on firstboot.

I tried this twice, with same result.
Comment 1 Chris Lumens 2008-12-02 16:36:12 EST
Can you switch over to tty2, grab /tmp/X.log and /tmp/syslog, and attach them to this bug report?
Comment 2 Jeff Cook 2008-12-02 19:34:50 EST
I experienced this as well with upgrade installer downloaded via preupgrade.
Comment 3 Jeff Cook 2008-12-02 19:35:27 EST
And have an old MacBook Pro, v2, pre-Santa Rosa. Normal touchpad with separate button.
Comment 4 Chris Lumens 2008-12-03 10:10:40 EST
Jeff - if you can grab the same information from comment #1, that'd be helpful.  Thanks.
Comment 5 gareth foster 2008-12-03 15:06:57 EST
Chris,

After I asked on IRC how to do what you asked, I had a go. Ctrl+Alt+F2 doesn't change to tty2. I tried every combination of buttons I could think of (shift etc) and nothing worked.

The installer hadn't frozen, I checked, I could still move back and forward with the arrow keys and return.
Comment 6 gareth foster 2008-12-03 15:09:32 EST
I should add this was all fine on F9.

(Also, if the DVD drive spins down at the menu when it says install/upgrade whatever, the installer is buggered. I think its trying to load from the DVD, but it just takes ages (I couldn't be arsed to wait and see if it ever loaded) ...

Loading ...

If I don't let the DVD spin down, it does the whole loading thing in a second and moves on.)
Comment 7 Matěj Cepl 2008-12-04 19:43:26 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

When the anaconda crashes, please, switch to the console (Ctrl+Alt+F2) and cp /tmp/X* to some other place -- USB stick, some other computer via network, some on the Internet, and please attach it to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 8 gareth foster 2008-12-06 15:34:45 EST
> When the anaconda crashes, please, switch to the console (Ctrl+Alt+F2) and cp

I said in the other comment, ctrl+alt+F2 doesn't do anything.
Comment 10 Peter Hutterer 2008-12-07 19:19:21 EST
do you have a USB mouse? If so, does that work?
Does the keyboard work normally (other than the C+A+F2 issue)?
Comment 11 gareth foster 2008-12-13 08:22:11 EST
Nah, not got a USB mouse. They KB arrow and enter keys work, because I can move through installer screens with them.

Could it be that Fedora isn't picking up that its dealing with an English/UK Mac keyboard layout?
Comment 12 Peter Hutterer 2008-12-14 20:48:57 EST
No, in that case you'd simply have the US layout.

Sorry, without the log files I can't really say what's going on there. It could be that the driver isn't loading, it's not there at all, it just doesn't work, or that something else is not quite right. Also, your keymap issues suggest some xkb issues at server startup but that again is hard to find without a log.

Do you have the same problems if you select us as keymap?
Comment 13 gareth foster 2009-01-07 18:16:01 EST
I managed to install with a USB mouse I borrowed. Can't believe there haven't been masses of Macbook owning moaners chirping up on here, but hey ho.
Comment 14 Peter Hutterer 2009-01-07 23:29:14 EST
Does the touchpad work after the install? If not, please provide the /var/log/Xorg.0.log and the output of lshal -m.
Comment 15 gareth foster 2009-01-12 18:34:31 EST
Yes, it does.

This looks unhelpful, but hey ...

[root@BigGaz ~]# lshal -m

Start monitoring devicelist:
-------------------------------------------------
23:33:22.042: computer_power_supply_battery_BAT0 property battery.charge_level.rate = 4856 (0x12f8)
23:33:22.047: computer_power_supply_battery_BAT0 property battery.reporting.rate = 4856 (0x12f8)
23:33:22.049: computer_power_supply_battery_BAT0 property battery.voltage.current = 12613 (0x3145)
23:33:52.056: computer_power_supply_battery_BAT0 property battery.charge_level.rate = 4781 (0x12ad)
23:33:52.059: computer_power_supply_battery_BAT0 property battery.reporting.rate = 4781 (0x12ad)
23:33:52.061: computer_power_supply_battery_BAT0 property battery.voltage.current = 12615 (0x3147)
Comment 16 gareth foster 2009-01-12 18:35:12 EST
Created attachment 328802 [details]
X11 log
Comment 17 Peter Hutterer 2009-01-12 19:16:26 EST
sorry, lshal -l. made the same mistake in a few bugs yesterday.
anyway, my guess is that the boxes affected are those with a bcm5974 touchpad.
what version of xorg-x11-drv-synaptics is on the F10 dvd? Anything past 0.15.0-6 should just work.
Comment 18 gareth foster 2009-01-13 13:32:36 EST
Created attachment 328901 [details]
lshal
Comment 19 gareth foster 2009-01-13 13:38:05 EST
xorg-x11-drv-synaptics-0.15.2-1.fc10.x86_64.rpm

That's what's on the CD. As I said, it worked on first book, but didn't work in the installer.
Comment 20 gareth foster 2009-06-10 17:17:00 EDT
This still doesn't work on Fedora 11.
Comment 21 gareth foster 2009-06-10 17:19:18 EDT
I should also note that Bug 238355 shows this hasn't worked since Fedora 7. That bug was closed as a DUP of something that looks totally unrelated to me.
Comment 22 Peter Hutterer 2009-06-11 20:23:19 EDT
frankly, I have no idea what's going on there. The log file looks completely normal, both for your gb layout and for the touchpad (including detecting the right axis ranges).

Does the button work? Is it just the movement that's restricted?
Also, once you actually start into the installed session, does it work then?
Comment 23 Joshua Baldock 2009-06-13 23:58:19 EDT
Not sure i this should be included on this bug report, or if i should create another one...

I am having the same issue, however my Laptop is not a Mac. It is an Acer 3230 with an "ETPS/2 Elantech Touchpad". I too am unable to move the mouse during install or afterwards in the installed session. When at the desktop the buttons for the mouse seem to work, eg. "right mouse button brings up desktop menu". However no movement is sensed during touching of the touchpad.

I have also noticed that after pushing the buttons on the touchpad to test if they are working, the keyboard stops responding. Eg. "Press right mouse button to show desktop menu, then unable to tab to open windows, switch to console, or restart Xsession with ctrl+alt+backspace"

This has only happened since installing Fedora 11 on this laptop. Everything was working great with Fedora 10.
Comment 24 Jeff Cook 2009-06-14 00:37:12 EDT
^ Joshua, that's probably a different bug. Everything works fine once you boot into Fedora proper after the installation.

Again, it works as expected after the initial installation. Works on the setup screens and all of that.

I don't know if the button works during the install because I don't ever remember the pointer being under something clickable.
Comment 25 Giovanni P. Tirloni 2009-10-21 12:43:00 EDT
Gareth, try pressing Control+Option+Fn+F2.

I have a MacBook 5,1 13" Aluminum and the touchpad does NOT work while trying to install either Fedora 11 x86_64 or Fedora 12 Beta x86_64. It DOES work on first boot though.

It seems Fedora 12 Beta does not load the synaptic driver at install time but after it's installed the driver loads just fine:

Xorg.0.log (after install):

...
(II) config/hal: Adding input device bcm5974
(II) LoadModule: "synaptics"
(II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
	compiled for 1.6.99.900, module version = 1.1.99
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 7.0
(II) Synaptics touchpad driver version 1.1.99.1
(**) Option "Device" "/dev/input/event6"
(II) bcm5974: x-axis range 0 - 1280
(II) bcm5974: y-axis range 0 - 800
(II) bcm5974: pressure range 0 - 256
(II) bcm5974: finger width range 0 - 16
(II) bcm5974: buttons: left double triple
(--) bcm5974: touchpad found
(**) bcm5974: always reports core events
(II) XINPUT: Adding extended input device "bcm5974" (type: TOUCHPAD)
(**) bcm5974: (accel) keeping acceleration scheme 1
(**) bcm5974: (accel) acceleration profile 0
(--) bcm5974: touchpad found
...

By looking at lshal and dmesg it seems the BCM5974 is not detected at install time but manages to get detected after the first boot.

I'll attach the Xorg, lshal and dmesg files from both install and first boot.
Comment 26 Giovanni P. Tirloni 2009-10-21 12:45:15 EDT
Created attachment 365560 [details]
Fedora 12 Beta x86_64 - DVD Install - dmesg
Comment 27 Giovanni P. Tirloni 2009-10-21 12:45:49 EDT
Created attachment 365562 [details]
Fedora 12 Beta x86_64 - DVD Install - lshal
Comment 28 Giovanni P. Tirloni 2009-10-21 12:46:18 EDT
Created attachment 365563 [details]
Fedora 12 Beta x86_64 - DVD Install - /tmp/X.log
Comment 29 Giovanni P. Tirloni 2009-10-21 12:46:55 EDT
Created attachment 365564 [details]
Fedora 12 Beta x86_64 - After First Boot - dmesg
Comment 30 Giovanni P. Tirloni 2009-10-21 12:47:25 EDT
Created attachment 365565 [details]
Fedora 12 Beta x86_64 - After First Boot - lshal
Comment 31 Giovanni P. Tirloni 2009-10-21 12:48:12 EDT
Created attachment 365566 [details]
Fedora 12 Beta x86_64 - After First Boot - /var/log/Xorg.0.log
Comment 32 Peter Hutterer 2009-10-21 23:48:54 EDT
This looks like the bcm5974 kernel module isn't available during install. Look at the working dmesg:

input: bcm5974 as /devices/pci0000:00/0000:00:04.0/usb3/3-6/3-6:1.2/input/input6
usbcore: registered new interface driver bcm5974

This is missing from the other one. If the driver isn't loaded, the device doesn't get created, it doesn't show up in hal and then the X server can't pick it up.

Reassigning to anaconda, changing to rawhide since F12 is affected by this.
Comment 33 Chris Lumens 2009-10-22 09:25:54 EDT
This should be fixed in the next build of anaconda post-F12.  If you think this should be an F12 fix, you'll need to propose this bug to be an F12 Blocker.
Comment 34 Peter Hutterer 2009-10-29 23:41:51 EDT
Adding to F12AnacondaBlocker. I think leaving users without a touchpad during the install process is annoying enough to warrant a fix before GA.
The fix itself seems to be reasonably easy as well, doesn't it?
Comment 35 Adam Williamson 2009-10-30 11:21:57 EDT
This was discussed at today's blocker bug review meeting. We accepted it as a blocker, hence anaconda team, please add the patch to the F12 branch for the next F12 build.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 36 Chuck Ebbert 2009-10-30 11:23:44 EDT
Could people who don't have Macbooks try adding "i8042.noloop=1" to the boot options when booting the installer disk?
Comment 37 Chris Lumens 2009-10-30 11:26:27 EDT
Done, will be included in anaconda-12.42-1.
Comment 38 Adam Williamson 2009-10-31 00:52:43 EDT
this is in the 12.42 build:

http://koji.fedoraproject.org/koji/buildinfo?buildID=139122

tag request:

https://fedorahosted.org/rel-eng/ticket/2942

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 39 Bill Nottingham 2009-11-02 16:17:13 EST
This should be in tomorrow's rawhide. Please retest.
Comment 40 Adam Williamson 2009-11-03 20:16:04 EST
gareth or giovanni, can you please re-test ASAP? this bug is blocking fedora 12's release, we need to confirm the fix ASAP to keep f12 on schedule. thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 41 Giovanni P. Tirloni 2009-11-04 07:39:18 EST
Today I burned a Fedora 12 x86_64 BETA DVD and did a Network install from:

http://linux.nssl.noaa.gov/fedora/linux/development/x86_64/os

The Synaptics driver is not loaded and the touchpad does not work.
Comment 42 Adam Williamson 2009-11-04 11:47:13 EST
ah, that won't work - you're still using the anaconda from the Beta image, just pulling in newer _packages for the installed system_ over the network.

Try doing it from one of these images instead:

http://fedora.mirror.iweb.ca/development/x86_64/os/images/

(use boot.iso for a CD, install.img for USB). Sorry, I should have explained that before. Thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 43 Adam Williamson 2009-11-05 18:05:33 EST
giovanni: ping?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 44 Adam Williamson 2009-11-06 11:51:09 EST
we rather belatedly decided this isn't really a blocker. We're pretty sure it's fixed anyway, but if it isn't, suggested workarounds are a) use the keyboard, b) plug in a frickin' mouse. :)

dropping to target. we'd still appreciate the test results, though. thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 45 gareth foster 2009-11-06 16:23:40 EST
we rather belatedly decided this isn't really a blocker. We're pretty sure it's
fixed anyway, but if it isn't, suggested workarounds are a) use the keyboard,
b) plug in a frickin' mouse. :)

Nice, just lovely. This has been broken for about 4 releases on the trot. Plug in a frickin mouse? Most people will have given up on Fedora as broken by then. What if I haven't got a mouse?
Comment 46 Adam Williamson 2009-11-06 16:48:04 EST
gareth: you're bothered enough to argue about the blocker decision, but not bothered enough to just test and report whether it's fixed? Thanks a bunch, that's very helpful.

if you haven't got a frickin' mouse, use the keyboard. The installer is designed to be usable entirely without a mouse.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 47 gareth foster 2009-11-06 17:43:52 EST
I'm not interested in arguing. This will turn people away from Fedora.
Comment 48 Adam Williamson 2009-11-06 23:38:35 EST
by 'this' you mean the fact that the bug is almost certainly fixed?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.