Bug 474235 - Starting a DVD install with "linux cmdline" causes anaconda to halt after "Welcome Screen" failure
Starting a DVD install with "linux cmdline" causes anaconda to halt after "We...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
ia64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 17:03 EST by Peter Trenholme
Modified: 2008-12-12 18:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 17:19:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Trenholme 2008-12-02 17:03:28 EST
Description of problem: I was trying to install F10 on a HP Intel x64 system with a built-in Intel 745 graphics device. The new Intel driver fails to properly recognize the monitor, resulting in a "black screen" when the graphical install starts. (This is not an anaconda problem - the same "black screen" results if I use the latest, official, Intel release on the Vista system shipped with he box.) So I though I'd install using the "cmdline" option, but, as the summary says, anaconda hangs with a failure to display the welcome screen.


Version-Release number of selected component (if applicable):
Everything is from the current F10 x86_ia64 install DVD.

How reproducible:
Every time

Steps to Reproduce:
1. Boot from the install DVD
2. Press "Escape" at the initial screen to get to the "BOOT:" prompt. (By the way, why is this option not mentioned in the F1 or F2 output where (some) of the anaconda options are listed to be entered at this prompt? What the point of suggesting, e.g., "Enter linux rescue" when you fail to tell the user how to enter that string?)
3. Specify the language and keyboard, wait for anaconda to recognize the media, and see the error message
4. Press Control-C to reboot
  
Actual results:
Error message

Expected results:
anaconda to run in command line (non-graphical) mode

Additional info:
Comment 1 Chris Lumens 2008-12-02 17:19:30 EST
cmdline mode requires that you specify all installation options via cmdline parameters.  So you'd have to add lang=, kbd=, ks=, and so forth all to the BOOT: prompt.  It's not listed in the options because it's almost certainly not what you want to do.

You probably want "linux text".
Comment 2 Andy Lindeberg 2008-12-09 16:54:13 EST
Alternatively, we recommend you give VNC a try. A guide for using VNC can be found here: http://dcantrel.fedorapeople.org/doc/vnc/
Comment 3 Peter Trenholme 2008-12-10 23:35:53 EST
Sorry, I forgot to reply here. "linux text" worked fine for the install, except that it left intab set to 3 instead of 5, but that was easy to fix.

Although telling people installing Fedora 10 how to actually enter the options listed when F2 is pressed would be an improvement, as would listing the "test" option. But that's a documentation problem, and also not a bug.
Comment 4 Andy Lindeberg 2008-12-11 10:27:19 EST
We're greatly reducing the customizability of the text mode install, and are encouraging people to use either graphical or VNC when doing an interactive install. That's why we removed "text mode" as an option in the splash screen, and why the beginning of text mode prompts the user to switch into VNC instead. As providing information within anaconda for how to start text mode would counteract our attempts to phase it out of general use, I highly doubt we'll be doing so.
Comment 5 Chris Lumens 2008-12-11 16:46:26 EST
Also note that a text install implies runlevel 3.  The theory here is that if you're doing a text install, you're likely doing it on a machine without serious graphics capabilities (a server, perhaps) and don't want it to boot up into X automatically.
Comment 6 Peter Trenholme 2008-12-11 18:49:16 EST
O.K., I do understand all that. But consider my scenario: A singe, home computer, using an Intel 945G chip-set and a monitor whose settings that cannot be read by the newer* Intel video driver(s). VNC is not an option because no other computers are available. (In fact, I do have several other systems, and a cross-over cable, so I could have used VNC, but how typical is that, eh?)

So the only install option is to stare at a black screen or use the "text" install. Thus - even if the use of the "text" install mode is depreciated - it needs to be available or some alternative should be provided.

What I'd suggest is a standard "mode change" pop-up window after the "discovered" driver is loaded with a roll-back to, say, the "vesa" driver if no response is entered within, say, ten seconds. That would also accommodate people using proprietary drivers and make anaconda a little more friendly.

Another option might be to display the "discovered" driver(s) and then ask the installer if any of the "discovered" driver(s) should be used. (Some people have more than one display driver in their system, and the monitor may be connected to only one of them.) If they say "no," present a list of available drivers from which they can select or (if you want to be really fancy) let them load their own driver and "xorg.conf" file.

If they say "no" to all the choices, you could then offer the (limited) "text" option.

*"Newer" because the driver that shipped with the Vista pre-installed on the box works fine, but all upgrades to that driver by Microsoft (or Intel - I've tried both) result in the "black screen." I'm using the new Intel driver with Fedora 10, but I had to add the correct "modline" information to xorg.conf before the screen was anything but black.
Comment 7 Chris Lumens 2008-12-12 09:22:49 EST
That sure is a very complicated procedure you've outlined.  It would be much easier to fix this in the right place - by fixing the X driver so it recognizes and supports your video hardware.

What we could do is add a "linux xdriver=vesa" option to the boot.iso to make it a little easier for people to select the fallback driver, in the case where their video otherwise does not work.  I might even consider having a xdriver=vesa fallback in anaconda itself, but that's about as far down that path as I am willing to go.

And accomodating proprietary drivers is never a concern of mine.
Comment 8 Peter Trenholme 2008-12-12 18:25:23 EST
The "xdriver=vesa" option would be a very good solution.

In fact, once I finished the "text" install, I created an xorg.conf with a "Driver "vesa"" entry, did a startx, looked at xorg.0.log, copied the modline settings from the log to xorg.conf, changed the driver to intel, and restarted the X server. Really quite simple. [And added to this "Not a Bug" thread in case someone else stumbles upon it.])

Re proprietary drivers, the Intel driver is now FOSS. (My problem is, apparently, a non-standard response by my monitor to the driver's query for a capability list. Interestingly, while I can't do anything about it in Windows, I can fix the problem in xorg.conf once I can boot Linux.)

I do understand (and sympathize with) your lack of concern for proprietary drivers and hardware. But many people do have such hardware, and do require some option (e.g., "vesa") when their hardware is not otherwise supported by a FOSS driver. Obviously you can't add options for all possible driver/hardware workarounds, but almost every video driver and monitor will support a "vesa" mode, and "vesa" capabilities are all you really need for anaconda to work.

Note You need to log in before you can comment on or make changes to this bug.