Bug 474263 - Many KDE4 and GTK applications fail to launch (segfault in libQtGUI.so
Many KDE4 and GTK applications fail to launch (segfault in libQtGUI.so
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 20:27 EST by Ryan Rix
Modified: 2009-07-20 22:09 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-20 22:09:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Konsole's environment variables (2.73 KB, text/plain)
2008-12-05 19:51 EST, Ryan Rix
no flags Details
Konsole.krash report generated when I try to start konsole. (4.99 KB, text/plain)
2009-03-15 18:18 EDT, Tom Diehl
no flags Details

  None (edit)
Description Ryan Rix 2008-12-02 20:27:50 EST
Description of problem:
I am running a freshly installed Fedora10-KDE4 setup on a gateway laptop. Whenever I try to run nearly any program (Either gtk, qt or anything else -- the only reliable program seems to be the KOffice Suite) from the Kickoff, Kmenu, KRunner or lancelot, it almost instantly segfaults.

This was discovered after travelling down various dead end roads debugging (is the dbus becoming blocked? is there an incompatible or missing dependancy?) I discovered in /var/log/messages various segfaults whenever I would run one of the crashing programs:
>Dec 2 18:03:10 localhost kernel kmail[5540]: segfault at 0 ip 0669b5d5 sp bfe73240 error 4 in libQtGui.so.4.4.3[6523000+8cb000]

The ip 0669b5d5 and the numbers in the brackets at the end of the line are always identical.

This issue only occurs when I run the command from Kickoff Kmenu Krunner or lancelot, but NOT when I run Konsole. The application runs fine via direct supplication via konsole, or even using kfmclient exec [command].

Version-Release number of selected component (if applicable):


How reproducible:
Attempt to launch nearly any application.

Steps to Reproduce:
1. Launch any application using kickoff, krunner, kmenu or lancelot
2. cat /var/log/messages|tail -n 5
3.
  
Actual results:
A segfault in libQtGui.so

Expected results:
A nice running program :)

Additional info:
This problem has somehow alleviated itself once or twice, but after a reboot it is right back where it was before, crashing.
Comment 1 Rex Dieter 2008-12-03 11:09:20 EST
The fact that apps are crashing all over the place (even non qt/kde ones), seems to indicate a more systemic problem.

Tried running memcheck86+?
Comment 2 Ryan Rix 2008-12-03 18:21:41 EST
I have run it, it runs just fine... No memory problems.

My personal belief is that there is a bug in LibQtGui.so, since the secmentation fault always occurs at the same address [6523000+8cb000]... I also notice that the GTK+ apps crashing are all on the library libGObject.so (Dec  3 16:17:12 localhost kernel: gimp-2.6[7570]: segfault at bf2e1fbc ip 0094434f sp bf2e1fc0 error 6 in libgobject-2.0.so.0.1800.2[91a000+40000])

Perhaps the bug is deeper down in the core? something that both libraries would use? but would not get caught in a backtrace?

Rex, what other information/logs can I spit up that may help in alleviating this issue?
Comment 3 Kevin Kofler 2008-12-03 22:56:25 EST
A backtrace with debugging information would be great, but as the crash only happens when the apps are started from the menu, that'll be hard to obtain unfortunately. :-(
Comment 4 Ryan Rix 2008-12-05 19:51:39 EST
Created attachment 325953 [details]
Konsole's environment variables
Comment 5 Ryan Rix 2008-12-05 19:52:22 EST
Well, after a few days struggling, a bit by myself, and a bit with the help of Kevin via IRC, I have been unable to generate any sort of backtrace... even a core dump is seemingly impossible to generate.

A tiny bit more information to add to this strange mystery... If I run any application through kdeinit4, ie kdeinit4 /usr/bin/krunner, as soon after boot as I possibly can, the menu and the startup applications will work perfectly fine.

Perhaps, then, it is that the application is not getting passed proper environment variables or something as simple as that? perhaps it is that kdeinit4 is expecting an include path or something that it simply cannot find. I have attached the output of konsole's /usr/bin/env (https://bugzilla.redhat.com/attachment.cgi?id=325953 ),  but am not sure that it is possible to dump KDE's environment variables without using konsole.
Comment 6 Steven M. Parrish 2009-01-10 10:15:01 EST
Thank you for the bug report.  This issue needs to be addressed by the upstream developers.  Please submit a report at http://bugs.kde.org. You are requested to add the bugzilla link here for tracking purposes. Please make sure the bug isn't already in the upstream bug tracker before filing it.
Comment 7 Steven M. Parrish 2009-02-04 12:31:38 EST
Reporter, could you please reply to the previous request? If you don't reply in within one month of the original request , we will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 8 Tom Diehl 2009-03-03 16:21:27 EST
I just updated 2 systems (one F9 and the other F10) to the latest kdebase, etc.. After yum was done, I tried to restart konsole (the only kde app I use) and I get the following error:

A Fatal Error Occurred
The application Konsole (konsole) crashed and caused the signal 11 (SIGSEGV).
Please help us improve the software you use by filing a report at http://bugs.kde.org. Useful details include how to reproduce the error, documents that were loaded, etc.

After a reboot, I still get the same error on both machines.

When I try to select the debugging option, I get a bunch of errors about not having debugging symbols. I am not if this is the same problem the op was seeing but it looked close enough to my non-programmer eyes, to try posting here.

If this is interesting to someone, please let me know what additional info you need.
Comment 9 Rex Dieter 2009-03-03 16:34:58 EST
(as root):
yum install yum-utils
debuginfo-install kdebase

To get a useful konsole backtrace.
Comment 10 Tom Diehl 2009-03-15 18:18:58 EDT
Created attachment 335279 [details]
Konsole.krash report generated when I try to start konsole.

Attached is the output of the konsole.krash that occurs when I try to start konsole on my F10 box. I have an F9 machine that does the same thing, I can provide debug into on that if needed.
Comment 11 Steven M. Parrish 2009-04-27 14:26:32 EDT
Ping?
Comment 12 Rex Dieter 2009-05-06 14:58:04 EDT
It would likely help us a bunch (if this is still reproducible) to get a new backtrace against the latest stuff in updates (qt-4.5.0/kde-4.2.2).
Comment 13 Ryan Rix 2009-07-20 20:57:12 EDT
Hi there, I've been in the Ubuntu world for a few months... My Fedora11 KDE does not have anything close to this issue and I was unable to recreate it in a Fedora10 KDE dual boot... soooo...

Sorry.
Comment 14 Kevin Kofler 2009-07-20 22:09:08 EDT
I'm closing this as not reproducible.

@Tom Diehl: Your bug is a completely separate issue and has to be filed separately.

Note You need to log in before you can comment on or make changes to this bug.