Bug 474280 - error in commands for auto-starting a guest
error in commands for auto-starting a guest
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Virtualization_Guide (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Christopher Curran
Don Domingo
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-02 22:37 EST by gwikle
Modified: 2009-09-02 00:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 00:56:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gwikle 2008-12-02 22:37:17 EST
The commands recommended in the section titled, Automatically starting domains during the host system boot, seem to be wrong.

I'm 95% sure that in the auto directory you should make links to
the virtual guest _config_ files rather than the image files so the line
that creates the symbolic link should be:

  ln -s /etc/xen/example .

instead of,

  ln -s /var/lib/xen/images/example .

Also, according to the xen documentation this is a configuration for a service called xendomains so you probably should document how to start and stop the service as they do in the xen documentation (or maybe just refer the user to the xen documentation?)
Comment 1 Christian Rose 2008-12-03 05:22:34 EST
I am 100% sure the example instructions in this section is wrong. After following the instructions in this section, I could not get automatic domain startup to work, and

  service xendomains status

showed garbage and errors (I guess the xendomains script did its best in order to try to interpret the domain image file I fed to it, as per the erroneous symlink instructions, as a domain config file, and then borked).

After a night's sleep, skimming the actual xendomains script and some googling I found out the correct instructions. After removing the erroneous symlink, and replacing it with

  cd /etc/xen/auto
  ln -s ../example .

then 'service xendomains status' would display the intended results.
Comment 2 Christopher Curran 2008-12-23 21:53:36 EST
I will try to reproduce this. From an initial look that example may not work with SELinux. This may be a bug with other components as well.

Chris
Comment 3 Christopher Curran 2009-07-31 01:20:54 EDT
This has been fixed in the latest version.

Note You need to log in before you can comment on or make changes to this bug.