Bug 474292 - [kn_IN] Few strings in firstboot are in English
[kn_IN] Few strings in firstboot are in English
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cracklib (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
: i18n, Translation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 01:50 EST by Shankar Prasad
Modified: 2010-01-21 10:37 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.8.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-21 10:37:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Firstboot of fedora-10 in kn_IN locale (143.52 KB, image/png)
2008-12-03 01:50 EST, Shankar Prasad
no flags Details
kannada translations of cracklib (3.34 KB, text/x-gettext-translation)
2008-12-11 01:24 EST, Shankar Prasad
no flags Details

  None (edit)
Description Shankar Prasad 2008-12-03 01:50:41 EST
Created attachment 325491 [details]
Firstboot of fedora-10 in kn_IN locale

Description of problem:
Few strings in "Create User" screen of firstboot in the fedora-10 is still in English


Version-Release number of selected component (if applicable):
Fedora-10

How reproducible:


Steps to Reproduce:
1.Install the fedora-10 in kannada(kn_IN) locale
2.Create an user with some weak password during the firstboot
3.See the text in pop-up window
  
Actual results:
One sentence is in English

Expected results:
It should be in Kannada

Additional info:
Similar kind of bug for "Hardware profile" has been filed here: https://bugzilla.redhat.com/show_bug.cgi?id=474134
Comment 1 Chris Lumens 2008-12-05 15:57:32 EST
That string must just not be translated in Kannadan.  I tested in other languages and it's showing up fine.  Reassigning.
Comment 2 Shankar Prasad 2008-12-07 23:59:45 EST
Clumens,
Among "Hardware Profile" and "it is based on dictionary word" which should not be translated to Kannada?
Comment 3 Chris Lumens 2008-12-08 16:31:54 EST
Shankar - the "Hardware Profile" string is in the smolt package and would need to be translated.  "it is based on a dictionary word" is an error message from system-config-users and would need to be translated in that package as well.  The second string is a little tricky since everything around it is part of firstboot.
Comment 4 Shankar Prasad 2008-12-10 00:11:13 EST
Chris,
Thanks.
But the smolt has been 100% translated to kannada. You can have a look at
https://translate.fedoraproject.org/POT/smolt.master/smolt.master.kn.po
And also, I didn't find any string as "it is based on a dictionary word" in system-config-users
Comment 5 Nils Philippsen 2008-12-10 04:28:08 EST
(In reply to comment #4)
> And also, I didn't find any string as "it is based on a dictionary word" in
> system-config-users

My bad, I should have mentioned that this error message comes from cracklib, not system-config-users. Its Kannada translation should be in cracklib as well, I think.
Comment 6 Shankar Prasad 2008-12-10 05:06:05 EST
Can any one tell me, how to get these strings translated to Kannada?
Comment 7 Nalin Dahyabhai 2008-12-10 11:21:42 EST
For cracklib, the upstream tracker at https://sourceforge.net/tracker/?group_id=130213 looks like the right way to go (there's a Russion translation filed there, too).  Alternately, you can attach a .po file to this report, and I can relay it.

Thanks!
Comment 8 Shankar Prasad 2008-12-11 01:24:56 EST
Created attachment 326590 [details]
kannada translations of cracklib

Please find the attached kannada translations of cracklib
Comment 9 Shankar Prasad 2008-12-15 23:39:58 EST
The Kannada translations of cracklib have been accepted by the upstream.
https://sourceforge.net/tracker/?func=detail&atid=717302&aid=2416062&group_id=130213
Comment 10 Nalin Dahyabhai 2008-12-16 12:51:21 EST
Excellent!  This should get pulled in when we update to the next release, then.  I guess the appropriate thing to do at this point is to mark this as closed with resolution "upstream".
Comment 11 Bug Zapper 2009-06-09 06:05:32 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Shankar Prasad 2009-07-20 08:10:45 EDT
Tested in fedora 11- Rawhide. The issue still exists.
Comment 13 Shankar Prasad 2009-10-22 07:14:47 EDT
The bug still exists in the fedora 12 Rawhide.
I just noticed that in transifex upstream page, the Kananda translation has been named as kn_IN instead of kn. Is that the reason the translations not included in fedora 12.

hth
shankar
Comment 14 Nalin Dahyabhai 2010-01-21 10:37:39 EST
(In reply to comment #13)
> The bug still exists in the fedora 12 Rawhide.
> I just noticed that in transifex upstream page, the Kananda translation has
> been named as kn_IN instead of kn. Is that the reason the translations not
> included in fedora 12.

I'm not sure.  In the upstream tree, 2.8.15 calls the file 'kn.po', which I would expect to cause it to be used in the kn_IN locale.  Marking this as fixed in Raw Hide with version 2.8.15.  If you continue to see problems in trees which incorporate this version, please reopen the bug.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.