Bug 474302 - F9->F10 upgrade gets unhandled exception: RPM Error opening Package
F9->F10 upgrade gets unhandled exception: RPM Error opening Package
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 03:06 EST by Don Lindsay
Modified: 2009-03-25 19:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-09 16:20:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda traceback (114.70 KB, text/plain)
2008-12-04 00:35 EST, Don Lindsay
no flags Details
"script" log showing the requested information (514 bytes, text/plain)
2008-12-05 00:01 EST, Don Lindsay
no flags Details

  None (edit)
Description Don Lindsay 2008-12-03 03:06:08 EST
Description of problem:

I downloaded the F10 x86_64 DVD iso, verified the sha1sum, and burned three copies on a box at work. All three pass self-check on the box I'm upgrading. All three give the following symptoms.

When I try to upgrade my "Athlon 3000+" box, after "preparing to install packages", Anaconda reports an unhandled exception. I will try again to capture the stack trace, but here are my hand notes:

miscutils.py:401 "RPM Error opening Package"
packages.py:593
depsolve.py:239
yuminstall.py:761
backend.py:1607
dispatch.py:204
dispatch.py:127
gui.py:1358
gui.py:79
gui.py:1379

package: /mnt/sysimage/var/cache/yum/anaconda-installationRepo-200811192115.x86_64/packages/libusb-0.1.12-20.fc10.x86_64.rpm
e: error reading package header
Comment 1 Chris Lumens 2008-12-03 09:49:50 EST
Please attach the complete error message to this bug report.  The message can be found in /tmp/anacdump.txt.
Comment 2 Don Lindsay 2008-12-04 00:35:27 EST
Created attachment 325639 [details]
anaconda traceback

anacdump.txt
Comment 3 Don Lindsay 2008-12-04 00:45:08 EST
I did 'sha1sum -b /dev/dvd' on the target machine, and got the 'correct' answer, so the DVD is OK, at least sometimes :-)

After the first failed upgrade attempt, I discovered that a normal boot got me to a working F9. So I did 'rpm -q libusb' and saw both an F9 and a F10 were present. I removed the F10 with 'rpm -e', hoping that clearing away the rubble would help, but subsequent upgrade attempts still failed. And, they did not leave me with an F10 libusb. Dunno what's different about the first try.
Comment 4 Chris Lumens 2008-12-04 15:13:23 EST
When it hits this error, can you press ctrl-alt-f2, and see if /mnt/sysimage/var/cache/yum/anaconda-InstallationRepo-200811192115.x86_64/packages/libusb-0.1.12-20.fc10.x86_64.rpm exists?
Comment 5 Don Lindsay 2008-12-05 00:01:23 EST
Created attachment 325799 [details]
"script" log showing the requested information
Comment 6 Chris Lumens 2008-12-05 10:13:51 EST
Strange, the file's there but it's 0 size.  I noticed there weren't any read errors in your syslog either, which I would usually expect from this situation.
Comment 7 Don Lindsay 2008-12-07 16:46:41 EST
Since F9 and F10 both have libusb-0.1.12, I grabbed the F10 one off the ISO, and installed it (rpm -U) using F9. Then I  booted the ISO DVD and tried to upgrade F9 to F10 again. Result: the error message about libusb did go away. However, further in the upgrade process, I got:

sqlite-3.5.9-2.fc10.x86_64 cannot be opened
This is due to a missing file, a corrupt package or corrupt media. Please verify...
If you exit your system will be left in an inconsistent state that will likely
require reinstallation.

Erk.
So I did a beboot, did a media check on the ISO (it passed, again). From there I want into the F9->F10 upgrade again, and it ran to completion without error.

I wondered if it was flaky hardware (despite the repeated sha1sum and self test successes), so I ran the ISO's memory test for an hour. Two full passes, no error.

So my best guess is that Anaconda does have a bug, but I'm now running Fedora 10, and therefore can no longer replicate the issue(s) reported above.
Comment 8 Chris Lumens 2009-02-09 16:20:49 EST
We have not seen this issue in any of our testing here, unfortunately, or we probably would have been able to fix it.  I'm going to close this as CANTFIX for now given the state of the situation.  If you do continue to run into this problem again in the future, please feel free to reopen this report.  Thanks for filing the bug report.
Comment 9 Justin Giroux 2009-03-25 19:42:21 EDT
I had the same bug doing the same upgrade (F9->F10) with identical error messages.  In my case the missing file (filename present but of size zero) was gnome-python2-applet-2.23.0-1.fc10.i386.rpm.

Note You need to log in before you can comment on or make changes to this bug.