Bug 474312 - krunner_lock and/or kcheckpass (from kdebase-workspace) crashes when using thinkfinger
krunner_lock and/or kcheckpass (from kdebase-workspace) crashes when using th...
Status: CLOSED DUPLICATE of bug 394181
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 04:33 EST by Christof Kaelin
Modified: 2011-12-18 07:50 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 06:02:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christof Kaelin 2008-12-03 04:33:39 EST
Description of problem:
krunner_lock (from kdebase-workspace-4.1.3-6.fc10.i386) still does not work when having thinkfinger input enabled in pam. If thinkfinger is enabled, it is not possible to unlock screen by fingerprint AND by password. There is a crash of kcheckpass (see backtrace below). One has always to switch to a tty and kill the process. This bug was already posted in fedora8 (394181, gets closed soon due to old version), so it seems to be the same codebase in krunner_lock as in it's predecessor kdesktop_lock. This should be given upstream to the kde dev's I suppose?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install and enable thinkfinger on a Thinkpad notebook and wait for KDE screensaver (with password protection).
2. Move a finger ;-)
3. Switch to the console to kill krunner_lock in order to continue working
  
Actual results:


Expected results:
At least be able to unlock with password, or even better to be able to use both password or fingerprint.

Additional info:
Here is the .xsession-errors output showing the crash:

krunner_lock(4731) KxkbCore::settingsRead: Kxkb is disabled, exiting... 
*** glibc detected *** kcheckpass: malloc(): memory corruption: 0x09311120 ***
======= Backtrace: =========
/lib/libc.so.6[0x386006]
/lib/libc.so.6(__libc_malloc+0x95)[0x387755]
/lib/libpam.so.0[0x8c6638]
/lib/libpam.so.0(pam_setcred+0x47)[0x8c59e7]
kcheckpass(Authenticate+0x1df)[0x8049eaf]
kcheckpass(main+0x402)[0x8049442]
/lib/libc.so.6(__libc_start_main+0xe5)[0x32a6d5]
kcheckpass[0x8048f31]
======= Memory map: ========
00110000-00111000 r-xp 00110000 00:00 0          [vdso]
00111000-0011c000 r-xp 00000000 fd:00 21932      /lib/libnss_files-2.9.so
0011c000-0011d000 r--p 0000a000 fd:00 21932      /lib/libnss_files-2.9.so
0011d000-0011e000 rw-p 0000b000 fd:00 21932      /lib/libnss_files-2.9.so
0011e000-00121000 r-xp 00000000 fd:00 51199      /lib/security/pam_env.so
00121000-00122000 rw-p 00002000 fd:00 51199      /lib/security/pam_env.so
00122000-00124000 r-xp 00000000 fd:00 48917      /lib/security/pam_thinkfinger.so
00124000-00125000 rw-p 00002000 fd:00 48917      /lib/security/pam_thinkfinger.so
00125000-00130000 r-xp 00000000 fd:00 51234      /lib/security/pam_unix.so
00130000-00131000 rw-p 0000b000 fd:00 51234      /lib/security/pam_unix.so
00131000-0013d000 rw-p 00131000 00:00 0 
0013d000-0013f000 r-xp 00000000 fd:00 51227      /lib/security/pam_succeed_if.so
0013f000-00140000 rw-p 00002000 fd:00 51227      /lib/security/pam_succeed_if.so
00140000-00141000 r-xp 00000000 fd:00 51197      /lib/security/pam_deny.so
00141000-00142000 rw-p 00000000 fd:00 51197      /lib/security/pam_deny.so
00142000-00143000 r-xp 00000000 fd:00 51210      /lib/security/pam_localuser.so
00143000-00144000 rw-p 00000000 fd:00 51210      /lib/security/pam_localuser.so
00144000-00145000 r-xp 00000000 fd:00 51217      /lib/security/pam_permit.so
00145000-00146000 rw-p 00000000 fd:00 51217      /lib/security/pam_permit.so
00146000-00149000 r-xp 00000000 fd:00 51195      /lib/security/pam_cracklib.so
00149000-0014a000 rw-p 00002000 fd:00 51195      /lib/security/pam_cracklib.so
0014a000-0014e000 rw-p 0014a000 00:00 0 
0014e000-00155000 r-xp 00000000 fd:00 725861     /usr/lib/libcrack.so.2.8.0
00155000-00156000 rw-p 00006000 fd:00 725861     /usr/lib/libcrack.so.2.8.0
00156000-0015a000 rw-p 00156000 00:00 0 
0015a000-0015b000 r-xp 00000000 fd:00 51206      /lib/security/pam_keyinit.so
0015b000-0015c000 rw-p 00001000 fd:00 51206      /lib/security/pam_keyinit.so
0015c000-0015f000 r-xp 00000000 fd:00 51208      /lib/security/pam_limits.so
0015f000-00160000 rw-p 00002000 fd:00 51208      /lib/security/pam_limits.so
00160000-0016d000 r-xp 00000000 fd:00 749351     /lib/libgcc_s-4.3.2-20081105.so.1
0016d000-0016e000 rw-p 0000c000 fd:00 749351     /lib/libgcc_s-4.3.2-20081105.so.1
002ef000-0030f000 r-xp 00000000 fd:00 749291     /lib/ld-2.9.so
00310000-00311000 r--p 00020000 fd:00 749291     /lib/ld-2.9.so
00311000-00312000 rw-p 00021000 fd:00 749291     /lib/ld-2.9.so
00314000-00482000 r-xp 00000000 fd:00 749336     /lib/libc-2.9.so
00482000-00484000 r--p 0016e000 fd:00 749336     /lib/libc-2.9.so
00484000-00485000 rw-p 00170000 fd:00 749336     /lib/libc-2.9.so
00485000-00488000 rw-p 00485000 00:00 0 
0048a000-0048d000 r-xp 00000000 fd:00 725055     /usr/lib/libthinkfinger.so.0.0.0
0048d000-0048e000 rw-p 00002000 fd:00 725055     /usr/lib/libthinkfinger.so.0.0.0
004b5000-004b8000 r-xp 00000000 fd:00 749342     /lib/libdl-2.9.so
004b8000-004b9000 r--p 00002000 fd:00 749342     /lib/libdl-2.9.so
004b9000-004ba000 rw-p 00003000 fd:00 749342     /lib/libdl-2.9.so
004bc000-004d2000 r-xp 00000000 fd:00 749337     /lib/libpthread-2.9.so
004d2000-004d3000 r--p 00015000 fd:00 749337     /lib/libpthread-2.9.so
004d3000-004d4000 rw-p 00016000 fd:00 749337     /lib/libpthread-2.9.so
004d4000-004d6000 rw-p 004d4000 00:00 0 
00620000-0063a000 r-xp 00000000 fd:00 749344     /lib/libselinux.so.1
0063a000-0063b000 r--p 00019000 fd:00 749344     /lib/libselinux.so.1
0063b000-0063c000 rw-p 0001a000 fd:00 749344     /lib/libselinux.so.1
00748000-00749000 r-xp 00000000 fd:00 1211892    /usr/lib/libkdefakes.so.5.1.0
00749000-0074a000 rw-p 00000000 fd:00 1211892    /usr/lib/libkdefakes.so.5.1.0
008c4000-008cf000 r-xp 00000000 fd:00 22284      /lib/libpam.so.0.81.12
008cf000-008d0000 rw-p 0000a000 fd:00 22284      /lib/libpam.so.0.81.12
04d9f000-04db5000 r-xp 00000000 fd:00 749355     /lib/libnsl-2.9.so
04db5000-04db6000 r--p 00016000 fd:00 749355     /lib/libnsl-2.9.so
04db6000-04db7000 rw-p 00017000 fd:00 749355     /lib/libnsl-2.9.so
04db7000-04db9000 rw-p 04db7000 00:00 0 
04eaa000-04ec2000 r-xp 00000000 fd:00 22069      /lib/libaudit.so.0.0.0
04ec2000-04ec3000 r--p 00017000 fd:00 22069      /lib/libaudit.so.0.0.0
04ec3000-04ec4000 rw-p 00018000 fd:00 22069      /lib/libaudit.so.0.0.0
05ff2000-05ff9000 r-xp 00000000 fd:00 1206540    /usr/lib/libusb-0.1.so.4.4.4
05ff9000-05ffb000 rw-p 00006000 fd:00 1206540    /usr/lib/libusb-0.1.so.4.4.4
0604e000-06058000 r-xp 00000000 fd:00 749368     /lib/libcrypt-2.9.so
06058000-06059000 r--p 00009000 fd:00 749368     /lib/libcrypt-2.9.so
06059000-0605a000 rw-p 0000a000 fd:00 749368     /lib/libcrypt-2.9.so
0605a000-06081000 rw-p 0605a000 00:00 0 
08048000-0804b000 r-xp 00000000 fd:00 296858     /usr/libexec/kde4/kcheckpass
0804b000-0804c000 rw-p 00002000 fd:00 296858     /usr/libexec/kde4/kcheckpass
0930a000-0932b000 rw-p 0930a000 00:00 0          [heap]
b6b00000-b6b21000 rw-p b6b00000 00:00 0 
b6b21000-b6c00000 ---p b6b21000 00:00 0 
b6c54000-b6c55000 ---p b6c54000 00:00 0 
b6c55000-b7655000 rw-p b6c55000 00:00 0 
b7655000-b7656000 ---p b7655000 00:00 0 
b7656000-b8058000 rw-p b7656000 00:00 0 
b8077000-b8078000 rw-p b8077000 00:00 0 
bf962000-bf977000 rw-p bffeb000 00:00 0          [stack]
Acceleration key: disabled
Acceleration key: disabled
Acceleration key: disabled
Acceleration key: disabled
Comment 1 Kevin Kofler 2008-12-03 05:57:50 EST
> from kdebase-workspace-4.1.3-6.fc10.i38

Then why do you file this against kdebase4? There IS NO kdebase4 in Fedora 10.
Comment 2 Kevin Kofler 2008-12-03 06:02:08 EST

*** This bug has been marked as a duplicate of bug 394181 ***
Comment 3 Christof Kaelin 2008-12-03 08:06:42 EST
Ok, sorry, my mistake. By the way, as I understand, the old F8 bugs are being closed soon, so I don't think we should mark this one as a duplicate, what do you think?
Comment 4 Kevin Kofler 2008-12-03 10:56:05 EST
I changed Version to 10 on the original report so it won't get closed. It's still the exact same bug with the same backtrace, even if it's now KDE 4.
Comment 5 Kevin Kofler 2008-12-03 11:00:18 EST
Oh, and sorry if it got lost under my complaining, but thanks for your report. ;-) Your report is the confirmation that the original issue still exists in F10 / KDE 4.1. (Sorry, I'm really in a bad mood today for reasons unrelated to Fedora, please don't take it personally.)
Comment 6 Fedora Update System 2011-12-18 07:50:08 EST
pspp-0.7.8-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/pspp-0.7.8-1.fc16

Note You need to log in before you can comment on or make changes to this bug.