Bug 474333 - makewhatis creates highly incomplete whatis database
makewhatis creates highly incomplete whatis database
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 06:36 EST by Daniel Roesen
Modified: 2008-12-03 07:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 07:14:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
generated /var/cache/man/whatis (5.51 KB, text/plain)
2008-12-03 06:36 EST, Daniel Roesen
no flags Details

  None (edit)
Description Daniel Roesen 2008-12-03 06:36:05 EST
Created attachment 325523 [details]
generated /var/cache/man/whatis

[root@trinity ~]# time makewhatis -u -w

real	0m2.560s
user	0m1.375s
sys	0m1.381s

[dr@trinity ~]$ wc -l /var/cache/man/whatis 
76 /var/cache/man/whatis

[dr@trinity ~]$ find /usr/share/man/ -type f | wc -l
12566

[root@trinity ~]# man lftp | col -b | grep -A 1 ^NAME
NAME
       lftp - Sophisticated file transfer program
[root@trinity ~]# apropos transfer
transfer: nothing appropriate

I haven't found a pattern yet what those 76 man pages are being indexed, but others not. I'm going to attach the whatis-cachefile (which is plain text).

Version-Release number of selected component (if applicable):
man-1.6f-11.fc10.i386
Comment 1 Ivana Varekova 2008-12-03 07:14:31 EST
The problem is you uses "-u" flag which means makewhatis only update /var/cache/man/whatis database (add man pages which were changed in last 24 hours). If the problem persists if you remove this flag please reopen this bug.
Comment 2 Daniel Roesen 2008-12-03 07:56:21 EST
OK, I can see the problem now. The daily cron job runs -u, the weekly doesn't. After a fresh install, the database only gets created when the weekly cronjob has ran once. As far as I can see, anacron should make sure that this is being done ASAP, but effectively doesn't here. Looking at my process list, anacron doesn't look too healthy:

root      2562  0.0  0.0   1936   768 ?        SNs  11:48   0:00 anacron -s
root     17016  0.0  0.0   4808  1104 ?        SN   13:42   0:00 /bin/bash /etc/cron.weekly/0anacron
root     17017  0.0  0.0   4456   728 ?        SN   13:42   0:00 awk -v progname=/etc/cron.weekly/0anacron progname {?????   print progname ":\n"?????   progname="";????       }????       { print; }

Something's "hanging" there...

makewhatis -w does what it is supposed to do, I guess the problem at hand lies within anacron's realm. Thanks for spotting the -u flag, I should have checked invocation parameters.

Note You need to log in before you can comment on or make changes to this bug.