Bug 474360 - Kernel prevents graphical boot
Kernel prevents graphical boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 09:29 EST by antonio montagnani
Modified: 2008-12-13 11:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-13 11:31:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my xorg.conf (693 bytes, text/plain)
2008-12-03 10:08 EST, antonio montagnani
no flags Details
xorg when using noevau drivet (6.48 KB, text/plain)
2008-12-03 10:11 EST, antonio montagnani
no flags Details
Dmesg (25.99 KB, text/plain)
2008-12-03 10:44 EST, antonio montagnani
no flags Details

  None (edit)
Description antonio montagnani 2008-12-03 09:29:43 EST
Description of problem:
If I boot in level 5 the graphical server is not started and box freezes after anacron start-up.
If I start il runlevel=3 box boots and if I issue a startx I see errors connected to DRM.I am using an Nvidia card with nvidia driver. Same with nv driver.

Version-Release number of selected component (if applicable):
kernel-2.6.28-0.106.rc6.git4.fc11.i686

How reproducible:
always

Steps to Reproduce:
1.just boot
2.
3.
  
Actual results:
freezing

Expected results:
plain boot

Additional info:
Comment 1 Mads Kiilerich 2008-12-03 09:54:01 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach /var/log/Xorg.0.log and /var/log/dmesg from this attempt and your X server config file if any (/etc/X11/xorg.conf).

We will review this issue again once you've had a chance to attach this information.

Thank you in advance.
Comment 2 antonio montagnani 2008-12-03 10:08:36 EST
Created attachment 325542 [details]
my xorg.conf

xlog will follow
Comment 3 antonio montagnani 2008-12-03 10:11:48 EST
Created attachment 325543 [details]
xorg when using noevau drivet
Comment 4 Mads Kiilerich 2008-12-03 10:26:51 EST
(II) Reloading /usr/lib/xorg/modules/extensions//libdri.so
(II) NOUVEAU(0): Loaded DRI module
drmOpenDevice: node name is /dev/dri/card0
[drm] failed to load kernel module "nouveau"
(EE) NOUVEAU(0): [dri] Failed to open the DRM
(EE) NOUVEAU(0): 1331: 
(II) UnloadModule: "nouveau"
(II) UnloadModule: "dri"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/lib/xorg/modules//libvgahw.so
(II) UnloadModule: "int10"
(II) Unloading /usr/lib/xorg/modules//libint10.so
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found



And dmesg, please?
Comment 5 antonio montagnani 2008-12-03 10:44:15 EST
Created attachment 325548 [details]
Dmesg

not sure if it is related to our case...
Comment 6 Mads Kiilerich 2008-12-03 20:35:04 EST
These days "graphical boot" usually means kernel mode setting and graphical plumouth boot. AFAIK that is however only implemented for some ATI chipsets, and I doubt there is any plans to implement it for nVidia any time soon. So I don't think that is the case here.

FWIW it seems to me that a better description of your problem is that the X server 1.5.3-5 just doesn't work with 2.6.28 kernels.

Note You need to log in before you can comment on or make changes to this bug.