Bug 474364 - /usr/share/cluster/fs.sh causes creation of hundreds of processes per second
/usr/share/cluster/fs.sh causes creation of hundreds of processes per second
Status: CLOSED DUPLICATE of bug 250718
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 09:58 EST by Herbert L. Plankl
Modified: 2009-04-16 18:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 11:59:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Herbert L. Plankl 2008-12-03 09:58:05 EST
Description of problem:
* 6-node-cluster
* one member has mounted 34 partitions (each 2TB but doesn't matter)

I wondered why this member's load is always >1 although he isn't doing sth special. I found out that the number of processes created per second is really high (average 600).

sar -c every second looks like this:
03:37:49 PM      0.00
03:37:50 PM      0.00
03:37:51 PM      1.00
03:37:52 PM    462.00
03:37:53 PM    936.00
03:37:54 PM    889.00
03:37:55 PM    862.75
03:37:56 PM    954.08
03:37:57 PM    884.16
03:37:58 PM    938.00
03:37:59 PM    975.76
03:38:00 PM    515.00
03:38:01 PM      0.00
03:38:02 PM    503.00
03:38:03 PM    891.09
03:38:04 PM   1019.19
03:38:05 PM    379.80
03:38:06 PM      0.00
03:38:07 PM      2.00
03:38:08 PM      0.00
03:38:09 PM      0.00
03:38:10 PM      0.00
03:38:11 PM      0.00
03:38:12 PM    510.00
03:38:13 PM    852.48
03:38:14 PM    880.81
03:38:15 PM    861.39
03:38:16 PM    942.00
03:38:17 PM    934.34




After some research I found out that one of the cluster scripts is causing this high number of processes: /usr/share/cluster/fs.sh

Every few seconds this script is called for each partition (34 partitions). Each call (/usr/share/cluster/fs.sh status) causes the creation of 92 (sub-)processes. Thats because fs.sh is a bash-script with a lot of subshells and binary-calls (in fact 92 calls in case of status).

Here is a the grep on a strace for one call:
[root@iconode01-sr1 tmp]# strace /usr/share/cluster/fs.sh status 2>&1|grep clone|wc -l
92


Version-Release number of selected component (if applicable):
rgmanager-2.0.38-2.el5

How reproducible:
1. export all OCF_* variables
2. call "strace /usr/share/cluster/fs.sh 2&>1|grep clone"

Actual results:
Creation of a lot of processes.

Expected results:
* 1 process per partition
* not a bash-script (fs.sh) but a executable or a python script

Additional info:
* this causes load of 1 on a 8-core-Opteron-machine while there are only cman/rgmanager running and 34 partitions mounted
Comment 1 Lon Hohberger 2008-12-03 11:59:26 EST

*** This bug has been marked as a duplicate of bug 250718 ***

Note You need to log in before you can comment on or make changes to this bug.