Bug 474374 - X hangs on startup with Radeon X1900
X hangs on startup with Radeon X1900
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 10:42 EST by Paolo Leoni
Modified: 2018-04-11 04:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:07:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my actual xorg.conf with a default vesa configuration (1.34 KB, text/plain)
2008-12-06 05:54 EST, Paolo Leoni
no flags Details
X log generated with vesa configuration (functional) (80.85 KB, text/plain)
2008-12-06 05:56 EST, Paolo Leoni
no flags Details
X log generated without any xorg.conf (defect) (70.99 KB, text/plain)
2008-12-06 06:00 EST, Paolo Leoni
no flags Details

  None (edit)
Description Paolo Leoni 2008-12-03 10:42:39 EST
Description of problem:

When I load ati driver 6.9.0, X hangs on startup, screen is freezed with black and white lines. 
If I creat an xorg.conf with "vesa" option, the system starts correctly. 

Version-Release number of selected component (if applicable):

6.9.0

How reproducible:

Boot Fedora 10 with a Radeon X1900 (R580) adapter.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

X hangs, system freeze.

Expected results:

Normal boot.

Additional info:
Comment 1 Matěj Cepl 2008-12-05 11:16:54 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Paolo Leoni 2008-12-06 05:54:25 EST
Created attachment 325983 [details]
my actual xorg.conf with a default vesa configuration
Comment 3 Paolo Leoni 2008-12-06 05:56:01 EST
Created attachment 325984 [details]
X log generated with vesa configuration (functional)
Comment 4 Paolo Leoni 2008-12-06 06:00:20 EST
Created attachment 325985 [details]
X log generated without any xorg.conf (defect)

This log is referred to the situation (system freezed) that I described below. Note that if xorg.conf is manually created with "radeon" driver the result is the same.
Comment 5 Paolo Leoni 2009-02-03 04:48:04 EST
I've tried with xorg-x11-drv-ati 6.10.0-1 from fedora-testing repository, but X still hangs.
But something has changed, the system seems to be not totally freezed like with 6.9.0, now I can able to reboot without forcing the poweroff.
Comment 6 Paolo Leoni 2009-02-13 14:26:51 EST
Update:
I've tried Fedora 11 Alpha with xorg-x11-drv-ati 6.10.0-2, I've the same problem. X still hangs.
Comment 7 Bug Zapper 2009-11-18 04:37:39 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2009-12-18 02:07:28 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.