Bug 474382 - virt-manager returns "KeyError: 00000000-0000-0000-0000-000000000000"
virt-manager returns "KeyError: 00000000-0000-0000-0000-000000000000"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.2
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 11:03 EST by Guy Albertelli
Modified: 2009-12-14 16:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 17:12:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager.log of failure (1.36 KB, text/plain)
2008-12-03 11:03 EST, Guy Albertelli
no flags Details
Fix for connect.py and connection.py (1.06 KB, patch)
2008-12-04 16:27 EST, Guy Albertelli
no flags Details | Diff

  None (edit)
Description Guy Albertelli 2008-12-03 11:03:45 EST
Created attachment 325550 [details]
virt-manager.log of failure

Description of problem:
Attempting to bring up "Details" screen from virt-manager on Dom-0 fails on RHEL 5.2.  Works on RHEL5.1

Version-Release number of selected component (if applicable):
virt-manager-0.5.3-8.el5
libvirt-0.3.3-7.el5
libvirt-python-0.3.3-7.el5
python-virtinst-0.300.2-8.el5
kernel-xen-2.6.18-92.el5

How reproducible:
Always occurs.

Steps to Reproduce:
1. Install fresh virgin copy of RHEL 5.2
2. Invoke virt-manager as root
3. Open connection to "Local"
4. Select "Domain-0"
5. Click on "Details" button
  
Actual results:
Selected item flashes, but no window opens.  Error (see attached) appears in /root/.virtmanager/virt-manager.log

Expected results:
The "Details" window would open.

Additional info:
This does not occur in RHEL 5.1.  In 5.1 the Details window opens.  This failure occurs on both a fresh 5.2 install and on an upgraded 5.1 system. Note also that the "New" button is always disabled (grayed out) in 5.2.

The virt-manager.log from a fresh install of 5.2 is attached.

The hardware is HP DL380 G5
Comment 1 Guy Albertelli 2008-12-04 16:25:55 EST
Problem occurs because 2 vmmConnection objects are created. The first with uri of "xen:///" and the other with an original uri of "xen".  Even though the uri is changed from "xen" to "xen:///" change during the creation of the second object, it is a different object.  Thus when Domain-0 is added it is added to the first object.  However when selecting the Domain-0 on the window, the second object is selected by the "Details" button. Since the second object does not have Domain-0 in it, we get the KeyError.  The root cause is the attempt to create the second object with the wrong uri.

Patch for virt-manager-0.5.3-8.el5 is attached.  It is the same code that shows up in virt-manager-0.5.4.
Comment 2 Guy Albertelli 2008-12-04 16:27:39 EST
Created attachment 325747 [details]
Fix for connect.py and connection.py
Comment 3 Guy Albertelli 2008-12-04 16:30:14 EST
The change to connection.py was to eliminate a bandaid that was applied to hide the effect of the problem in connect.py.  With only the connection.py patch, then two different rows for ID "xen" showed up - cooresponding to the two vmmConnection objects.  One was Disconnected and the other Active.
Comment 4 Cole Robinson 2009-01-21 17:12:55 EST
Hi, thanks for the patch! Unfortunately for your patch's sake, we had another bug for this same issue, and it was fixed in 5.3 (bug 441850). So updating to the current release.

Closing as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.