Bug 474425 - Cannot configure basket, kcm_basket.la missing
Cannot configure basket, kcm_basket.la missing
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: basket (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 14:27 EST by Arturo Alejandro Hoffstadt Urrutia
Modified: 2008-12-06 23:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-06 23:22:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arturo Alejandro Hoffstadt Urrutia 2008-12-03 14:27:12 EST
Description of problem:

I tired to enter the configuration dialog, but it fails, and instead a message appears saying:

The specified library basket could not be found.
...
The diagnostics is:
Library files for "kcm_basket.la" not found in paths.

Version-Release number of selected component (if applicable):
basket-1.0.3.1-2.fc10.i386

How reproducible:
always

Steps to Reproduce:
1. start basket
2. go to the configuration dialog

  
Actual results:
the message displayed above

Expected results:
The complete configuration dialog

Additional info:
yum provides *kmc_basket.la* shows that two versions ago the was the mentioned file.
Comment 1 Rex Dieter 2008-12-04 09:54:36 EST
confirmed.  

Looks like over-agressive .la file pruning.
Comment 2 Rex Dieter 2008-12-04 10:05:36 EST
Fwiw, confirmed broken on F-8 too.
Comment 3 Rex Dieter 2008-12-04 10:09:51 EST
Fixed in cvs (all relevant branches), built for rawhide.

I'll leave it to basket maintainer(s) to decide when/if to build and issue updates.
Comment 4 Christopher D. Stover 2008-12-04 10:28:45 EST
Hi Rex, thanks for fixing it in CVS.  I'll push the update shortly.  I was working on this last night as I was doing a rawhide update that hosed my system. :D  I left off looking at the guidelines last night, which says we should remove all *.la files.  In instances like this, I assume it's ok to include them?  I was also talking to someone in #fedora-devel last night who was saying the need for the *.la file could be removed in the source code.
Comment 5 Rex Dieter 2008-12-04 10:44:51 EST
The guideline:
https://fedoraproject.org/wiki/Packaging/Guidelines#Packaging_Static_Libraries
doesn't go as far as saying packagers MUST remove *all* .la files.  In short, remove them if able.

In this case, kde3 loadable modules pretty much require them.  We've tried various ways to "fix" that locally in fedora, with not much success.  And upstream kde, for the most part, considers it NOTABUG, partly because kde3 is frozen/legacy stuff by now, and best not to be mucking with it too much (especially at low-levels such as loadable modules).
Comment 6 Fedora Update System 2008-12-04 12:27:04 EST
basket-1.0.3.1-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/basket-1.0.3.1-4.fc10
Comment 7 Fedora Update System 2008-12-04 12:27:06 EST
basket-1.0.3.1-4.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/basket-1.0.3.1-4.fc9
Comment 8 Fedora Update System 2008-12-06 23:22:11 EST
basket-1.0.3.1-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-12-06 23:32:23 EST
basket-1.0.3.1-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.