Bug 474461 - Firefox doesn't recognize it's the default browser
Firefox doesn't recognize it's the default browser
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jan Horak
desktop-bugs@redhat.com
:
Depends On: 474441
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 17:06 EST by Heiko Adams
Modified: 2008-12-16 02:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 02:45:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.86 KB, patch)
2008-12-12 08:03 EST, Jan Horak
no flags Details | Diff

  None (edit)
Description Heiko Adams 2008-12-03 17:06:05 EST
Description of problem:
After setting the system's default browser to "Firefox" FF doesn't recognize it's the default browser on launching. After starting Firefox asks for setting it to the system's default browser. When answering this question the system's default browser is set to "User defined" and the command is set to "/usr/lib/firefox-3.0.4/firefox "%s"".

Version-Release number of selected component (if applicable):
firefox-3.0.4-1.el5.centos
xulrunner-1.9.0.4-1.el5

How reproducible:
allways

Steps to Reproduce:
1. Open "Favorite applications"
2. Set default browser to "Firefox"
3. Start firefox
  
Actual results:
Firefox asks for setting it to the default browser

Expected results:
Firefox should start without this question

Additional info:
Comment 1 Matěj Cepl 2008-12-04 14:11:33 EST
Cannot reproduce here with the real RHEL 5.2 -- browser application in the Gnome is truly set to custom, but it is firefox, so it works as it should.

Martin, you were saying something about bad registration? Or should I just close this as WORKSFORME?
Comment 2 Heiko Adams 2008-12-04 15:17:00 EST
Maybe I found the reason: On my profile the checkbox which lets firefox check on startup if it is the default browser was activated. In a new created profile this checkbox is disabled.

So if you activate this checkbox you should be able to reproduce this issue. BTW: If you answer the default browser question with yes FF set the default browser to "User defined" with "/usr/lib/firefox-3.0.4/firefox %s" as command.
Comment 3 Matěj Cepl 2008-12-04 19:01:56 EST
Reporter, you are right -- with the checking of "Check for being a default" I can reproduce the mess as well (on Rawhide).

IMHO, this whole setting should be removed from Firefox on Linux entirely -- this shouldn't be done in Firefox, we have a good application for it, and the environment is not suspectible from taking default from us.

But that's certainly decision on developers, so passing to them.
Comment 5 Jan Horak 2008-12-12 08:03:28 EST
Created attachment 326725 [details]
Proposed patch

Firefox is using location of binary file (/usr/lib/firefox-3.0.5/firefox for example) to compare with string in gconf protocol handlers (like /desktop/gnome/url-handler/http). However in gconf register is not stored full path. Only 'firefox %s'. The patch is only checking 'firefox' word in gconf register instead of full path. 

It also fixes bug #474441.
Comment 7 Jan Horak 2008-12-16 02:45:07 EST
See https://bugzilla.mozilla.org/show_bug.cgi?id=469648. Closing as upstream.

Note You need to log in before you can comment on or make changes to this bug.