Bug 474501 - DSGW doesn't lets directory manager delete a entry
DSGW doesn't lets directory manager delete a entry
Status: CLOSED WORKSFORME
Product: 389
Classification: Community
Component: UI - Gateway/Phonebook (Show other bugs)
1.1.2
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 22:25 EST by Deependra Singh Shekhawat
Modified: 2015-01-04 18:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-22 11:25:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deependra Singh Shekhawat 2008-12-03 22:25:31 EST
Description of problem:
The directory server gateway doesn't allow authenticated directory manager to delete a already existing directory entry from the web UI.

Version-Release number of selected component (if applicable):
fedora-ds-dsgw-1.1.0-1.fc10.i386

How reproducible:
The following are the steps.

Steps to Reproduce:
1. Open up web browser. That is firefox
2. Give this URL : http://<serverip>:<adminserver port>/dist/download
3. Under Services for Administrator -> Directory Server Gateway -> Authenticate  -> Authenticate as Directory Manager -> Give Password 'directory' -> Return to Main -> Advance Search -> Search for some user you like. 
4. Page showing the user information comes up.
5. Click on Edit person button
6. A new page opens up which let's you edit the person's details. Click on the delete person button now.
  
Actual results:
A new firefox window pops up with the following url:
http://<serverip>:<adminserver port>/dsgwcmd/lang?file=confirm.html
but that doesn't have any confirmation message in it but again the old links to authenticate, add a new entry and advance search.


Expected results:
It should have asked for a confirmation from the administrator and after giving his confirmation should have deleted the user's entry.

Additional info:
If required feel free to ask.
Comment 1 Rich Megginson 2008-12-22 11:25:24 EST
I was not able to reproduce.  Once I hit the Delete Person button, I did get the correct confirmation dialog.  The dialog has a yellow triangle with an exclamation point inside next to the text Delete this person? and Ok and Cancel buttons.  Pressing Ok deleted the person, as confirmed by doing a search.

Note You need to log in before you can comment on or make changes to this bug.