Bug 474507 - Deadlock on exit when using Logitech Quickcam Vision Pro
Deadlock on exit when using Logitech Quickcam Vision Pro
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cheese (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 00:51 EST by Braden McDaniel
Modified: 2008-12-09 14:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 14:53:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stack trace (4.15 KB, text/plain)
2008-12-04 00:51 EST, Braden McDaniel
no flags Details

  None (edit)
Description Braden McDaniel 2008-12-04 00:51:03 EST
Created attachment 325641 [details]
Stack trace

Description of problem:
Cheese deadlocks on exit.

Version-Release number of selected component (if applicable):
2.24.1-2.fc10

How reproducible:
Consistently.

Steps to Reproduce:
1. Start Cheese with a Logitech Quickcam Vision Pro attached.
2. Try to quit.
Comment 1 Hans de Goede 2008-12-04 02:30:17 EST
does it display an image, iow does cheese work before you try to quit?

I think you might be hitting a known libv4l bug, please try this libv4l update:
http://koji.fedoraproject.org/koji/buildinfo?buildID=72926

Please let us know if this update fixes this.
Comment 2 Braden McDaniel 2008-12-04 03:09:57 EST
No, it doesn't work.

The update doesn't fix this.
Comment 3 Hans de Goede 2008-12-08 11:19:55 EST
Hmm,

Ok, I *think* that you've got the logitech cam with the manufacture:device id of:
046d:09a6

You can confirm this by running the "lsusb" command in a terminal.

If this is the case, chances are you've got a cam with a hardware bug, see:
http://www.quickcamteam.net/hcl/linux/logitech_device_list_v2.pdf

And notice how this cam has footnote 7:
"7 Incompatibilities with some USB controllers on Linux. The camera may hang when starting the stream multiple times. This affects cameras with the
USB BCD 0x0009"

please run:
lsusb -d 046d:09a6 -v | grep bcdDevice

If the output is 0.09, your cam has the hardware bug, for more on this see:
http://www.quickcamteam.net/documentation/faq/how-many-versions-of-the-quickcam-pro-9000-are-there.

---

The uvcvideo driver in kernels >= 2.6.27.5-121, has a workaround for a similar bug in other model camera's which might work here too.

To try this, make sure you are running a kernel >= 2.6.27.5-121. If you
need to update your kernel for that, please first check if the update itself fixes things and then as root do:
rmmod uvcvideo
modprobe uvcvideo quirks=64


Let me know if that helps.
Comment 4 Braden McDaniel 2008-12-09 00:11:35 EST
Yup, sure enough. That's it.

I tried kernel-2.6.27.7-134.fc10 from updates-testing and the problem went away.
Comment 5 Hans de Goede 2008-12-09 03:14:26 EST
(In reply to comment #4)
> Yup, sure enough. That's it.
> 
> I tried kernel-2.6.27.7-134.fc10 from updates-testing and the problem went
> away.

Thats good news! Did you need to use "modprobe uvcvideo quirks=64", or did it work right away ? I want to know because if you needed the quirsk=64 option then I will add your cam to the list of cams with quirks so that this happens automatically.
Comment 6 Braden McDaniel 2008-12-09 10:35:41 EST
It Just Worked; I didn't need the quirks=64 option.

I don't think I'm getting the 30 fps at 640x480 that this camera is supposed to be capable of (and quirks=64 doesn't apper to help with this); but I am getting the higher resolution that the camera can do (1600x1200).
Comment 7 Hans de Goede 2008-12-09 14:53:11 EST
Ok, thanks. Closing this then :)

Note You need to log in before you can comment on or make changes to this bug.