Bug 474514 - file conflict on upgrading
file conflict on upgrading
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 03:51 EST by Akira TAGOH
Modified: 2014-01-21 18:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-15 09:58:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum -d 9 update (36.26 KB, text/plain)
2010-06-25 20:30 EDT, Bill McGonigle
no flags Details

  None (edit)
Description Akira TAGOH 2008-12-04 03:51:13 EST
Description of problem:
Transaction Check Error:
  file /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf from install of dejavu-fonts-sans-mono-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSansMono-BoldOblique.ttf from install of dejavu-fonts-sans-mono-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSansMono-Oblique.ttf from install of dejavu-fonts-sans-mono-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSansMono.ttf from install of dejavu-fonts-sans-mono-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSerif-Bold.ttf from install of dejavu-fonts-serif-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSerif.ttf from install of dejavu-fonts-serif-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSerif-BoldItalic.ttf from install of dejavu-fonts-serif-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-experimental-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSerif-Italic.ttf from install of dejavu-fonts-serif-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-experimental-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf from install of dejavu-fonts-serif-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-experimental-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSerifCondensed-BoldItalic.ttf from install of dejavu-fonts-serif-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-experimental-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSerifCondensed-Italic.ttf from install of dejavu-fonts-serif-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-experimental-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf from install of dejavu-fonts-serif-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-experimental-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf from install of dejavu-fonts-sans-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSans-BoldOblique.ttf from install of dejavu-fonts-sans-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSans-Oblique.ttf from install of dejavu-fonts-sans-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSans.ttf from install of dejavu-fonts-sans-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSans-ExtraLight.ttf from install of dejavu-fonts-sans-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-experimental-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSansCondensed-Bold.ttf from install of dejavu-fonts-sans-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-experimental-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSansCondensed-BoldOblique.ttf from install of dejavu-fonts-sans-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-experimental-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSansCondensed-Oblique.ttf from install of dejavu-fonts-sans-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-experimental-2.26-2.fc10.noarch
  file /usr/share/fonts/dejavu/DejaVuSansCondensed.ttf from install of dejavu-fonts-sans-2.26-6.fc11.noarch conflicts with file from package dejavu-fonts-experimental-2.26-2.fc10.noarch


Version-Release number of selected component (if applicable):
# rpm -qa | grep dejavu
dejavu-fonts-2.26-2.fc10.noarch
dejavu-fonts-experimental-2.26-2.fc10.noarch
Comment 1 Nicolas Mailhot 2008-12-04 07:30:26 EST
What command did you use to update?
There are compat dejavu packages in F11 which are supposed to take care of this, and they worked fine when I tested them in yum.
Comment 2 Akira TAGOH 2008-12-04 07:42:07 EST
Oh, sorry. should mentioned that. I did just yum groupupdate Fonts and didn't work.
Comment 3 Nicolas Mailhot 2008-12-04 13:55:33 EST
Thanks for the info. Re tested and with yum update everything works, with you groupupdate that fails. Which makes it a yum bug IMHO. Seth is not going to be happy with me for making you trigger it.

Anyway, here is the complete test scenario:

1. Initial system: F10 or rawhide with the 3 F10 dejavu packages (koji built http://koji.fedoraproject.org/koji/buildinfo?buildID=61502 )

2. Add rawhide repo to the system, do a yum update
⇒ everything works nicely, you end up with
dejavu-fonts-common dejavu-fonts-sans-mono dejavu-fonts-lgc-serif dejavu-fonts-lgc-sans-mono dejavu-fonts-serif dejavu-fonts-lgc-sans dejavu-fonts-sans dejavu-fonts-compat dejavu-fonts-lgc-compat

3. uninstall the new dejavu packages with rpm -e, and reinstall the original dejavu packages

4. try to perform a yum groupupdate Fonts
⇒ bang (same packages, same upgrade path)
Comment 4 seth vidal 2008-12-04 17:20:06 EST
okay, I've duplicated this and provided a fix here
http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=4d28a994dddfcd80a23eb5d0b83ed989dcbc4de8
Comment 5 Nicolas Mailhot 2008-12-06 04:59:36 EST
I probably did something wrong, but I could not reproduce the fix with the test font packages at http://nim.fedorapeople.org/fontpackages/

yum groupupdate Fonts 
Resolving Dependencies
--> Running transaction check
---> Package dejavu-fonts-sans.noarch 0:2.27-7.fc11 set to be updated
--> Processing Dependency: dejavu-fonts-common = 2.27-7.fc11 for package: dejavu-fonts-sans
---> Package cjkunifonts-uming.noarch 0:0.2.20080216.1-9.2.fc11 set to be updated
---> Package dejavu-fonts-serif.noarch 0:2.27-7.fc11 set to be updated
---> Package dejavu-fonts-sans-mono.noarch 0:2.27-7.fc11 set to be updated
---> Package thaifonts-scalable.noarch 0:0.4.9-3.fc9 set to be updated
--> Running transaction check
---> Package dejavu-fonts-common.noarch 0:2.27-7.fc11 set to be updated
--> Processing Conflict: dejavu-fonts-serif conflicts dejavu-fonts-experimental < 2.26-3
--> Processing Conflict: dejavu-fonts-serif conflicts dejavu-fonts < 2.26-3
--> Processing Conflict: dejavu-fonts-sans-mono conflicts dejavu-fonts-experimental < 2.26-3
--> Processing Conflict: dejavu-fonts-sans-mono conflicts dejavu-fonts < 2.26-3
--> Processing Conflict: dejavu-fonts-sans conflicts dejavu-fonts-experimental < 2.26-3
--> Processing Conflict: dejavu-fonts-sans conflicts dejavu-fonts < 2.26-3
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package dejavu-fonts-compat.noarch 0:2.27-7.fc11 set to be updated
--> Finished Dependency Resolution
dejavu-fonts-serif-2.27-7.fc11.noarch from local has depsolving problems
  --> dejavu-fonts-serif conflicts with dejavu-fonts
dejavu-fonts-sans-2.27-7.fc11.noarch from local has depsolving problems
  --> dejavu-fonts-sans conflicts with dejavu-fonts-experimental
dejavu-fonts-sans-2.27-7.fc11.noarch from local has depsolving problems
  --> dejavu-fonts-sans conflicts with dejavu-fonts
dejavu-fonts-sans-mono-2.27-7.fc11.noarch from local has depsolving problems
  --> dejavu-fonts-sans-mono conflicts with dejavu-fonts
dejavu-fonts-sans-mono-2.27-7.fc11.noarch from local has depsolving problems
  --> dejavu-fonts-sans-mono conflicts with dejavu-fonts-experimental
Error: dejavu-fonts-sans-mono conflicts with dejavu-fonts
Error: dejavu-fonts-sans-mono conflicts with dejavu-fonts-experimental
Error: dejavu-fonts-sans conflicts with dejavu-fonts
Error: dejavu-fonts-sans conflicts with dejavu-fonts-experimental
Error: dejavu-fonts-serif conflicts with dejavu-fonts
Comment 6 James Antill 2009-01-14 10:41:48 EST
Can you test with the 3.2.21 yum, and see what happens?
Comment 7 Akira TAGOH 2009-01-14 21:11:38 EST
That works fine now. Thanks!
Comment 8 Bill McGonigle 2010-06-25 20:30:13 EDT
Created attachment 427018 [details]
yum -d 9 update

Might this have regressed?  

Seeing the same symptom with yum-3.2.27-3.fc12.noarch, also upgrading from f10 (mythdora version upgrade).
Comment 9 Nicolas Mailhot 2010-06-26 07:40:18 EDT
For this particular upgrade path to work, you need to upgrade to F11 and then only to something else

Note You need to log in before you can comment on or make changes to this bug.