Bug 474529 - "I'm providing info" checkbox doesn't remove NEEDINFO flag
"I'm providing info" checkbox doesn't remove NEEDINFO flag
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
devel
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 05:29 EST by Chris Ward
Modified: 2013-06-23 22:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-05 04:11:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ward 2008-12-04 05:29:52 EST
Description of problem:
RE: Bug 440557

I set the NEEDINFO flag to 'any' bugproxy@us.ibm.com. Later, after the information request was sent back, I updated the bug and selected the check box field "I am providing the requested information for this bug." and saved. After saving, the bug remains in NEED_INFO

Version-Release number of selected component (if applicable):
3.2

How reproducible:
Currently always

Steps to Reproduce:
1. Select "I am providing the request info...."
2. Save
3. Bug is still in NEED_INFO
  
Actual results:
Bug remains in NEED_INFO even after selecting what would appear to be the 'drop need info' select box.

Expected results:
The bug would no longer have the NEED_INFO flag set

Additional info:
Comment 1 Chris Ward 2008-12-04 11:00:04 EST
Hmm, yeah, still can't cancel the needinfo on this bug. Other's worked alright. Maybe it's because this bug is set in the VERIFIED state?? Hmm...
Comment 2 David Lawrence 2008-12-04 11:35:28 EST
Quick question, did you add a comment when you set the "I am providing the request info...." checkbox? It requires a comment to be added along with checking the box. That may be the problem here. 

If that is the case, then it could be debated that this is a bug I suppose since a person may not add a comment and want to clear a previous needinfo request.

FWIW, the needinfo flag can be cleared manually by unsetting the needinfo flag in the flags section. The checkboxes/dropdowns under the comment box are merely shortcuts to the needinfo flag itself.

Dave
Comment 3 Chris Ward 2008-12-05 04:11:56 EST
That was the issue. I guess this isn't a bug, since we don't want people randomly remove the NEEDINFO even if they're not provided information. For the cases like mine, i could have simply removed the flag manually. Thanks for the info. It all makes sense.

Note You need to log in before you can comment on or make changes to this bug.