Bug 474540 - crash in libdrm_intel.so.1 (Intel X3100)
crash in libdrm_intel.so.1 (Intel X3100)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 06:25 EST by James
Modified: 2009-09-06 17:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 04:33:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from the hung session (214.77 KB, text/plain)
2008-12-04 06:25 EST, James
no flags Details
xorg.conf (728 bytes, text/plain)
2008-12-04 06:26 EST, James
no flags Details
stuck X server for 82845G/GL chipset (45.41 KB, text/plain)
2008-12-06 13:05 EST, Michal Jaegermann
no flags Details
another Xorg.log from a hung server (197.76 KB, application/octet-stream)
2009-02-18 06:28 EST, Milos Jakubicek
no flags Details

  None (edit)
Description James 2008-12-04 06:25:12 EST
Created attachment 325666 [details]
Xorg.0.log from the hung session

Description of problem:
X.org server got stuck in a "EQ overflowing. The server is probably stuck in an infinite loop" spin shortly after logging in.

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e7a26]
1: /usr/bin/Xorg(mieqEnqueue+0x291) [0x4c8591]
2: /usr/bin/Xorg(xf86PostMotionEventP+0xc4) [0x491494]
3: /usr/bin/Xorg(xf86PostMotionEvent+0xa9) [0x491669]
4: /usr/lib64/xorg/modules/input//synaptics_drv.so [0x3060832]
5: /usr/lib64/xorg/modules/input//synaptics_drv.so [0x3062de2]
6: /usr/bin/Xorg [0x47a765]
7: /usr/bin/Xorg [0x46b307]
8: /lib64/libc.so.6 [0x39edc32f60]
9: /lib64/libc.so.6(cfree+0x62) [0x39edc7a442]
10: /usr/lib64/libdrm_intel.so.1 [0x56a6428]
11: /usr/lib64/libdrm_intel.so.1 [0x56a6867]
12: /usr/lib64/libdrm_intel.so.1 [0x56a6ed5]
13: /usr/lib64/libdrm_intel.so.1 [0x56a705f]
14: /usr/lib64/xorg/modules/drivers//intel_drv.so(intel_batch_flush+0x7f) [0x1fd73cf]
15: /usr/lib64/xorg/modules/drivers//intel_drv.so [0x1fe1fae]
16: /usr/bin/Xorg [0x51cdb9]
17: /usr/bin/Xorg [0x4f7311]
18: /usr/bin/Xorg(BlockHandler+0x50) [0x44a320]
19: /usr/bin/Xorg(WaitForSomething+0x161) [0x4e4eb1]
20: /usr/bin/Xorg(Dispatch+0x7f) [0x4465ef]
21: /usr/bin/Xorg(main+0x45d) [0x42cd1d]
22: /lib64/libc.so.6(__libc_start_main+0xe6) [0x39edc1e546]
23: /usr/bin/Xorg [0x42c0f9]
[mi] mieqEnequeue: out-of-order valuator event; dropping.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

...repeat ad infinitum.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.5.3-5.fc10.x86_64
xorg-x11-drv-i810-2.5.0-3.fc10.x86_64

How reproducible:
Occasionally.

Actual results:
No response to keyboard or mouse click events, although the cursor still moved. Had to log in over SSH and manually kill Xorg.

Expected results:
Good behaviour.

Additional info:
Logs and config attached.
Comment 1 James 2008-12-04 06:26:18 EST
Created attachment 325667 [details]
xorg.conf

Note also that this was when running kernel-2.6.27.7-134.fc10.x86_64.
Comment 2 Michal Jaegermann 2008-12-06 13:05:14 EST
Created attachment 326011 [details]
stuck X server for 82845G/GL chipset

This is another one for but this time for "82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device".  No xorg.conf present at all.  This was after F8->F10 distro upgrade attempts to reuse xorg.conf from F8, where all this worked quite nicely, ended up with:

(EE) No devices detected.

Fatal server error:
no screens found
Comment 3 Michal Klich 2008-12-08 05:36:56 EST
I suffer from same bug.
My hardware: 
00:02.1 Display controller: Intel Corporation Mobile GME965/GLE960 Integrated Graphics Controller (rev 0c)

Kernel:
2.6.27.5-117.fc10.x86_64
2.6.27.7-134.fc10.x86_64

xorg:
xorg-x11-drv-i810-2.5.0-4.fc10.x86_64
xorg-x11-server-Xorg-1.5.3-5.fc10.x86_64 

I do not have a xorg.conf file.


X locks on both of them. Randomly locks and i am not able to do anything, though music is playing. I can just turn off my laptop.

Output of Xorg.0.log.old

exaCopyDirty: Pending damage region empty!                                             
[mi] EQ overflowing. The server is probably stuck in an infinite loop.                 

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x26) [0x4e7a26]
1: /usr/bin/X(mieqEnqueue+0x291) [0x4c8591]  
2: /usr/bin/X(xf86PostMotionEventP+0xc4) [0x491494]
3: /usr/bin/X(xf86PostMotionEvent+0xa9) [0x491669] 
4: /usr/lib64/xorg/modules/input//evdev_drv.so [0x7fc50b6eb126]
5: /usr/bin/X [0x47a765]                                       
6: /usr/bin/X [0x46b307]                                       
7: /lib64/libc.so.6 [0x7fc51ef58f60]                           
8: /lib64/libc.so.6(ioctl+0x7) [0x7fc51f003ff7]                
9: /usr/lib64/libdrm.so.2 [0x7fc51d992023]                     
10: /usr/lib64/libdrm.so.2(drmCommandWrite+0x1b) [0x7fc51d9922ab]
11: /usr/lib64/xorg/modules/drivers//intel_drv.so(I830Sync+0x118)[0x7fc51d712d38]
12: /usr/lib64/xorg/modules//libexa.so(exaWaitSync+0x5c) [0x7fc51c7a429c]         
13: /usr/lib64/xorg/modules//libexa.so(ExaDoPrepareAccess+0x91) [0x7fc51c7a5591]  
14: /usr/lib64/xorg/modules//libexa.so [0x7fc51c7aa749]                           
15: /usr/lib64/xorg/modules//libexa.so [0x7fc51c7aac7f]                           
16: /usr/lib64/xorg/modules//libexa.so(exaDoMigration+0x68f) [0x7fc51c7ab46f]     
17: /usr/lib64/xorg/modules//libexa.so [0x7fc51c7acbac]                           
18: /usr/lib64/xorg/modules//libexa.so(exaComposite+0x645) [0x7fc51c7ad2d5]       
19: /usr/bin/X [0x5291b8]                                                         
20: /usr/bin/X [0x5183fa]                                                         
21: /usr/bin/X(Dispatch+0x364) [0x4468d4]                                         
22: /usr/bin/X(main+0x45d) [0x42cd1d]                                             
23: /lib64/libc.so.6(__libc_start_main+0xe6) [0x7fc51ef44546]                     
24: /usr/bin/X [0x42c0f9]                                                         
[mi] mieqEnequeue: out-of-order valuator event; dropping.                         
[mi] EQ overflowing. The server is probably stuck in an infinite loop.            
[mi] mieqEnequeue: out-of-order valuator event; dropping.
Comment 4 Artem 2008-12-12 04:41:05 EST
The same for me.

Don't know if that's related see the following in xorg.log:

(EE) intel(0): Failed to set tiling on front buffer: rejected by kernel
(EE) intel(0): Failed to set tiling on back buffer: rejected by kernel
(EE) intel(0): Failed to set tiling on depth buffer: rejected by kernel
Comment 5 Matthew Stanton 2008-12-19 02:22:17 EST
I can confirm this bug with an intel GMA X3100 running Fedora 10 fully updated as off December 17th.  This happens when I am running Compiz or a game that requires 3D acceleration.  This appears to be a memory leak of some sort, because when I am playing a game the frame rate will start to slow down exponentially.  After that X just crashes.  I do not know how to get a terminal output, because I have to do a hard reset.  If anyone can explain to me on how I can get a report, I would gladly do it.
Comment 6 Michal Jaegermann 2008-12-21 23:12:01 EST
See bug 469292.  Using 'Option     "NoAccel"' as described in that report allows at least to have something more-or-less working while this bug is still present.
Comment 7 Artem 2009-02-05 05:19:49 EST
@Adam, is there any progress on the bug? Maybe there is help/testing needed?
Comment 8 Milos Jakubicek 2009-02-18 06:28:17 EST
Created attachment 332360 [details]
another Xorg.log from a hung server

Same problem here, attaching Xorg.log
Comment 9 Vedran Miletić 2009-09-06 04:33:30 EDT
This is fixed in Fedora 11, tested on my HP 6710s (GMA X3100, 965GM). If anyone is still experiencing this, please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.