Bug 474552 - ATA bug: exception Emask 0x50 SAct 0x0 SErr 0x400800 action 0x6 frozen
ATA bug: exception Emask 0x50 SAct 0x0 SErr 0x400800 action 0x6 frozen
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 07:47 EST by scott mcmahan
Modified: 2012-03-26 10:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:08:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmsg with HW bug (32.08 KB, text/plain)
2008-12-09 06:54 EST, scott mcmahan
no flags Details
log file (83.05 KB, text/plain)
2011-02-08 03:49 EST, markus.moll
no flags Details

  None (edit)
Description scott mcmahan 2008-12-04 07:47:44 EST
Description of problem:

  My SATA blu-ray burner is a very expensive brick because something
  is wrong with ATA support. The burner worked fine originally, but
  broke after a kernel reboot. This was originally running Fedora 8,
  but I just upgraded that box to Fedora 10, and I still get the
  error. This happens after a disc (CD, DVD, or BD) is completely
  burned, at the end of the burn process.

How reproducible:

Happens every time

Additional info:

  K3b Version: 1.0.5
  
  KDE Version: 3.5.10-1.fc10 Fedora
  QT Version:  3.3.8b
  Kernel:      2.6.27.5-117.fc10.i686
  Devices
  
  SONY BDRW BWU-200S 1.0a (/dev/sr0, ) [CD-R, CD-RW, CD-ROM, DVD-ROM,
  DVD-R, DVD-RW, DVD-R DL, BD-ROM, BD-R, BD-RE, DVD+R, DVD+RW, DVD+R DL]
  [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual
  Layer Jump, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential,
  DVD+RW, DVD+R, DVD+RW Dual Layer, DVD+R Dual Layer, CD-ROM, CD-R,
  CD-RW, BD-ROM, BD-R Sequential (SRM), BD-R Random (RRM), BD-RE] [SAO,
  TAO, Restricted Overwrite, Layer Jump, Random Recording, Sequential
  Recording, Sequential Recording + POW]
  
  growisofs
  -----------------------
  Executing 'builtin_dd if=/dev/fd/0 of=/dev/sr0 obs=32k seek=0'
  /dev/sr0: "Current Write Speed" is 8.2x1352KBps.
  :-[ WRITE@LBA=a90h failed with SK=0h/ASC=00h/ACQ=03h]: Input/output error
  :-( write failed: Input/output error
  /dev/sr0: flushing cache
  /dev/sr0: updating RMA
  /dev/sr0: closing session

From /var/log/messages:

  kernel: ata2.00: exception Emask 0x50 SAct 0x0 SErr 0x400800 action 0x6 frozen
  kernel: ata2.00: irq_stat 0x08000000, interface fatal error
  kernel: ata2: SError: { HostInt Handshk }
  kernel: ata2.00: cmd a0/01:00:00:00:80/00:00:00:00:00/a0 tag 0 dma 32768 out
  kernel:         cdb 2a 00 00 00 0a 90 00 00  10 00 00 00 00 00 00 00
  kernel:         res 50/00:03:00:00:80/00:00:00:00:00/a0 Emask 0x50 (ATA bus error)
  kernel: ata2.00: status: { DRDY }
  kernel: ata2: hard resetting link
Comment 1 Chuck Ebbert 2008-12-08 20:45:10 EST
"ATA bus error" looks like a hardware problem.

Can you boot the system and attach the file /var/log/dmesg after booting?
Comment 2 scott mcmahan 2008-12-09 06:54:42 EST
Created attachment 326287 [details]
dmsg with HW bug

dmsg file with HW bug

  ata2: softreset failed (device not ready)
  ata2: failed due to HW bug, retry pmp=0
  ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
  ata2.00: ATAPI: SONY    BDRW BWU-200S, 1.0a, max UDMA/66
  ata2.00: configured for UDMA/66
Comment 3 scott mcmahan 2009-01-06 07:03:29 EST
Ok, so what's going on with this bug? Anything new?

I don't even know where to start trying to diagnose something like this, because I am inexperienced with low-level ATA interfaces. Does "looks like a hardware problem" mean there is some kind of physical damage to my brand-new Blu-Ray burner? Or is it a problem talking to the hardware?
Comment 4 scott mcmahan 2009-01-12 09:35:23 EST
From December 4, 2008 to January 12, 2009 there has been no solution-oriented activity on this bug at all -- I know the holidays are part of that, but what is the status of this bug? I have supplied the requested information, but there has been no further activity since Dec 9. I don't really want a resolution as much as to know what the problem is so I can decide whether this is a hardware failure, driver failure, or what. I don't -- and I imagine there are few people on the planet who do -- know how to to diagnose this sort of ATA error message. I have search for this error extensively on google before even reporting the bug, and turned up nothing. I would be happy to go do my own research if I had any idea where to begin.

Please give me more information on the cryptic "looks like a hardware problem" -- does this mean my brand-new Blu-Ray burner is damaged? The burned worked initially. I used it for monthly backups, so some time between one month and the next something happened.

What does "failed due to HW bug, retry pmp=0" mean and where can I get more information on it?

Thanks for any help possible -- if this is hardware damage, I will need to get service on the Blu-Ray while it is under warranty. I have never had this sort of low-level ATA error happen with Linux before and don't know how to diagnose it.
Comment 5 scott mcmahan 2009-01-27 12:10:16 EST
Ok, so no response at all - making a bug report was a waste of time - I am going to look at other distributions besides Fedora from now on. I could understand if Fedora had bleeding-edge new stuff that wasn't working. I don't have any problems with that. But I have problems with existing, working code suddenly breaking to the point the systems aren't usable.
Comment 7 Andrew D. 2009-06-11 13:39:51 EDT
I'm not sure if this is a hardware problem. I recently noticed this on RedHat Enterprise 5.3 using a DVD+-RW TS-H653B. The reason I'm thinking this might not be a HW error is that I get the error message in /var/log/messages for k3b (k3b-0.12.17-3.el5) but not when I use Nero Linux. Nero Linux works fine without generating any error messages. The message occurs under k3b when starting to write a DVD (haven't tried CD).
Comment 8 scott mcmahan 2009-06-11 13:57:54 EDT
I remember that this happened with BOTH k3b and Nero -- I installed Nero (just) to burn to a BD-R, and got the error, and since I was more comfortable with k3b than Nero on Linux, switched to it and got the same behavior. Neither will burn any discs -- CD, DVD, or BD-R.

This bug was reported 2008-12-04 and has had zero activity... I have a $500 paperweight with the Blu-Ray drive... it worked perfectly at first. I have BD-Rs I successfully burned. After a reboot, it quit working.

Since I used the Blu-Ray for monthly backups, I am not sure exactly when this broke because I noticed it when I did the end-of-month backups for Nov 2008 in early December. I would be happy to supply any needed info or do tests, but there has been no answer at all. I would be happy to isolate this as a physical drive error, if that was possible. I only have one SATA burner, the Blu-Ray, so I can't plug another SATA DVD burner in and test. All my other burners are IDE.

I don't know anything about SATA programming, so it's hard to investigate or debug this problem.
Comment 9 Andrew D. 2009-06-11 14:15:04 EDT
Unfortunately I'm pretty much in the dark with S/ATA as well. I guess one thing that could be tried to help isolate the problem is to hook up the drive to another machine. This might help figure out if the problem is with the drive or the motherboard interface. Or maybe try booting up with a live CD of another distro to see if it works under that distro. If it doesn't work under any scenario then it's likely a faulty drive. For the Bugzilla team, below is my dmesg output when I run k3b to burn a DVD (the message usually repeats about 3 times):

ata4.00: exception Emask 0x12 SAct 0x0 SErr 0x400 action 0x6 frozen
ata4.00: irq_stat 0x08000000, interface fatal error
ata4: SError: { Proto }
ata4.00: cmd a0/00:00:00:02:00/00:00:00:00:00/a0 tag 0 pio 2 in
         cdb ad 00 00 00 00 00 00 00  00 04 00 00 00 00 00 00
         res 50/00:03:00:08:00/00:00:00:00:00/a0 Emask 0x12 (ATA bus error)
ata4.00: status: { DRDY }
ata4: hard resetting link
ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata4.00: configured for UDMA/100
ata4: EH complete

Our messages aren't identical but that might be just due to hardware differences.
Comment 10 Kostya Berger 2009-07-11 17:10:48 EDT
Hi everyone. It seems, I have some good news. I just had this 'BUG', and then it was "healed" completely by unplugging and then plugging in again of the SATA HDD interface cable. Just 2 minutes ago my computer froze on boot with the following output repeated several times:

ata5.00: exception Emask 0x50 SAct 0x1ff SErr 0x280900 action 0x6 frozen
ata5.00: irq_stat 0x08000000, interface fatal error                     
ata5: SError: { UnrecovData HostInt 10B8B BadCRC }                      
ata5.00: cmd 60/50:00:5d:7b:76/01:00:11:00:00/40 tag 0 ncq 172032 in    
ata5.00: status: { DRDY }                                               
ata5.00: cmd 60/80:08:9f:00:00/00:00:00:00:00/40 tag 1 ncq 65536 in     
ata5.00: status: { DRDY }                                               
ata5.00: cmd 60/20:10:aa:15:2e/00:00:12:00:00/40 tag 2 ncq 16384 in     
ata5.00: status: { DRDY }                                               
ata5.00: cmd 60/08:18:97:15:2e/00:00:12:00:00/40 tag 3 ncq 4096 in      
ata5.00: status: { DRDY }                                               
ata5.00: cmd 60/a8:20:9c:3c:76/00:00:11:00:00/40 tag 4 ncq 86016 in     
ata5.00: status: { DRDY }                                               
ata5.00: cmd 60/40:28:5f:00:00/00:00:00:00:00/40 tag 5 ncq 32768 in     
ata5.00: status: { DRDY }                                               
ata5.00: cmd 60/08:30:bc:ef:aa/00:00:1d:00:00/40 tag 6 ncq 4096 in      
ata5.00: status: { DRDY }                                               
ata5.00: cmd 60/08:38:3c:6d:ab/00:00:1d:00:00/40 tag 7 ncq 4096 in      
ata5.00: status: { DRDY }                                               
ata5.00: cmd 60/30:40:ad:7c:76/00:00:11:00:00/40 tag 8 ncq 24576 in     
ata5.00: status: { DRDY }                                               
ata5: hard resetting link                                               
ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 310)                  
ata5.00: configured for UDMA/100                                        
ata5: EH complete                                                    

after that it booted OK into KDE 4.1. But when I commanded to reboot, it even froze on "going to reboot"!... (So I used 'RESET' -- my favourite;-))
I also had similar problem a few weeks ago, when my BRAND NEW SATA HDD failed unexpectedly after a few weeks from purchase. 
I immediately suspected some bad fixing of the interface cable (HDD-motherboard). Well I unplugged it and plugged in again and -- voilà! -- it worked just fine.


MY VERDICT? The SATA information cable is of BAD CONSTRUCTION. Look how easily it gets loose in its socket, if compared with IDE! What with some constant vibration always present in the computer case, you should expect it to get loose one fine day. 

OK! This is my experience with this 'bug'; hope it could help somebody else.
Comment 11 Kostya Berger 2009-07-11 17:21:25 EDT
You might want to look at this thread 
http://ubuntuforums.org/showthread.php?t=598837.

This problem WAS SOLVED back in January 2008. It is THE CABLE, just as I suspected. The guy bought a "SATAII" marked cable with some kind of lock on the end, which fixed it after all. Why won't you guys try this one?

Regards and best wishes,
Kostya Berger
Comment 12 Bug Zapper 2009-11-18 04:38:04 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Bug Zapper 2009-12-18 02:08:59 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 14 markus.moll 2011-02-08 03:46:38 EST
This bug seems to have been closed too early.
I have recently experienced exactly the same behaviour on Fedora 14.
Most other similar bug reports report spontaneous or permanent emission of ata errors, while I have the same problem described here: the error occurs _only_ after "successfully" burning a CD (or in the finalization step). After that, the CD is usually garbage. (The same CD, a collection of files, burns perfectly in Windows using Nero)

The error here is:
  ata2.00: exception Emask 0x12 SAct 0x0 SErr 0x1000400 action 0x6 frozen
  ata2.00: irq_stat 0x08000000, interface fatal error
  ata2: SError: { Proto TrStaTrns }
  sr 1:0:0:0: [sr0] CDB: Volume set (in), Read cd: be 00 ff ff ff ff 00 00 01 10 00 00
  ata2.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
           res 50/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x12 (ATA bus error)
  ata2.00: status: { DRDY }
  ata2: hard resetting link
  ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
  ata2.00: configured for UDMA/100
  ata2: EH complete

(full log attached)

I have replaced the DVD burner, the SATA cable, have swapped the SATA port, and have tried different burning applications (brasero, k3b). The error remained the same after all these steps (save the port number in ata2)
Comment 15 markus.moll 2011-02-08 03:49:01 EST
Created attachment 477576 [details]
log file
Comment 16 melchiaros 2012-03-26 10:20:31 EDT
This bug is still present in recent kernel serie 3.0.x

Look at:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/965213

Note You need to log in before you can comment on or make changes to this bug.