This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 474553 - crazy mouse pointer
crazy mouse pointer
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
10
All Linux
low Severity urgent
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
http://forums.fedoraforum.org/showthr...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 07:47 EST by bee
Modified: 2013-01-09 23:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 10:44:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (17.36 KB, image/png)
2008-12-04 07:48 EST, bee
no flags Details

  None (edit)
Description bee 2008-12-04 07:47:59 EST
Description of problem:
http://forums.fedoraforum.org/showthread.php?t=206443
after the update of today, in place of the cursor icon, i see some random pixels...
The GUI is close to be unusable.

the green arrow in the attached picture, points to what is my mouse at the moment. Some time it switches to a white/transparent picture, and i cannot even see my cursor!!

Version-Release number of selected component (if applicable):
Fedora 10, GNOME 2.41.1
And the last updated components (the update i did today):
[root@localhost ~]# cat /var/log/yum.log | grep "Dec 04"
Dec 04 12:36:33 Updated: glib2-2.18.3-2.fc10.i386
Dec 04 12:36:34 Updated: libtalloc-1.2.0-23.fc10.i386
Dec 04 12:36:34 Updated: libtdb-1.1.1-23.fc10.i386
Dec 04 12:36:34 Updated: nspr-4.7.3-1.fc10.i386
Dec 04 12:36:39 Updated: evolution-data-server-2.24.2-1.fc10.i386
Dec 04 12:36:41 Updated: 1:qt-4.4.3-6.fc10.i386
Dec 04 12:36:44 Updated: gtkhtml3-3.24.2-1.fc10.i386
Dec 04 12:37:45 Updated: evolution-2.24.2-1.fc10.i386
Dec 04 12:37:46 Updated: libtirpc-0.1.10-1.fc10.i386
Dec 04 12:37:46 Updated: 32:bind-libs-9.5.1-0.9.b3.fc10.i386
Dec 04 12:37:50 Updated: 1:qt-x11-4.4.3-6.fc10.i386
Dec 04 12:38:02 Updated: sbcl-1.0.22-1.fc10.i386
Dec 04 12:38:04 Updated: openobex-1.4-1.fc10.i386
Dec 04 12:38:29 Updated: selinux-policy-3.5.13-26.fc10.noarch
Dec 04 12:39:14 Updated: selinux-policy-targeted-3.5.13-26.fc10.noarch
Dec 04 12:39:25 Updated: evolution-help-2.24.2-1.fc10.i386
Dec 04 12:39:25 Updated: evolution-perl-2.24.2-1.fc10.i386
Dec 04 12:39:26 Updated: nspr-devel-4.7.3-1.fc10.i386
Dec 04 12:39:32 Updated: phpMyAdmin-3.1.0-1.fc10.noarch
Dec 04 12:39:33 Updated: docbook-utils-0.6.14-15.fc10.noarch
Dec 04 12:39:34 Updated: 32:bind-utils-9.5.1-0.9.b3.fc10.i386
Dec 04 12:39:35 Updated: rpcbind-0.1.7-1.fc10.i386
Dec 04 12:39:40 Updated: glib2-devel-2.18.3-2.fc10.i386
Dec 04 12:39:40 Updated: 1:xorg-x11-drv-nouveau-0.0.11-1.20081119git65b956f.fc10.i386
Dec 04 12:39:41 Updated: sed-4.1.5-11.fc10.i386
Dec 04 12:39:42 Updated: xorg-x11-drv-ati-6.9.0-59.fc10.i386
Dec 04 12:39:43 Updated: samba-winbind-3.2.5-0.23.fc10.i386
Dec 04 12:39:46 Updated: samba-common-3.2.5-0.23.fc10.i386
Dec 04 12:40:05 Updated: maxima-5.16.3-4.fc10.i386
Dec 04 12:40:08 Updated: maxima-runtime-sbcl-5.16.3-4.fc10.i386
Dec 04 12:40:12 Updated: wxMaxima-0.7.6-1.fc10.i386
Dec 04 12:40:15 Updated: samba-3.2.5-0.23.fc10.i386
Dec 04 12:40:17 Updated: samba-client-3.2.5-0.23.fc10.i386
Dec 04 12:40:18 Updated: libsmbclient-3.2.5-0.23.fc10.i386


How reproducible:
at each boot

Steps to Reproduce:
1. yum update
2. reboot
3.
  
Actual results:
the mouse cursors is a bunch of pixels

Expected results:
updating the system without damaging it, maybe?

Additional info:
Now, like before:
glxinfo | grep direct
direct rendering: Yes
but before that update the system were working, including the mouse.
Comment 1 bee 2008-12-04 07:48:47 EST
Created attachment 325671 [details]
screenshot
Comment 2 Simon Blakely 2008-12-04 08:47:31 EST
I have this problem also. Setting nomodeset has given a more reliable mouse pointer, but other graphics (menu icons, taskbar icons) are corrupted. If an icon is corrupt, it will be ok when highlighted - ok icons are corrupt when highlighted.

Problem occurred following updates 4/12/08
Dec 04 09:31:17 Updated: glib2-2.18.3-2.fc10.i386           
Dec 04 09:31:21 Updated: 1:qt-4.4.3-6.fc10.i386
Dec 04 09:31:22 Updated: libtalloc-1.2.0-23.fc10.i386
Dec 04 09:31:22 Updated: libtdb-1.1.1-23.fc10.i386
Dec 04 09:31:39 Updated: 1:qt-x11-4.4.3-6.fc10.i386
Dec 04 09:31:40 Updated: nspr-4.7.3-1.fc10.i386
Dec 04 09:31:48 Updated: evolution-data-server-2.24.2-1.fc10.i386
Dec 04 09:31:52 Updated: gtkhtml3-3.24.2-1.fc10.i386
Dec 04 09:31:53 Updated: libtirpc-0.1.10-1.fc10.i386
Dec 04 09:31:56 Updated: 32:bind-libs-9.5.1-0.9.b3.fc10.i386
Dec 04 09:31:57 Updated: libmtp-0.3.4-1.fc10.i386
Dec 04 09:33:01 Updated: evolution-2.24.2-1.fc10.i386
Dec 04 09:33:17 Updated: amarok-1.98-1.fc10.i386
Dec 04 09:33:25 Updated: ktorrent-3.1.5-1.fc10.i386
Dec 04 09:33:38 Updated: sbcl-1.0.22-1.fc10.i386
Dec 04 09:33:39 Updated: openobex-1.4-1.fc10.i386
Dec 04 09:33:39 Updated: 32:bind-utils-9.5.1-0.9.b3.fc10.i386
Dec 04 09:33:46 Updated: rpcbind-0.1.7-1.fc10.i386
Dec 04 09:33:49 Updated: kdeartwork-4.1.3-3.fc10.i386
Dec 04 09:33:50 Updated: 1:qt-mysql-4.4.3-6.fc10.i386
Dec 04 09:33:50 Updated: 1:xorg-x11-drv-nouveau-0.0.11-1.20081119git65b956f.fc10.i386
Dec 04 09:33:52 Updated: sed-4.1.5-11.fc10.i386
Dec 04 09:33:52 Updated: xorg-x11-drv-ati-6.9.0-59.fc10.i386
Dec 04 09:34:23 Updated: selinux-policy-3.5.13-26.fc10.noarch
Dec 04 09:35:18 Updated: selinux-policy-targeted-3.5.13-26.fc10.noarch
Dec 04 09:35:18 Updated: evolution-perl-2.24.2-1.fc10.i386
Dec 04 09:35:31 Updated: maxima-5.16.3-4.fc10.i386
Dec 04 09:35:32 Updated: samba-winbind-3.2.5-0.23.fc10.i386
Dec 04 09:35:37 Updated: samba-common-3.2.5-0.23.fc10.i386
Dec 04 09:35:40 Updated: maxima-runtime-sbcl-5.16.3-4.fc10.i386
Dec 04 09:35:42 Updated: wxMaxima-0.7.6-1.fc10.i386
Dec 04 09:35:45 Updated: samba-client-3.2.5-0.23.fc10.i386
Dec 04 09:35:45 Updated: libsmbclient-3.2.5-0.23.fc10.i386
Comment 3 Simon Blakely 2008-12-04 08:59:45 EST
Just to add, this error affects KDE applications, so maybe relates to qt-x11-4.4.3-6.fc10.i386
Comment 4 bee 2008-12-04 09:06:14 EST
(In reply to comment #3)
> Just to add, this error affects KDE applications, so maybe relates to
> qt-x11-4.4.3-6.fc10.i386

i don't have KDE installed.
I've only GNOME and i have this problem starting from the login screen.
(unlucky:P) it isn't a KDE-related problem.
Comment 5 Simon Blakely 2008-12-04 09:16:51 EST
Try nomodeset as a kernel option in /boot/grub/grub.conf
Comment 6 bee 2008-12-04 09:33:58 EST
(In reply to comment #5)
> Try nomodeset as a kernel option in /boot/grub/grub.conf

WOW!! that trick work!
Whit your workaround my system works and i'm able to see my mouse pointer again!
I've only "quiet nomodeset" as kernel parameters (i have removed the rhbg option). At the startup (and and on the other consoles ctrl+alt+f2 etc) the resolution isn't the same of before.
Can you tell me what "nomodeset" is useful for? because it work (even if with a couple of side effects), but i don't have understand why...

thanks a lot!
Comment 7 Simon Blakely 2008-12-04 10:07:46 EST
nomodeset disables graphic code mode setting in the kernel - you lose the graphical boot screen and flickerless x startup.

My continuing issue relates to KDE/QT apps and should probably be moved to a separate bug.
Comment 8 bee 2008-12-04 10:12:17 EST
Thank you Simon.
Yes, that workaround has also some side effects... for example i'm unable to play at Urban Terror... and look the output of glxgears
(fullscreen)
85 frames in 5.1 seconds = 16.811 FPS
85 frames in 5.0 seconds = 16.922 FPS
85 frames in 5.0 seconds = 16.849 FPS
(window)
938 frames in 5.0 seconds = 187.532 FPS
937 frames in 5.0 seconds = 187.302 FPS
931 frames in 5.0 seconds = 186.024 FPS
935 frames in 5.0 seconds = 186.874 FPS
My FPS in a window were over 1000 before the nomodeset argument in the
kernel...

So, this bug report isn't ended yet, because even if that workaround "works" for
normal work/browsing, it isn't a final solution for my problem. 
Good luck for the qt/kde issue also.
Comment 9 J McBride 2008-12-04 18:06:16 EST
Same behavior here.

Smolt Profile:
	Default run level: 5
	Language: en_US.UTF-8
	Platform: x86_64
	BogoMIPS: 2009.08
	CPU Vendor: AuthenticAMD
	CPU Model: AMD Athlon(tm) 64 X2 Dual Core Processor 5600+
	Number of CPUs: 2
	CPU Speed: 2800
	System Memory: 3967
	System Swap: 5951
	Vendor: System manufacturer
	System: System Product Name System Version
	Form factor: desktop
	Kernel: 2.6.27.5-117.fc10.x86_64
	SELinux Enabled: True
	SELinux Policy: targeted
	SELinux Enforce: Enforcing

		 Devices
		=================================
		(None:None:None:None) ppdev, Unknown, None, Parallel Port Device
		(None:None:None:None) scsi_generic, Unknown, None, SCSI Generic Interface
		(None:None:None:None) scsi, sr, None, SCSI Device
		(None:None:None:None) input, Unknown, None, PC Speaker
		(None:None:None:None) input, Unknown, MOUSE, Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)
		(None:None:None:None) input, Unknown, KEYBOARD, Generic USB+PS2 Keyboard
		(None:None:None:None) pnp, rtc_cmos, None, AT Real-Time Clock
		(4098:29312:4163:386) pci, Unknown, VIDEO, RV570 [Radeon X1950 Pro]
		(None:None:None:None) pnp, serial, None, 16550A-compatible COM port
		(None:None:None:None) scsi_host, Unknown, None, SCSI Host Adapter
		(None:None:None:None) scsi, sd, None, SCSI Device
		(4318:1009:4163:33332) pci, ohci_hcd, USB, MCP61 USB Controller
		(4318:1008:4163:33332) pci, HDA Intel, OTHER, MCP61 High Definition Audio
		(None:None:None:None) platform, Unknown, None, Platform Device (floppy.0)
		(None:None:None:None) input, Unknown, MOUSE, Microsoft Microsoft Basic Optical Mouse
		(None:None:None:None) scsi_host, Unknown, None, SCSI Host Adapter
		(None:None:None:None) platform, Unknown, None, Platform Device (vesafb.0)
		(None:None:None:None) pnp, parport_pc, None, Standard LPT printer port
		(None:None:None:None) net, Unknown, NETWORK, Loopback device Interface
		(None:None:None:None) net, Unknown, NETWORK, Networking Interface
		(4098:29344:4163:387) pci, Unknown, VIDEO, RV570 [Radeon X1950 Pro] (secondary)
		(None:None:None:None) net, Unknown, NETWORK, Bridge Interface
		(1118:64:None:None) usb, usbhid, OTHER, USB HID Interface
		(None:None:None:None) scsi_host, Unknown, None, SCSI Host Adapter
		(None:None:None:None) platform, i8042, None, Platform Device (i8042)
		(None:None:None:None) platform, pcspkr, None, Platform Device (pcspkr)
		(4318:1013:4163:33332) pci, Unknown, OTHER, MCP61 Memory Controller
		(4318:1014:4163:33332) pci, sata_nv, IDE, MCP61 SATA Controller
		(4318:1011:0:0) pci, Unknown, OTHER, MCP61 PCI bridge
		(4318:1010:4163:33332) pci, ehci_hcd, USB, MCP61 USB Controller
		(None:None:None:None) scsi_host, Unknown, None, SCSI Host Adapter
		(4130:4352:0:0) pci, Unknown, OTHER, K8 [Athlon64/Opteron] HyperTransport Technology Configuration
		(4130:4353:0:0) pci, Unknown, OTHER, K8 [Athlon64/Opteron] Address Map
		(4130:4354:0:0) pci, Unknown, OTHER, K8 [Athlon64/Opteron] DRAM Controller
		(4130:4355:0:0) pci, k8temp, OTHER, K8 [Athlon64/Opteron] Miscellaneous Control
		(3426:28:None:None) usb, usbhid, OTHER, USB HID Interface
		(3426:28:None:None) usb, usbhid, OTHER, USB HID Interface
		(None:None:None:None) input, Unknown, KEYBOARD, Generic USB+PS2 Keyboard
		(None:None:None:None) input, Unknown, MOUSE, Macintosh mouse button emulation
		(4318:1014:4163:33332) pci, sata_nv, IDE, MCP61 SATA Controller
		(None:None:None:None) scsi_host, Unknown, None, SCSI Host Adapter
		(None:None:None:None) pnp, i8042 kbd, None, IBM Enhanced (101/102-key, PS/2 mouse support)
		(None:None:None:None) scsi_host, Unknown, None, SCSI Host Adapter
		(None:None:None:None) scsi_host, Unknown, None, SCSI Host Adapter
		(4318:1001:0:0) pci, pcieport-driver, OTHER, MCP61 PCI Express bridge
		(None:None:None:None) input, Unknown, None, Power Button (FF)
		(1118:132:None:None) usb, usbhid, OTHER, USB HID Interface
		(None:None:None:None) scsi_generic, Unknown, None, SCSI Generic Interface
		(4318:1007:4163:33332) pci, forcedeth, OTHER, MCP61 Ethernet
		(None:None:None:None) input, Unknown, None, Power Button (CM)
		(4318:1002:4163:33332) pci, Unknown, OTHER, MCP61 Memory Controller
		(4318:1003:4163:33332) pci, nForce2_smbus, OTHER, MCP61 SMBus
		(4318:1004:4163:33332) pci, pata_amd, IDE, MCP61 IDE
		(None:None:None:None) tty, Unknown, None, 16550A-compatible COM port
		(None:None:None:None) platform, serial8250, None, Platform Device (serial8250)
		(None:None:None:None) serio, atkbd, None, i8042 KBD port
		(None:None:None:None) input, Unknown, KEYBOARD, AT Translated Set 2 keyboard
		(4318:992:4163:33332) pci, Unknown, OTHER, MCP61 LPC Bridge
		(4318:1000:0:0) pci, pcieport-driver, OTHER, MCP61 PCI Express bridge
		(4318:1001:0:0) pci, pcieport-driver, OTHER, MCP61 PCI Express bridge
		(None:None:None:None) scsi_host, Unknown, None, SCSI Host Adapter
		(None:None:None:None) drm, Unknown, None, Direct Rendering Manager Device

	Filesystem Information
		device mtpt type bsize frsize blocks bfree bavail file ffree favail
		===================================================================
		/dev/root / ext3 4096 4096 16304075 15334202 14505991 4145152 4024910 4024910
		/dev/sda1 /boot ext3 1024 1024 194442 180179 170140 50200 50164 50164


Same update information as the posters above.

Hope this helps.
Comment 10 pillowmeto 2008-12-05 00:14:26 EST
Similar problem, mouse not visible but functioning.  Would someone mind explaining the "Try nomodeset as a kernel option in /boot/grub/grub.conf" fix to the computer illiterate, or point us in the direction of an explanation?
Comment 11 Simon Blakely 2008-12-05 02:34:01 EST
/boot/grub/grub.conf is a file you can edit that controls the boot options. One line defines the kernel as follows (your kernel line will be somewhat different, but I am away from my laptop)
        kernel /vmlinuz-2.6.27.5-117 ro root=/dev/hda3 
There may be options appended to this line - so the nomodeset option should be added.
        kernel /vmlinuz-2.6.27.5-117 ro root=/dev/hda3 nomodeset

To edit the grub.conf, you need to be running as root, so
su -
kwrite /boot/grub/grub.conf &

However, nomodeset impacts the way video drivers are loaded into the kernel, and can result in slower video drivers being loaded, impacting some aspects of performance. It is a workaround.
Comment 12 John Chivall 2008-12-05 06:18:48 EST
Confirmed with xorg-x11-drv-ati-6.9.0
using VGA compatible controller: ATI Technologies Inc RV530 [Radeon X1600]
Comment 13 rockonthemoonfm 2008-12-07 12:43:16 EST
same problem here.
the cursor is a 1" pixeled square, very annoying
running a new netinstal fedora 10 x64
on a radeon 1300 - rv500 chip

i don't want nomodesetting, i changed to fedora for being on a bleeding-edge!
how to keep KMS plymouth and exa acceleration and see the essential mouse pointer?
Comment 14 bee 2008-12-08 16:10:33 EST
with the update of today, looks like the problem has been finally solved!
all works here!
Comment 15 bee 2008-12-09 10:44:31 EST
closed

Note You need to log in before you can comment on or make changes to this bug.