Bug 474575 - atop not fully functional
atop not fully functional
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: atop (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kairo Francisco de Araujo
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 10:04 EST by Vladimir Ivanovic
Modified: 2008-12-04 10:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 10:12:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Ivanovic 2008-12-04 10:04:58 EST
Description of problem: "When atop is used on a system running a standard Linux-kernel, no information is available about the disk- and network-accesses issued per process. This means a.o. that the selection 'd' (show disk-transfers per process) and 'n' (show network-transfers per process) can not be used, and that the columns shown in the generic screen are different." 
--- http://www.atcomputing.nl/Tools/atop/kernpatch.html


Version-Release number of selected component (if applicable): all versions


How reproducible:n Run atop


Steps to Reproduce:
1. atop
2. Press 'N'
3.
  
Actual results:
Error message: "No kernel patch installed; request ignored!"

Expected results:
A new screen with per-process network activity shown.

Additional info:
I have run Gentoo kernels with these two patches installed without any problems. I am now compiling a Fedora 2.6.17.5-117.fc10.i686 (SMP) kernel with the patches. (I had to increase the patch fuzz to 3 (probably overkill) to get the atop patches to install cleanly.) I'll report any problems. Silence means no problems.
Comment 1 manuel wolfshant 2008-12-04 10:12:49 EST
This is not a bug or a lack of features in atop. Please ask the kernel team to include the needed patches.

Note You need to log in before you can comment on or make changes to this bug.