Bug 474584 - zd1211 has broken sysfs 'driver' link
zd1211 has broken sysfs 'driver' link
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 10:42 EST by Jurica Vukadin
Modified: 2008-12-29 07:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-29 07:59:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jurica Vukadin 2008-12-04 10:42:31 EST
Description of problem:
Since day before yesterday (I suppose after yum update & reboot) NetworkManager 
does not detect my wireless device anymore. This line is showing in
/var/log/messages:
Dec  4 16:26:37 localhost NetworkManager: nm_device_wifi_new: assertion `driver != NULL' failed

On Dec 2, everything was working fine:
Dec  2 16:48:53 localhost NetworkManager: <info>  wlan0: driver is 'zd1211rw'.


Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.12.svn4326.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
Simply boot the system.
  
Actual results:
NetworkManager can't detect/connect the device.

Expected results:
NetworkManager detects/connects

Additional info:
Wireless device(lsusb):
Bus 001 Device 004: ID 0ace:1215 ZyDAS WLA-54L WiFi
Kernel driver: zd1211rw
Comment 1 Jurica Vukadin 2008-12-06 05:27:37 EST
This seems to be caused by HAL somehow, there is no info.linux.driver property for the device:
[jura@eriador src]$ hal-device /org/freedesktop/Hal/devices/net_00_11_3b_04_b4_25
udi = '/org/freedesktop/Hal/devices/net_00_11_3b_04_b4_25'
  info.capabilities = { 'net', 'net.80211' } (string list)
  net.80211.mac_address = 74004608037  (0x113b04b425)  (uint64)
  info.subsystem = 'net'  (string)
  info.product = 'WLAN Interface'  (string)
  net.physical_device = '/org/freedesktop/Hal/devices/usb_device_ace_1215_noserial_if0'  (string)
  info.udi = '/org/freedesktop/Hal/devices/net_00_11_3b_04_b4_25'  (string)
  net.originating_device = '/org/freedesktop/Hal/devices/usb_device_ace_1215_noserial_if0'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:02.1/usb1/1-4/1-4:1.0/net/wlan0'  (string)
  info.parent = '/org/freedesktop/Hal/devices/usb_device_ace_1215_noserial_if0'  (string)
  net.interface = 'wlan0'  (string)
  net.address = '00:11:3b:04:b4:25'  (string)
  net.linux.ifindex = 3  (0x3)  (int)
  linux.hotplug_type = 2  (0x2)  (int)
  info.category = 'net.80211'  (string)
  net.arp_proto_hw_id = 1  (0x1)  (int)
  linux.subsystem = 'net'  (string)
Comment 2 Jurica Vukadin 2008-12-06 05:48:26 EST
Hm, manually setting the property doesn't help. It still bails with the failed assertion.
Comment 3 Dan Williams 2008-12-09 12:14:56 EST
What exact kernel version and hal version do you have?

What's the output of:

ls -al /sys/class/net/wlan0/device/driver

it should look something like:

lrwxrwxrwx 1 root root 0 2008-12-09 12:13 /sys/class/net/eth2/device/driver -> ../../../../bus/pci/drivers/ipw2200
Comment 4 Jurica Vukadin 2008-12-09 12:46:24 EST
[jura@eriador ~]$ rpm -q kernel
kernel-2.6.27.5-117.fc10.x86_64

[jura@eriador ~]$ rpm -q hal
hal-0.5.12-12.20081027git.fc10.x86_64

[jura@eriador ~]$ ls -al /sys/class/net/wlan0/device/driver
lrwxrwxrwx 1 root root 0 2008-12-09 16:40 /sys/class/net/wlan0/device/driver -> ../../../../../../bus/usb/drivers/zd1211rw

But the link is broken... 
[jura@eriador ~]$ ls -l /sys/bus/usb/drivers
total 0
dr-xr-xr-x 2 root root 0 2008-12-09 17:40 001
dr-xr-xr-x 2 root root 0 2008-12-09 17:40 002
-r--r--r-- 1 root root 0 2008-12-09 16:40 devices

I'm updating to kernel-2.6.27.7-134.fc10.x86_64, will let you know how it goes.
Comment 5 Jurica Vukadin 2008-12-09 12:54:07 EST
Nope, no change with latest kernel.
Comment 6 Dan Williams 2008-12-09 12:54:23 EST
Ok, it's a kernel bug then; if that link doesn't work, HAL can't get the driver name, and thus NM can't get the driver name either.
Comment 7 John W. Linville 2008-12-18 13:52:06 EST
Can you replicate this with a current rawhide kernel?
Comment 8 Jurica Vukadin 2008-12-18 17:27:56 EST
Yep, reproducible with 2.6.28-0.129.rc8.git2.fc11.x86_64
Comment 9 Jurica Vukadin 2008-12-20 05:06:14 EST
Oddly enough, it works with the same kernel (2.6.27.5-117.fc10.x86_64) on the live cd, but not on my machine. I think I'll just reinstall.
Comment 10 Jurica Vukadin 2008-12-29 07:59:10 EST
OK, I figured it out. I had this line in fstab (because of VirtualBox), which overwrote the directory:
none on /sys/bus/usb/drivers type usbfs (rw,devgid=501,devmode=664)

Note You need to log in before you can comment on or make changes to this bug.