Bug 474591 - Alias /cgi-mod-perl/ should point to /usr/share
Alias /cgi-mod-perl/ should point to /usr/share
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
: Reopened
Depends On:
Blocks: space13
  Show dependency treegraph
 
Reported: 2008-12-04 10:58 EST by Miroslav Suchý
Modified: 2011-02-08 03:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-08 03:40:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2008-12-04 10:58:04 EST
We have alias /cgi-mod-perl/ in Apache conf which points to /var/www/cgi-mod-perl/.
According to http://fedoraproject.org/wiki/Packaging/Guidelines#Web_Applications
it should point to /usr/share.


Affected packages:
NPalert
SputLite-server
SNMPAlerts
Comment 1 Miroslav Suchý 2008-12-04 11:02:19 EST
And spacewalk-config
Comment 2 Miroslav Suchý 2008-12-04 12:01:31 EST
Commited as fd777d47413dacc43865d98afbdb659e8e457f11
Comment 3 Michael Mráka 2009-01-15 08:13:38 EST
Still points to old location.

[root@xen35 ~]# grep -i alias /etc/rhn/satellite-httpd/conf/rhn/*
/etc/rhn/satellite-httpd/conf/rhn/rhn_monitoring.conf:Alias /cgi-mod-perl/ /var/www/cgi-mod-perl/
Comment 4 Miroslav Suchý 2009-01-15 08:19:53 EST
It is due that Milan revert it back to /var/www/ due to change back to stock httpd.
I'm going to postpone this changes to Spacewalk 0.4.
I'm giving this to Milan so he can finish what he start. :)
Comment 5 Milan Zázrivec 2010-01-31 16:11:15 EST
The assertion from comment #4 is false. I did not start any reverting whatsoever.

It was in fact started by Dave Parker with commit
968f20039b1c18d2c3ea610268cfda85ba53a5ff

The decision to move the monitoring cgi scripts back to /var/www was made by
Dave Parker; the only thing I did was that I alerted him about the fact that
the commit 968f20039b1c18d2c3ea610268cfda85ba53a5ff is incomplete and that
for the monitoring to work correctly, more scripts need to be moved to the
original location. After this, I was asked (in a nice way) by Dave Parker
to finish the task for him, which I did.

This was done few days before the release of Spacewalk 0.4 (Jan 10 2010 in
fact) and in the release time frame, there was no time for any more monitoring
shenanigans.

Also, I'd like to emphasise the fact that this was not my decision and as such
I don't recognize this as my fight.

I want to encourage anybody, who still sees this as a major scar on the
face of Spacewalk to take over the ownership of the bug.
Comment 6 Miroslav Suchý 2010-02-01 03:16:05 EST
Reopening and taking over.
Comment 7 Jan Pazdziora 2010-11-19 11:02:22 EST
Mass-moving to space13.
Comment 8 Miroslav Suchý 2010-11-20 07:09:07 EST
Fixed in commit 530200e879cfa42a7c3484c97b464f9993b346ba
Comment 9 Tomas Lestach 2011-02-03 07:21:10 EST
Moving ON_QA ...
Comment 10 Tomas Lestach 2011-02-08 03:40:52 EST
This bug has been fixed in Spacewalk 1.3.

Note You need to log in before you can comment on or make changes to this bug.