Bug 474613 - rhm : Unowned directories
rhm : Unowned directories
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qpidc (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Alan Conway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 11:57 EST by Michael Schwendt
Modified: 2009-01-23 21:41 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 22:16:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-12-04 11:57:44 EST
One or more directories are not included within this
package and/or its sub-packages:

=> rhm-0.2.2632-1.fc10.i386 (rawhide-development-i386)
/usr/lib/qpid
/usr/lib/qpid/daemon

[...]

Further information:

https://fedoraproject.org/wiki/Packaging/ReviewGuidelines

MUST: A package must own all directories that it creates. If it does not
create a directory that it uses, then it should require a package which
does create that directory.

https://fedoraproject.org/wiki/Packaging/Guidelines#FileAndDirectoryOwnership
https://fedoraproject.org/wiki/Packaging/UnownedDirectories
Comment 1 Jose Pedro Oliveira 2009-01-07 20:36:09 EST
This isn't exactly a rhm problem. The problem lies in the qpidc specfile, and more precisely in the generated qpidd package:

  * is owns the %{_libdir}/qpidd directory (which appears to be unused)

  * it should own the directories %{_libdir}/qpid and  
    %{_libdir}/qpid/daemon  instead

/jpo
Comment 2 Michael Schwendt 2009-01-08 06:25:05 EST
Seems plausible. Reassiging.   [A lot of these tickets have been filed semi-automatically without taking a deep look under the hood.]
Comment 3 Fedora Update System 2009-01-21 11:54:28 EST
qpidc-0.4.734452-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/qpidc-0.4.734452-2.fc10
Comment 4 Fedora Update System 2009-01-21 11:54:31 EST
qpidc-0.4.734452-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/qpidc-0.4.734452-2.fc9
Comment 5 Jose Pedro Oliveira 2009-01-22 22:16:51 EST

*** This bug has been marked as a duplicate of bug 474614 ***
Comment 6 Fedora Update System 2009-01-23 21:33:34 EST
qpidc-0.4.734452-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2009-01-23 21:41:55 EST
qpidc-0.4.734452-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.