Bug 474628 - setterm -blank no longer works as documented
setterm -blank no longer works as documented
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: util-linux-ng (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 13:00 EST by Jason Tibbitts
Modified: 2009-06-19 09:38 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.14.1-3.3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-19 09:38:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Tibbitts 2008-12-04 13:00:15 EST
I know this is trivial, but "setterm -blank" used to disable blanking and has been in rc.local on all of my machines since RHL-6 or so.  Upon installing a Fedora 10 machine I found that it no longer works.  Instead of disabling screen blanking, it prints a '0' to the console but otherwise does nothing.  The '0' doesn't seem to change even if setterm -blank 60 is run previously, so it isn't doing something like returning the current blanking time.

"setterm -blank 0" works as expected, of course.
Comment 1 Karel Zak 2008-12-04 14:48:08 EST
We did a small change in the blank command to improve it for blind people. Unfortunately, the change was not properly documented in the man page.

 - blank force   ... keeps screen blank even if a key is pressed.
 - blank poke    ... unblank (returns which vt was blanked)
 - blank         ... (default without options) returns blank status  <<<!
 - blank 0-60    ... set delay in minutes

I'll fix the man page. Thanks for your report!
Comment 2 Karel Zak 2009-03-19 10:12:45 EDT
The man page fixed in rawhide (F-11).
Comment 3 Fedora Update System 2009-06-01 08:08:19 EDT
util-linux-ng-2.14.1-3.3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/util-linux-ng-2.14.1-3.3.fc10
Comment 4 Fedora Update System 2009-06-02 10:29:44 EDT
util-linux-ng-2.14.1-3.3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update util-linux-ng'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-5775
Comment 5 Fedora Update System 2009-06-19 09:38:41 EDT
util-linux-ng-2.14.1-3.3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.