Bug 474630 - no updates-newkey in F10
no updates-newkey in F10
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: revisor (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 13:03 EST by David Juran
Modified: 2008-12-05 07:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 22:00:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2008-12-04 13:03:30 EST
Description of problem:
The configuration files for Fedora 10 e.g. /etc/revisor/conf.d/revisor-f10-i386.conf contains references to updates-newkey i.e. sections like 

[updates-newkey]
name=Fedora 10 - i386 - Updates Newkey
baseurl=http://localrepo/fedora/updates/10/i386.newkey/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f10.newkey&arch=i386
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-8-and-10-i386

Since such directories (fortunately) don't exit, revisor fails with the rather cryptic message:

Fatal Error: Unable to retrieve software information.
        This could be caused by one of the following:
         - not having a network connection available,
         - Server refusing connections,
         - Using a mirror that isn't fully synchronized,
         - Misconfigured repositories.


Version-Release number of selected component (if applicable):
revisor-2.1.3-1.fc10

How reproducible:
Every time

Steps to Reproduce:
1. revisor --kickstart=/usr/share/spin-kickstarts/fedora-livedvd-games.ks  --mode=f10-i386 --live-optical
Comment 1 Jeroen van Meeuwen 2008-12-04 22:00:40 EST
Fixed in GIT: http://git.fedorahosted.org/git/?p=revisor;a=commitdiff;h=64935726f496ba38507a852174873f97e75b5193

Pending next release
Comment 2 Jeroen van Meeuwen 2008-12-04 22:01:33 EST
(In reply to comment #0)
> Since such directories (fortunately) don't exit, revisor fails with the rather
> cryptic message:
> 
> Fatal Error: Unable to retrieve software information.
>         This could be caused by one of the following:
>          - not having a network connection available,
>          - Server refusing connections,
>          - Using a mirror that isn't fully synchronized,
>          - Misconfigured repositories.
> 
> 

FWIW, any recommendations on the error message?
Comment 3 David Juran 2008-12-05 07:42:28 EST
In hindsight, the error message _was_ quite accurate (i.e Misconfigured repositories)  But it got me checking and re-checking my proxy configuration and it took a tcpdump for me to realise that it was actually the repository that was wrong. Maybe if revisor could output the yum error verbatim, at least when upping the debug level, it would become clearer.

Nevertheless, I guess this is a discussion better suited for a mailing list, thanks for fixing the repository issue.

Note You need to log in before you can comment on or make changes to this bug.