Bug 474635 - Metacity: No command 33 has been defined
Metacity: No command 33 has been defined
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 13:23 EST by Christopher D. Stover
Modified: 2014-06-18 05:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 08:29:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Re-add some missing defaults (1.63 KB, patch)
2008-12-24 10:44 EST, Yanko Kaneti
no flags Details | Diff

  None (edit)
Description Christopher D. Stover 2008-12-04 13:23:03 EST
Description of problem: Hitting the 'Print Screen' key on my keyboard results in a Metacity popup box that says "No command 33 has been defined."


Version-Release number of selected component (if applicable):
metacity-2.25.34-1.fc11
also occurs in metacity-2.25.8-4.fc11

How reproducible:
every time

Actual results:
pop up box with warning

Expected results:
should take me to the screen shot window
Comment 1 Tom "spot" Callaway 2008-12-22 12:30:58 EST
Annoyingly, I also get this with the "up" arrow on my Lenovo T60.

metacity-2.25.55-1.fc11.x86_64
Comment 2 Tom "spot" Callaway 2008-12-22 14:56:04 EST
(In reply to comment #1)
> Annoyingly, I also get this with the "up" arrow on my Lenovo T60.
> 
> metacity-2.25.55-1.fc11.x86_64

Reverting to metacity-2.25.34-1.fc11 fixes it.
Comment 3 John Ellson 2008-12-22 18:13:22 EST
Reverting to metacity-2.25.34-1.fc11.x86_64 didn't work for me.


All my "inverted T" arrow keys are broken, but just "Up" opens the "No command 33 ..." message.
Comment 4 Tom "spot" Callaway 2008-12-22 22:09:27 EST
(In reply to comment #3)
> Reverting to metacity-2.25.34-1.fc11.x86_64 didn't work for me.
> 
> 
> All my "inverted T" arrow keys are broken, but just "Up" opens the "No command
> 33 ..." message.

I had to kill the running metacity process after doing the rpm downgrade, to start the old one.
Comment 5 John Ellson 2008-12-22 22:55:24 EST
Weird.   I tried again:  After downgrading the rpm and leaving X I looked for any running metacity processes, there weren't any.  To be sure, I rebooted, but
metacity-2.25.34-1.fc11.x86_64 still gives me "No command 33...." for "Up" arrow.
As does metacity-2.25.55-1.fc11.x86_64.

I have a Logitech USB keyboard which is being recognized as a "BTC USB Multimedia Keyboard"   Does that sound right?

(II) XINPUT: Adding extended input device "BTC USB Multimedia Keyboard" (type: K
EYBOARD)
(**) Option "xkb_rules" "evdev"
(**) BTC USB Multimedia Keyboard: xkb_rules: "evdev"
(**) Option "xkb_model" "pc105+inet"
Comment 6 John Ellson 2008-12-22 22:57:57 EST
My arrow keys are being recognized normally by bash in a ctrl-alt-2 console.
Comment 7 John Ellson 2008-12-24 10:24:27 EST
Seems to be fixed today!?!  Still using metacity-2.25.55-1.fc11.x86_64
Perhaps this was fixed by the Xorg-x11-server updates?
Comment 8 Yanko Kaneti 2008-12-24 10:44:55 EST
Created attachment 327820 [details]
Re-add some missing defaults

The xorg update would have fixed the up arrow problem. I don't think the command 33 issue here is related. I think this patch will fix it, at least temporarily until upstream figures what to do about it.
Comment 9 Bug Zapper 2009-06-09 06:07:35 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Yanko Kaneti 2009-09-10 08:29:48 EDT
The missing defaults bug that was the problem here was fixed sometime between 2.25.55 and 2.25.89. that is before the Fedora 11 release which has 2.26.0. Closing.

Note You need to log in before you can comment on or make changes to this bug.