Bug 474645 - network scripts don't set interface MTU when bridging is enabled
network scripts don't set interface MTU when bridging is enabled
Status: CLOSED DUPLICATE of bug 463014
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 13:50 EST by Eduardo Habkost
Modified: 2008-12-04 13:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 13:58:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduardo Habkost 2008-12-04 13:50:14 EST
Description of problem:
When an interface is configured to be attached to a bridge, the MTU= line on ifcfg-ethX is ignored by the network setup scripts.


Version-Release number of selected component (if applicable):
initscripts-8.45.19.1.EL-1

How reproducible:
Always.


Steps to Reproduce:
# cat ifcfg-eth0
# Broadcom Corporation NetXtreme BCM5752 Gigabit Ethernet PCI Express
DEVICE=eth0
BOOTPROTO=none
HWADDR=00:19:B9:45:C2:CA
ONBOOT=yes
BRIDGE=br0
MTU=9000
# cat ifcfg-br0
TYPE=Bridge
DEVICE=br0
BOOTPROTO=dhcp
ONBOOT=yes
# ifup eth0
# ifup br0
Determining IP information for br0... done.
# ip link show eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:19:b9:45:c2:ca brd ff:ff:ff:ff:ff:ff


Actual results:
eth0 MTU kept as 1500.


Expected results:
eth0 MTU to be set as specified on ifcfg-eth0.

Additional info:
Bridging configuration is common on virtualization setups, and increasing the  MTU on network interfaces that support that is a recommended way of improving network performance. Being able to configure the MTU of interfaces attached to bridges is important on those cases.

Two patches from the upstream Fedora initscripts fix this issue (but they involve bonding also, so a simpler fix is possible for mtu/bridging setup only).
http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=15850b0
http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=f9cfaa36
Comment 1 Bill Nottingham 2008-12-04 13:58:07 EST

*** This bug has been marked as a duplicate of bug 463014 ***

Note You need to log in before you can comment on or make changes to this bug.