Bug 474665 - very dark output from Logitech QuickCam Chat webcam
very dark output from Logitech QuickCam Chat webcam
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 14:49 EST by Vladimir Kotal
Modified: 2008-12-09 03:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 03:37:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full dmesg output (30.04 KB, text/plain)
2008-12-04 14:49 EST, Vladimir Kotal
no flags Details
camera output taken by cheese (3.64 KB, image/jpeg)
2008-12-04 14:51 EST, Vladimir Kotal
no flags Details

  None (edit)
Description Vladimir Kotal 2008-12-04 14:49:52 EST
Created attachment 325734 [details]
full dmesg output

Description of problem:

Logitech QuickCam gives very dark image/video.

Version-Release number of selected component (if applicable):

The HW (lsusb excerpt) is:

Bus 007 Device 002: ID 046d:092e Logitech, Inc. QuickCam Chat

The kernel is:

RPM: kernel-2.6.27.5-117.fc10.i686

uname -a: Linux erazim.local.lab.devnull.cz 2.6.27.5-117.fc10.i686 #1 SMP Tue Nov 18 12:19:59 EST 2008 i686 athlon i386 GNU/Linux

How reproducible:

launch cheese and watch the image.

Actual results:

the image/video is too dark.

Expected results:

the image/video should be usable.

Additional info:

dmesg output is attached.
Comment 1 Vladimir Kotal 2008-12-04 14:51:09 EST
Created attachment 325736 [details]
camera output taken by cheese

and no, I am not sitting in a dark room :)
Comment 2 Hans de Goede 2008-12-09 03:37:14 EST
(In reply to comment #1)
> and no, I am not sitting in a dark room :)

Well you are, but that is all relative. Atleast you are not sitting in a room in daylight on a bright sunny day. Artificial light is much darker then daylight, but the human eye is very good in compensating for this (unlike webcams).

The problem is that you're cam does not have autoexposure support in the driver and thus will not automatically adjust to lightning conditions.

You can however control the exposure setting manual to fix the image. Install v4l2ucp (as root do: "yum install v4l2ucp") and then run v4l2ucp.

This will give you an exposure slider, upping the exposure setting should fix your issue (at the cost of framerate, so the image might get a bit jerky).

I'm planning on adding software autoexposure code to libv4l sometime in the future.

Note You need to log in before you can comment on or make changes to this bug.