Bug 474671 - [LTC 5.4 FEAT] Pre/post install hooks needed in Kernel module packaging infrastructure. [201074]
[LTC 5.4 FEAT] Pre/post install hooks needed in Kernel module packaging infra...
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: driver-update-program (Show other bugs)
5.4
All All
high Severity high
: beta
: 5.4
Assigned To: Jon Masters
BaseOS QE
: FutureFeature, OtherQA
Depends On:
Blocks: 445204 483784
  Show dependency treegraph
 
Reported: 2008-12-04 15:00 EST by IBM Bug Proxy
Modified: 2009-06-20 04:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 16:27:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 50272 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-12-04 15:00:46 EST
=Comment: #1=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:     [201074]
a. Name of Feature:     Pre/post install hooks needed in Kernel module
packaging infrastructure.
b. Feature Description
Kernel module packaging standard supported by distro do not allow the module
packager to execute special code as part of pre and post installation of the
rpm.  This is a big handicap especially for packaging storage drivers.  There
are instances where the driver in the package needs to be added to initrd.  And
to add the driver in initrd the distro driver update/build process needs to add
information in configuration files as part of post install of the rpm.

6.0 feature request: https://bugzilla.redhat.com/show_bug.cgi?id=463547
5.3 feature request (closed): https://bugzilla.redhat.com/show_bug.cgi?id=253219

2. Feature Details:
Sponsor:        xSeries
Architectures:
x86
x86_64

Arch Specificity: Purely Common Code
Affects Kernel Modules: Yes
Delivery Mechanism: 
Category:       xSeries
Request Type:   Driver - Feature from Vendor
d. Upstream Acceptance: Submitted
Sponsor Priority        1
f. Severity: High
IBM Confidential:       no
Code Contribution:      3rd party code
g. Component Version Target:    Distro deliverable.

3. Business Case
System-x's UxSP uses the distro driver update technology to install drivers.
But unfortunately we have to build ugly hacks to get the driver into the
initrd, because of lack of this support.  E.g., the emulex driver has 5
different modules, one of which is not shipped in the distro. So when the
emulex driver is packaged, the one driver is not added to the initrd.  Also,
some drivers distributed in distro have different names than those provided by
the IHV. Hence without the support requested above there is no easy way to
populate the initrd with the appropriate driver. Apart from the above there can
be  creative ways of using the pre/post installation hooks in the driver update
process.

Benefits
Removes some of the blocks from wide spread use of distro driver update
technology.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Monte Knutson, mknutson@us.ibm.com, 877-894-1495

Technical contact(s):
Kevin Stansell, kstansel@us.ibm.com
Ramachandra Pai, pair@us.ibm.com
Comment 1 John Jarvis 2008-12-23 15:52:15 EST
IBM is signed up to test and provide feedback.
Comment 2 Jon Masters 2009-03-17 16:27:10 EDT
I will discuss this with Ram in two weeks and agree an implementation for post RHEL5.4. At this time I don't have sufficient buy-in from other stakeholders to support arbitrary hooks.

Note You need to log in before you can comment on or make changes to this bug.