Bug 474678 - Watch logs does not work in web interface when logged in using SSL
Watch logs does not work in web interface when logged in using SSL
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
https://koji.fedoraproject.org/koji
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 15:28 EST by Iain Arnell
Modified: 2013-01-09 23:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 12:51:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix watchlogs.js (634 bytes, patch)
2008-12-04 15:28 EST, Iain Arnell
no flags Details | Diff

  None (edit)
Description Iain Arnell 2008-12-04 15:28:49 EST
Created attachment 325744 [details]
patch to fix watchlogs.js

Description of problem:

when logged into koji web interface using SSL, the "Watch logs" feature doesn't work (at least, not when using Firefox 3).


Version-Release number of selected component (if applicable):

Whatever's running on koji.fedoraproject.org right now.


Steps to Reproduce:
1. Logon to https://koji.fedoraproject.org and select "Tasks" tab
2. Click on an active buildArch task
3. Click on the "Watch logs" link at the bottom of the page
  
Actual results:

Firefox error pops up:

Error checking if task was finished:
RequestOpenFailed [module 'urllib' version: 1.1.4]:
  Opening of HTTP Request failed.

[Exception... "Access to restricted URI denied" code: "1012" nsresult: "0x805303f4 (NS_ERROR_DOM_BAD_URI)" location: "https://koji.fedoraproject.org/koji-static/js/jsolait/init.js Line: 255"]


Expected results:

Watch the build logs scroll.


Additional info:

The problem is that watchlogs.js is trying to access unsecure 'http://'+window.location.hostname from a page loaded as https://koji.fedoraproject.org.  Looks like Firefox won't allow this.

Simple fix is to access window.location.protocol+'//'+window.location.hostname instead - see attachment for details.
Comment 1 Dennis Gilmore 2009-03-19 12:51:03 EDT
fixed in the current koji deployment

Note You need to log in before you can comment on or make changes to this bug.