Bug 474680 - Accessibility support broken in firefox
Accessibility support broken in firefox
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 15:32 EST by Omair Majid
Modified: 2009-01-06 09:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-06 09:18:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 476491 None None None Never
Mozilla Foundation 460926 None None None Never
Novell 457728 None None None Never

  None (edit)
Description Omair Majid 2008-12-04 15:32:53 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111217 Fedora/3.0.4-1.fc10 Firefox/3.0.4

When examining firefox through accerciser (http://live.gnome.org/Accerciser), only two frames (and nothing else) is visible. Accerciser cant see any menus, buttons, text or anything else in firefox. 

Accerciser can see accessible components in other applications, so it doesnt look like accerciser's fault. 

Reproducible: Always

Steps to Reproduce:
1. Enable accessibility support in gnome
2. open firefox
3. use accerciser to take a look at firefox
Actual Results:  
Only two components under firefox (frames)

Expected Results:  
All the accessible components should be visible
Comment 1 Brad Taylor 2008-12-17 09:49:48 EST
OpenSUSE 11.1 also suffers from this issue, and we're tracking it upstream in gtk+ at http://bugzilla.gnome.org/show_bug.cgi?id=564751.
Comment 2 Matěj Cepl 2008-12-20 18:47:33 EST
Reassigning, but not sure with the target -- maybe just Gtk+? (Matthias?)

Brad, what is the number of OpenSUSE bug?
Comment 3 Brad Taylor 2008-12-20 19:29:49 EST
We're tracking it as https://bugzilla.novell.com/show_bug.cgi?id=457728.
Comment 4 Matěj Cepl 2008-12-20 19:49:28 EST
(In reply to comment #3)
> We're tracking it as https://bugzilla.novell.com/show_bug.cgi?id=457728.

Thanks
Comment 5 Matthias Clasen 2008-12-21 01:41:36 EST
> Reassigning, but not sure with the target -- maybe just Gtk+? (Matthias?)

I have nothing to do with firefox accessibility. They do their own thing
Comment 6 Matěj Cepl 2008-12-22 04:03:52 EST
(In reply to comment #5)
> > Reassigning, but not sure with the target -- maybe just Gtk+? (Matthias?)
> 
> I have nothing to do with firefox accessibility. They do their own thing

Look at Novell bug, it seems to be more than just FF accessibility.
Comment 7 Matěj Cepl 2009-01-06 09:12:02 EST
According to https://bugzilla.novell.com/show_bug.cgi?id=457728#c11 the fix for this bug *is* in Firefox and that is in commit
http://hg.mozilla.org/mozilla-central/rev/59508a1ac7dc
Comment 8 Matěj Cepl 2009-01-06 09:18:38 EST
We believe that it is more appropriate to let this bug be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.